HDD waking up from sleep every hour

Since I updated my EX2 Ultra to MyCloud OS 5 both HDDs (WD Red 2TB) are spinning up every hour for no reason. No device on my network is trying to connect to the MyCloud, no entries for SAMBA in the Log at this times.

I am not using Cloud Connection, no Apps are installed. Only using the MyCloud with SAMBA. HDDs are in JBOD.

The log says * HD awake now! * or * HD standby now! *

It is annoying that the HDDs are spinning up without accessing any files.

2 Likes

Me too … I’ve got an EX4100 and PR4100 … they both wake up hourly then go back to sleep.

Firmware 5.04.114

2 Likes

Same here with EX2 Ultra.

Before updating the NAS would sleep and only wake up when I trying to access it. This was quite consistent behavior.

After the update, it takes more time to go to sleep and then keeps on waking up even when its not being accessed. This keeps the drives hot for the entire day and makes me wonder why the sleep option exists if its not functioning as expected.

WD needs to fix this in next update as this will shorten the disk lifespan due to constant spin up and spin downs, and due to constant 50C temperatures.

2 Likes

Same here. What it is doing?

Mark

I have done a system reset, the problem still exists. Also formatted one of the two disks and reconfigured it from scratch.

Annoying, especially when you are using the MyCloud as a backup drive as i do. Before the upgrade my disks were sleeping for days when not in use!

Thanks for reporting the issue.
We will be looking into it.

Same issue here. Before sleep was working well, now not at all. I’ve disabled all the functions, network services and cloud access but still no sleep for the unit

Im having the same issue i think. I turned off the logging running once per hour by editing the “/etc/nas/wdlog.ini” (PERF_STATUS) and “/usr/local/config/wdlog.conf” (STATUS). Also the “/usr/local/sbin/getAgreement.sh” and “/usr/local/sbin/wdLogUploader.sh” is read only so not able to do a chmod 000 on them. :confused: Tried doing a “mount -o remount,rw /” to remedy this but without luck. Maybe there’s a better way?

I believe it’s related to the new “Analytics opt-in” project which i opted out of but it’s still trying to upload data.

You can try checking your own logs (/var/log/user.log) for clues. mine looks like this:

Very frustrating. :thinking:

“getAgreement.sh” and “wdLogUploader.sh” is both at “/usr/local/sbin/” & “/usr/local/modules/localsbin/” (or pointing at each other). Both files are read-only.

Mentions “FOREGROUND_FLAG=”/tmp/wdloguploader_foreground" , “/tmp/upload_files” and “/etc/nas/wdlog.ini”.

The wdlog.ini seems relevant for the logging process so i deleted it but i ofcause made a copy first. haven’t got the patience today to edit or chmod the ini. maybe i’ll try blocking my local port 8003 as well.

Maybe im getting this because i’ve disabled/tweaked to much on an earlier firmware (restsdk-serverd?). Although i believe it’s still running a least “restsdk-server -minimal”. Not sure if im alone in getting these problems? Another thought maybe removing the “analytics” line completely from inside of config.xml?

CachePIP, cache and /tmp i haven’t investigated yet.

If it helps, I have noted much less “wake-sleep” activity when cloud access is disabled.

1 Like

I found that if you ssh into the my cloud and press the “tab” key twice you’ll get most of the configs listed.

Noteworthy are “wdlog” ,“log_conf”, “log_upload_freq.sh”, “hd_standby.sh” “hdparm”, “remote_access.sh”, “restsdk.sh”, “media_analytics.sh”.

Regarding hdparm i usually just run "sudo hdparm -B 127 /dev/sd* && sudo hdparm -S 120 /dev/sd* .127 meaning the hardrive is allowed to spin down and 120 meaning 10 minuttes to spindown.

Other tweaks are to disable “wdmcserverd”, “wdphotodbmergerd” among others. Commands may differ depending on my cloud models but most of the time it’s something like:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

chmod 644 /etc/init.d/wdmcserverd
chmod 644 /etc/init.d/wdphotodbmergerd

(the below finds and deletes the wdmc folders so think before you use! this site may edit some of the wierd characters out)
“find / -name .wdmc | wc -l” or “find . -type d -name ‘.wdmc’ -print0 | xargs -0t rm -rf” or “find . -name .wdmc -exec rm -rf {} ;”

update-rc.d netatalk disable
update-rc.d restsdk-serverd disable
update-rc.d samba disable
update-rc.d nfs-kernel-server disable
update-rc.d nfs-common disable
update-rc.d upnp_nas disable
update-rc.d mDNSResponder disable
update-rc.d mdadm disable
update-rc.d rpcbind disable
update-rc.d itunes disable
update-rc.d wdphotodbmergerd disable
​update-rd.d wdmcserverd disable
​update-rc.d twonky disable
​update-rc.d openvpn disable
​update-rc.d ssh enable
update-rc.d vsftpd enable
update-rc.d apache2 enable

The last part here is just copy and pasted so check what they all do before use them. :slight_smile:

Im just a beginner at linux so please check before using any of this.

1 Like

EX4100 4TB, 500GB used.
After taking 7 days indexing drive activity continues 24/7.
Now nearly 9 days of continuous drive activity. No sleep and no indication of what it is doing.
Unit had been working perfectly for 3+ years prior to OS5 update, entering and waking from Sleep as would be expected.

It’s seems i managed to tame to analytics/logs.

(the activity at the end is because of me typing in the commands in again to show the forum)

I still get those two sh files popping up from time to time in the user.log but not nearly as much as im used to. :slight_smile: set_pwm still were spinning my drives down (and up?) according to my hdparm/hd_standby.sh settings but after running the set_pwm clean (-c, -s, -e parameters not working?) it stopped spinning up after 10 minuttes all the time. :slight_smile: Ran “restsdk.sh stop” as well.

edit: Well at least i hope it’s fixed. i’ll check the log some more next night.

edit2: Also remember crontab -e let’s you edit a couple of things. like “random_chk_central”. i believe just remove the command by typing # in front of it or if that doesn´t work typing something like "0 5 31 2 * (31. feb. meaning never). That or type in “random_chk_central -d” (“Remove check wdlog central server”, this may just reset the check time so check your cron afterward.).

1 Like

Thought updating to 5.05.111 may fix the problem, but it doesn’t. Still hourly spin ups:

Will now try the workarounds from this thread.

Maybe i should consider buying a QNAP or Synology on BF and take the disks from the EX2 before WDs crappy firmware is damaging them completely. :confused:

No fix in 5.05.111 update. Seems like WD is not serious about this issue since there is no fix and no feedback from them.

Since the update, I have logged no wake sleep events. And now the unit does not go into standby at all. Sleep mode is disabled.

What happens if i will set the status inside the wdlog.conf file to “disabled”?
Or to increase the interval in the wdlog.ini file from 60 to 525600 (one year)?

1 Like

Please refer to this announcement for updates on the issues that users have reported : Update on My Cloud OS 5 feedback

I ended up deleting wdlog.ini (/etc/nas/), wdlog.conf (/usr/local/config/) & system.conf (/etc/) and i haven’t had anything wierd popping up in the user.log for days now (other than maybe cleanAlert.sh). Although my user.log only seem to show spinups/spindowns now for cifs login and i haven’t been running back and forth checking each hour by touching the cabinet, so i may be wrong and it’s still doing it although i think not. :slight_smile:

Stopped restsdk.sh (restsdk.sh stop) as well.

May not help you superschlundi but try it. Also sorry for hijacking your thread.

Edit: Remember to backup your files first (example. cp system.conf system.bak). remove file by using the “rm” command (example. rm wdlog.ini)

Edit 2: Perhaps there’s no need deleting all three files (maybe just # before the config lines) but just got tired of dancing around it. :smiley:

Edit 3: i’ll try adding the files back one by one and see when the sh issues come back. It’s seems like all the troubles come from the wdlog.ini.

These are the logs uploaded when i enabled everything again and agreed to share:

so maybe just remove those from the “declare” log items list (wdlog.ini)? wdLogUploader.sh mentions:

/usr/local/config/wdlog.conf
/etc/system.conf
/etc/nas/wdlog.ini

Im guessing these are important but im no wizard, just messing around. :slight_smile: Use vi to view the files i’ve mentioned earlier (example vi /etc/nas/wdlog.ini, vi /usr/local/sbin/wdLogUploader.sh and so on.).

Edit: 4. User.log seem to log my my own spinups/spindowns again around an hour after re-adding
the wdlog.ini file (mv wdlog.bak wdlog.ini).

Edit 5. I believe i was successful! :slight_smile: What i did was to put a # in front of the declare log list inside of the wdlog.ini file (vi /etc/nas/wdlog.ini) :

meaning:
#declare -a LOG_LIST_MyCOS=(‘analyticpublic.log’ ‘wdpublic.log’ ‘otaclient.log’ ‘nasAdmin.log’ ‘kern_upload.log’ ‘atop_upload.log’)

This is because wdLogUploader.sh (cd / first then vi usr/local/sbin/wdLogUploader.sh) writes:

checkLogFile()
{
if [ “{modelNumber}" == "sq" ]; then LOG_LIST=("{LOG_LIST_sq[@]}”)
else
# Use /etc/NAS_CFG/debug.xml to decide upload log list
debug_mode=/usr/sbin/getLogDebug.sh
if [ “{debug_mode}" == "1" ]; then LOG_LIST=("{LOG_LIST_MyCOS_DEV[@]}”)
else
LOG_LIST=("{LOG_LIST_MyCOS[@]}") fi fi FILE_NAME=(basename {ROTATED_FILE}) if [[ " {LOG_LIST[@]} " =~ " {FILE_NAME} " ]]; then if [ ! -z "{NO_APPEND}" ]; then
FILE_TO_UPLOAD={ROTATED_FILE} else FILE_TO_UPLOAD={ROTATED_FILE}.1
fi
#echo “checkLogFile: to upload {FILE_TO_UPLOAD}" >> /tmp/upload_files appendEOFInfo {FILE_TO_UPLOAD} >> {FILE_TO_UPLOAD} else unset FILE_TO_UPLOAD # if given log file not in the list do nothing #echo "checkLogFile: not in whitelist {FILE_TO_UPLOAD}” >> /tmp/upload_files
fi
}

And my debug.xml (vi /etc/NAS_CFG/debug.xml) say “0” (0). You can possibly keep the ‘kern_upload.log’ ‘atop_upload.log’ but i just went the simple route. Else my wdlog.ini is default and enabled also the wdlog.conf. I believe that’s default. restsdk.sh still disabled. Not sure how important it is.

I also deleted wd-alert-desc.db and wd-alert.db (/CacheVolume/.wd-alert) because the cleanAlert.sh (vi /usr/local/sbin/cleanAlert.sh) pointed to that location and i wanted the cleanAlert.sh error to stop.

If the spindown still is wierd try ‘set_pwm clean’.

The cifs messages im getting is just when i change ip by vpn or maybe boot at the pc as well. So it’s normal.

I hope this helps someone if not just ask. :v: I may be way off here. i’ll try giving it 24 hours now and hope the errors wont come back. :smiley: Sorry for the mess everybody. :shushing_face:

Edit: 6. alright so i got a these after 4 hours but after this not for 6 hours+…:

MyCloudPR4100 root: Rotated atop, atop_size=40607744 atop_upload_size=405504
MyCloudPR4100 getAgreement.sh: restsdk-serverd/restsdk-server not run. Get PIP 0 from cache
MyCloudPR4100 wdLogUploader.sh: getAgreement.sh: False
MyCloudPR4100 wdLogUploader: Current PIP_STATUS: false wdlog.conf STATUS: enabled

The first error rotated atop., im guesssing this either can be disabled by editing /etc/logrotate.conf, # in front of the wdlog.ini lines or the conflict is because my wdlog.ini/wdlog.conf still say enabled or because i # out the “atop_upload.log”. anyway i would love for the errors never to show up. Anyway once an hour seem not to be an issue anymore. But i mess to much with my pr4100, might not be an issue with yours.

Edit 7: the atop/sh errors came back at 23.59. “#” out the restsdk in logrotate.conf to see if that does anything. “#” out “MyCOS_DEV” didn’t change anything it seems but maybe if i “#” out the top "atop_upload.log from “LOG_LIST_sq” i at least remove one of the errors. alse it’s wdlog.ini again under “# PERFORMANCE LOGGING (atop)” but i don’t wan’t to break user logging if i can avoid it. Anyway im just talking to myself lol. :smiley:

I tried to disable but it still tried to upload with errors. Although i may have done something wrong. :slight_smile: Perhaps the interval value does something more useful or putting # infront of the lines related to the upload time.

Edit: That did it. :slight_smile: Look at my post above.

Edit: 2. it still comes with error on my pr4100 in intervals of 4-6 hours. im still trying to make it stop doing it. you could just remove the wdlog.ini but there’s a chance that user.log will break after some hours. I like being able to see if the drives spin up/down. Anyway im starting having problems remembering the tweaks i’ve done. hehe.

Anyway the drives doesn’t seem to spin up regardless of the errors, so it’s just me being anal. But check the log first to see what is going on and back it all up first.