HDD not recognized with WD TV Live

Hi,
I have had a 3TB drive hooked up to my WD live for over 3 years with no problems. Yesterday I decided to unplug it from the WDTV and hook it into my new laptop that is running W10. Figured it would be easier to transfer a couple of large files via USB vs LAN. Files transferred with no issues, but when plugged the drive into the WDTV, it would not recognize the drive. In fact, it starts to connect the drive, ie I see the message at the top stating its connecting the USB drive but after 4-5 seconds the message disappears and the flashing light is gone. Going into my local drive section and its not showing up. When I plug the drive in my laptop its recognized with no issues!!

I’ve done the following:

  1. checked the drive with scan disk-no errors found-no help
    2)Deleted the WDTV folder on the drive, maybe corrupted-no help
    3)Decided to just format the drive, NTFS, -no help
    4)Tried transfering a couple of files to another external drive I have using my laptop, then plugged that drive into the WDTV and no go either.

Also, I have two WDTV’s in the house, only one usually has drives connected to it while the other is just networked to the other, but even that one when I try plugging in the ext HD does the same thing…ie shows that the USB is connecting but then after 4-5 seconds it disappears… and isn’t recognized.

Is W10 doing something to the external while its plugged in that is different than W7? I was previously using a W7 machine and could easily plug a drive into my comp and back to the WDTV with no issues.

Thank you in advance for any suggestions!!

Hi, I have the newer version of the media player and I really have no problem with Windows 10 and transferring information to the external drive.

However, have you tried resetting the media player? Also you could check the permissions on the external drive, although Windows 10 shouldn’t change them, but worth to take a look at them.

@peed - Are you properly ejecting the drive from the computer before plugging it in to the WD TV? When you improperly eject a drive from a computer a flag doesn’t get set right and the WD TV may not recognize the device…

The article below applies to an ancient model WD TV, but try following the instructions and let us know if it resolves the issue:

I normally do not have issues in the past with disconnecting and connecting in the past but I have worked through that process to ensure that it wasn’t the case and I still have the same issue. I’ve reset the device to factory a few times and each time my other drive is recognized but not this one, which had been attached previously for the last 3 years. i’ve even tested the ports but pluging the other drive in both and each time the one drive is recognized but not the other.

i’ve formatted the drive and smart tested and its good. when I plug it in to a computer it connects no problem. only issue is that after the initial messaging popping up indicating that its attaching the USB drive it seems to stop after 4 second and no local drive is visible. I am truly stumped since the only thing I can think of is that is has something to do with 10 as another external drive i have, which was new is displaying the same issues. I’m afraid to try the other drive I had in case the same thing happens and I end up with three ext HDD that aren’t recognized by the WDTV. I thinking of downgrading the firmware as a next step. Currently formating it again on my wifes W8 machine to see if that makes a difference.

Well, it was definitely something with W10 as I just finished formating the ext hdd with my wifes W8 machine and put a file on it, ran a chkdsk and all came out good. Plugged it into WDTV and it recognized right away. Not sure what the issue is going to try to avoid transferring things directly through the w10 computer.