4TB WD no longer works

OK, short and sweet. I am at my wits ends and frustrated. If anyone has a solution I would love to hear it. Here is the issue:

Been using a 4TB WD external HDD plugged into the player since December 2014. It’s not nearly full but it has the bulk of ALL my movies and videos. Backing it up to another source is not an option right now so I cannot reformat the drive.

I EJECTED the HDD first then unplugged it from the WD TV Live SMP as I have done many times before with no issues.

Plugged it into my desktop PC running Windows 10 Home (as many times before)…no issues. Once done I plugged the HDD back into the WD TV Live SMP (I should mention that I am using a powered Belkin USB hub with another WD HDD plugged into it. Both HDDs have their own power source too).

I start the SMP up, it scans and when the light stops, I now see only the 2TB HDD. No matter what I do, only the 2TB HDD shows up, not the 4TB. Things I have tried:

  • Unplugged the Belkin hub. 
  • Plugged the 4TB direct into both USB ports on the SMP
  • Tested and ensured 4TB and all files are not corrupt
  • Plugged the 4TB into the older WD TV Live Plus - SAME RESULTS!
  • Updated SMP firmware, rolled back, etc.
  • Checked for hidden files and folders on 4TB - none found. .wd_tv, $recycle.bin and recycler hidden folders ARE NOT PRESENT, same issue.

Bottom line is this - all of a sudden the 4TB is not recognized by either one of my WD TV media players otherwise it seems totally fine! No changes were made to 4TB other than adding a video file (which is not corrupt). PLEASE HELP!

Hi, you didn’t say if you used the “Safely remove hardware” function on the PC. Did you? It’s like the eject function on the WDTV but for your PC. If you just pull out the USB cable from the computer without first ejecting the drive then it can cause problems. Try this anyway. Plug the external drive back into your PC. Run an error check, either by using chkdsk /f from a dos prompt, or right click on drive in windows explorer --> tools–>Check–>Scan and Repair drive. It will most likely say no errors found, but in my experience that will reset any error flags on the drive. Now use the “Safely remove hardware” function and don’t remove the usb cable until you get the “safe to remove hardware” message. Good luck.

Sorry for the late response. Yes, I use the eject method every time. I performed the scan, all went well but the drive still does not show up on the WD SMP. :cry: and :angry:  At least all of my media is still intact and can be transferred to another storage device such as a USB stick or another hard drive but of course with over 1.5 TB of media, this is time consuming and frustrating. At minimum, I will have to access the drive by connecting it to my desktop and possibly streaming it that way, use my Chromecast or find some other quick way of accessing and playing from the external hard drive. Thanks for your help.

i am having the same issue as you. I had 3tb drive plugged in for the last 3 years and decided to attach to to my new w10 machine for transfer and when I tried to reconnect it I could not get WDTV to recognize the drive although windows has no problems with the drive. i scanned it, formated it and reset the WDTV an still can not get it to recognize.

did you ever figure out a sokution?

No, the only thing I can think of at this time is to contact WD for a solution. I appreciate you trying to find a solution as well and sorry you have to experience this but it’s kind of comforting to know I’m not the only one with this issue.

For me the solution was to plug the hd into my other w8 machine and reformat the drive, chkdsk, etc. transferred a couple of files and plugged it in to the wd tv and it found it right away. Not sure what the issue is but for now it’s working. I’m going to do some testing with another ext hdd I have to see if it happens again

Thanks. I may have to bite the bullet and transfer my media from the 4TB to multiple HDDs and follow your procedure. It ■■■■■ because I have just over 1 TB of files to move so that’s taking extra minutes but better than having to move 3 or more TBs of files! I will try that once I get another HDD which I conveniently already ordered from Amazon and should be here by Wednesday.

Before doing any transfers/formatting I would recommend that you attack the drive to a non w10 machine and do a scan disk, etc and then try attaching it to the wd box. For me I think that would have solved it but I just assume it was soemthing with the drive and went right for the format while doing it all in w10. It was only after when I had a clean formatted drive and it still wasn’t recognized that I tried a non w10 computer

Thanks for the tip! I suspected that W10 may be the culprit after seeing all my files intact and the drive functioning but never thought about performing the chkdsk using a non W10 PC. Funny, I just received my new HDD in the mail early today but I’ll try your tip first to see if that works.

I had the exact same issue. Been going nuts trying to figure it out and then saw this post. My 3TB Seagate hard drive just stopped being recognized. The WD Live Hub would recognize it for a second when it was plugged in but then it would disappear and not show up under the drives section. I did all the things that have been suggested elsewhere short of reformatting the entire drive. My blueray dvd player can read all the files on this drive. So the windows 10 suggestion had merit as I had recently added new files to this drive from a Win10 computer. I have two other external drives (4TB and 1TB) which have not yet been coupled with a win10 computer. Sure enough, when I connect those to the WD Live Hub it recognizes the drives and all the content on them. So there is something about Win10 that is conflicting with how the Live Hub interacts. With no new firmware from WD, I would love to hear other suggestions. As for using a computer without win10 - I’m out of luck as I upgraded all mine to win10.

Yeah, I almost upgraded my last win7 laptop to win10 but it was a bit much for a 10 year old laptop . I’m trying the HDD chkdsk now on it and will report my results when it finishes.

I can confirm that the issue is tied to Windows 10. I took my 3TB Seagate HD and ran a check disk using a Windows 7 machine. After completion, the drive was recognized by the WD Live Hub.

Given that WD does not seem to be posting any patches/firmware updates we can only hope that someone can figure out what Win 10 is doing to the file structure.

So, that poses a challenge as I had to borrow a Win 7 machine to test this out. For now, any future transfers to this HD will be done over my network (plugging it into the router) so that I can add stuff to it wirelessly.

Yes, I used my old WIN7 laptop to run the CHKDSK on the drive. I didn’t have to transfer any media or reformat the drive (thank God). Once it was completed, the WD TV recognized it and all of my media was there! Thanks for the tip Peed!

Updating this post in case others find this in a search for a similar problem.

Now that Win 10 is pretty well established on a whim I tried other versions of chkdisk to see if I could still load my hard drive from a win 10 pc. I had a 3TB Seagate drive and the WD TV Live Hub only recognized a movie file if it was in the root folder. All other subfolders were “not there”.
I downloaded this version of chkdisk, http://www.majorgeeks.com/files/details/checkdisk.html and ran it on the drive before hooking up to the WD. This worked and now all subfolders were found and indexed.
There is something about Win10 and the drive interface that the OLD firmware on the WD does not recognize. Running this other chkdisk utility is a easy fix.