WDTV Live Hub - Lost access to usb drives

For a number of years I’ve had 2 3tb drives connected for storage of movies and stuff. A few days ago, after adding another 2 movies to a drive the WD TV Live Hub only recognized 60 of the 210 movies on the drive. After trying a number of things the WD stopped recognizing the drive at all. Then I tried resetting the device and now it won’t recognize either of the drives. to be certain the drives are still ok, I connected them to my PC and yep the files are there and I can see them on my PC. This morning I once again tried the reset option and still nothing.

ARGHHHH. What can I do to get this foolish device to recognize the drives again?


Have you tried replacing the USB cable? and also deleting the “.wd_tv” folder from the drive?

Delete the .wd_tv folder from which drive? Haven’t tried a new cable yet.

Every time the WDTV accesses any drive it writes to a hidden datbase file on the drive called .wd_tv. Yhis file can get corrupted and it needs to be deleted so a new one can becreated when drive is reattached to WDTV Thw files on the drive will be reread and names added to the new .wd_tv file.

This needs to be done on the drive when it is attached to PC so the hidden file can be seen, so Windows must be configured to show hidden files. If you need to do this, goggle for how.

Thanks. I did remove the wd_tv folder and that fixed part of the issue.
It now recognizes one of the drives but not the other.

It does show some of the folders from that drive in “usb_sync” but not the
biggest one (about 2.5+ tb in the file but only 60+ gb left on the USB_SYNC). Do I need to unsync that and if so, how?

Sorry, I know nothing about usb_sync, it’s a new term to me.