Having trouble backing up to time machine


So I bought the WD MyCloud, and I love it on Windows, it’s so easy to use as a mapped drive espically with Plex. My issue is with Mac. So my partner has a MacBook Pro, and wants to backup to the WD. I set the WD Drive as the Time Machine backup drive, and it started. It got to about 5GB and it froze, I do it multiple times (each time deleting what was backed up, and i’ve even reset the defaults a couple of times incase something was changed). Sometimes it gets up to 5GB, othertimes 64MB, it’s really unreliable, and once it stops it’s not getting back up.

I’ve tried turning off wireless hoping when it comes back up the backup would continue, i’ve had it plugged in to the router via Ethernet, nothing is helping. I also tried with another manufacter and got almost identical results.

So I resorted to Google and saw all this stuff about making sure it’s the same format (OSXJournaled). Now if this was windows i’m sure this would be easy. Map the drive, select and format. Mapping a drive in osx makes it selectable, but you can’t use it as a local harddrive (ie, can’t format it in disk utility), and I can’t see anywhere to format it to mac osx format on the WebUI.

So: How can I format the WD to OSXJournaled

On another note i’ve plugged a 3TB external drive into the WD and it sees it in Windows as a folder of \WDMYCLOUD\ (which is awesome BTW). However in the WebUI it has a predefined TimeMachineBackup folder in \WDMYCLOUD\ which Time Machine picks up automatically. On that note, I could plug the external directly in to the mac and format it as OSXJournaled, plug it back in to the \WDMYCLOUD, and use the external as the backup drive. However as stated, it seems I can’t change the directory from what WD have defined, and if I can, please share…

Also, I know that the WD has a USB port, but can that be used Male to Male with a computer, because if so I might be able to see it as a local and format it that way. I’ve never done that (and don’t have a M-M USB, but if it will work i’ll **bleep** as **bleep** get one.

Let me know what you think, and if there’s another solution, please let me know.

Thanks in advance,


Hi kurtbarker, it is not possible or needed to change the format of the My Cloud. Have you tried transferring files manually to the My Cloud from the Mac? Also be sure you have the latest My Cloud firmware update installed. 

Firmware Release 4.00.01


You can also try following some of the troubleshooting steps on the link below.


I have tried Time Machine Backup with all our Macs. No success.

This piece of hardware is proving too hard to use. While having a good knowledge of Macs the use of the MyCloud requires a totally different focus than most Mac software.

It will be going back if I don’t get the hang of it today. My wife just looked at it dumbfounded. Far too much fiddling about to use it.

Pity as it had potential. Nowhere near as easy as promoted.