Having all sorts of problems with 1TB My Book Live

Hi all… nice to see a bustling community, I just hope someone can help me out with a problem I’m experiencing.

I set up another My Book Live on my partners network, all went well, but I’m having all sorts of problems with mine.  Basically, my setup is an iMac, wirelessly connected to a Billion 7404VNPX router (802.11n & Gigabit) with the MBL hardwired to the router.  (While not really relevant, my partners setup is a Mac Book Pro, same router, extact same setup, i.e. wireless to router, MBL connected to router.  There didn’t seem to be any problems at their end). 

It all started with problems trying to update the firmware.  I was getting all sorts of Communication errors (pointing me to KB 5657), so I ended up setting a static IP address, and that seemed to resolve the FW problem, and I’m know runnig the latest FW on my MBL.

The issues I’m currently having are getting the data onto the drive.  To try and solve the problem, I’ve currently disabled Twonky, iTunes & Remote Access as all I want is a network drive with my Movies/TV shows stored, but linked to my iTunes library.  Copying 180+GB across the wireless network was going to be painful, so I connected the MBL directly to the ethernet port on my iMac.  I could happily browse the UI, and all the mounts appeared as they should.  I used the direct connection on my partners drive to copy data, and I’m pretty sure 20GB of data only took half an hour (if that) to transfer to the drive, so I was expecting it might take somewhere about 3-3.5 hours to copy the data I had.  When I started copying the data, Finder told me it was going to take in the region of 10 to 11 hours.  So I went to bed, and left it copying.  This morning, I woke to find about 150GB copied to the drive, and a Finder error -50 message on the screen.  I’ve spent the whole day trying to copy the rest of the data to the drive with no luck.  I selected a 6GB folder (24 files), and every time I’ve tried to copy across, I get the same Finder error -50 after between 2 & 3GB has been copied.   The green light on the front continues to blink, I lose ssh access (broken pipe), and the UI dies.  The drive appears to be doing something for a while after that as it continues to make noises as if the drive is being accessed.  I’ve been leaving it for an hour or so after the failed copies, and it’s still dead to external access, so I’ve been pulling the plug, and rebooting the drive, and it comes back up ready to try again.

I’m concerned about the copy speed to begin with.  I’m certain the copy of data over at my partners place was pretty fast, as I mentioned, yet 180GB in 10 hours seems much longer.  The 6GB folder I was copying over was estimating about 30 minutes, but it never ended so I can’t be sure.  

 All lights and network utils show that the drive is connected at 1000, so the connection seems good.  Both iMac & MBL are set for DHCP network (however, I’ve tried this with static IP addresses too). 

I’ve tried factory resets, running diagnostics, and just about everything else I can think of, but I’m at a complete loss.  Does it sound like there may be a problem with the drive?  Is it worth returning it to the store and getting a replacement, or does anyone else have any suggestions?  I’ve trawled through the forums (and google) and have been in and checked the disk usage (from various topics about log files expanding), yet a df -h on the MBL shows the log drive to be  only about 20% used.

Any help/advice would be much appreciated.


hmm… seems a short diagnostic test worked ok, but I ust tried a full diagnostic test and I received a self test failed message.  Ok, so I’m leaning toward a possible screwed device?

Having said I just received the self test error, it appears the exact same thing has happened to the drive as when I try and copy data to it… it’s just died.  The green light is flashing, but UI & ssh access is unavailable.

Is it possible the data being sent via the network cable is not being ‘processed’ quickly enough by the drive, for some strange reason, and it’s being flooded, bringing it to a grinding halt?  I’m not sure how else to explain it, but it does seem like the drive isn’t able to ‘keep up’ with the flow of data, and it decides to shut itself down.

Would it be worth trying to FTP the latest FW up to the drive, and reapplying it in case something didn’t take correctly when I was having all the dramas trying to get the FW updated originally?   

After leaving the MBL off all night, I did a manual FW update using a method from another thread (i.e. uploading by FTP, and then running the update from file script).  This seemed to go through ok.

I’ve tried to upload a 6GB folder via FTP to the drive. The upload started at about 5 MB/s, and over the last 2GB it’s got slower and slower until the speed is now showing as 1.2 MB/s, but there doesn’t seem to be any more data writing out to the MBL.  It’s like the data is trying to be sent to the MBL, but it doesn’t want it!  :^)

Does anyone have any idea at all??? 

Is there any possibility you have a bad ethernet cable?  The cable provided with the drive is a shielded cable (although you should be able to use any cat 5e or greater ethernet cable (shielded or unshielded).

On my gig network - I can copy an 8 gig dual layer DVD image file in 3 minutes to the MBL - and that is through 2 layers of switches.  However my tiny 22 gig iTunes folder take about 20-25 minutes to copy.  Because of the AFP/SMB protocol being used - the performance is much slower when copying a large number of files or folders - because the protocol reports back to the host after each file (or so it appears) and this is not very efficient from a network perspective - this is true of any network drive.  In short - copying a folder of 3 10 gig files will copy exponentially faster than a folder containing 3,000 small files totaling 30 gig - because of the status reporting that occurs on a per file basis during the copy.

If using a different cable doesn’t solve the problem - you might consider a factory restore.  However - the fact that the diagnostic test is reporting a failure - is pretty much a sign that there mabye something wrong with the drive itself.


Thanks for the reply Scott.

Funnily enough I was thinking about the network cable myself… it was the only thing I hadn’t tried so far.  I’ve just put a new lead in, and have powered the drive up to give it another try.  The UI still hasn’t come up, but I can sign in with ssh, no doubt a reboot will rectify the UI though.

The 6GB folder I’m copying has 24 files in it, each between 250 and 300MB.  I think, in this instance, that’s fairly irrelevany anyway as the problem is the ‘pipe’ to the drive seems to be getting saturated, and somthing ends up blocking any further data.  I’m a little concerned about a very short scratching sort of noise every few minutes that I keep hearing from the drive, even when it’s not doing anything, so whether that’s an indication there’s something wrong I’m not sure.

While the short diag test was succesful, I’m guessing the full diag test failed for the same reasons as above, the drive just seems to stop all network traffic after a while.  So maybe it’s all pointing to a problem with the drive itself.

Is it usual for these drives to get really warm?

UPDATE: The cable change didn’t make any difference.  The network monitor showed the copy starting at about 4.8 MB/s, and was fairly consistent for a few minutes, then it completely stopped at 1.52 of 6.67 GB copied (Finder was still reporting an estimated 23 mins for the copy which seems way too high).  The drive has now had a dummy spit and Finder is reporting a server connection interuption, ah, and now comes the same error code -50 message and the light on the drive went yellow, and now back to a quick flashing green.   I’m heading back to town over the next few days, so I think I’ll just pack it up and return it as faulty.

I thought I had it then… I tried switching off the wireless network on my Mac, and this time I got about 4.5GB through the copy before the same thing happened.  Darn it!!  :)

By the way… is there meant to be anything in the Software folder on the Public drive?  There was on my partners MBL, but there’s nothing showing in mine… very odd!

Hey Scot, I’m assuming you’re the same SBeattie2 that’s posting in the Apple Discussion forums about a server conneciton interruption with a TC?

From what I read of that thread… I’m wondering if I’m experiencing a similar problem to you, but just manifesting in a slightly different way.  I dumped that 150GB on the drive the other night, and ever since then, every time I try and copy the data stops sending, or being received by the MBL, and after a few minutes that same popup appears.

I wonder if I’m looking in the wrong place, maybe it’s a Mac issue, and not a drive issue?  I wonder why it’s worked ok on my partners MacBook Pro though, she’s running the same OSX version as me.

I don’t know.  I’m kind of lost now!  I guess I could bring her MBL drive over here and try it on my Mac, or vice versa, and see if I get the same problems copying from her Mac.  That might shed some light and at least point at the offending bit of hardware!     

The drive ships from the factory with basically the entire contents of the install CD copied into the Software folder.  This is meant as a convenience so you don’t have to use the CD.  However, there is no guarantee that what is on the CD and what is in the software folder are exactly the same.  One could be newer than the other - and both the software folder and the CD are probably already outdated.  You can get all the updated software (that is on the CD) from the WD Website - under downloads for the MBL.

If you are using the MBL in a Mac environment (which you are) - then you don’t really need to install anything extra.  Just attach the drive to the network.  You don’t need (and really can’t use) the smartware on a Mac.  The only utility that will even work on the Mac is the Quick View.  If you want quick view - you need to get it from the WD Website - don’t install from CD or software folder - it caused a problem on my Mac - and I couldn’t figure out what it was doing or how to uninstall it - so I restored my Mac from backup to ensure that it was removed.

If your software folder is empty - this sort of indicates that you did a factory restore of some sort.  When I was experimenting with the factory restore - I noticed that it left the software folder empty.  I had a second MBL so I just copied it back from the other drive.

As far as temperature - the MBL uses WD Caviar Green drives - which don’t run very hot.  The drive uses a convection cooling mechanism (kind of like a chimney).  There should be some warmth coming from the vents on the top of the drive enclouse - but nothing that would remotely be considered hot.  The sides of the drive enclosure should barely be warm to the touch.  I’ve had the MBL running constantly for 10 hours doing a safebpoint backup - and there is not much detectable difference in the temperature when the drive is idle vs when the drive is actively reading and writing.

The scratching noise sounds a little unusual to me and I would be suspicious of that.  The drive occasionally will make clicking noises - even when the LED on the front does not flash.

You could try a full factory restore - and what that will do is completely wipe out the entire drive with zeros and rebuild the filesystem.  You will have a drive that appears to be factory fresh - less the contents of the software folder in the public share.  You will have to set the drive up from scratch and the full factory restore will take about 15 hours.  You don’t have an option of not writing zeros over the entire drive.   This process will also detect and mark any newly discovered bad sectors.  (Aren’t bad sectors now few and far between - if not non-existent on most modern day hard drives?).

Your data transer of 4.8 MB per second is rather slow - especially for being directly connected to the Mac’s ethernet port.  That’s only 288 megabytes per minute.  In my “optimal” copying scenario (single large 8+ gig binary file writing to the MBL takes ~3 minutes.  That calculates out to 44MB per second (and that’s over a wired network with other traffic through more than one switch).  Copying a larger number of smaller files reduces this throughput substantially.  Your scenario of 24 250mb+ files shouldn’t really impact this much.  I’m referring to something like an itunes folder where there are many subdirectories and thousands of small files.

When I run a safepoint backup - which is initiated MBL to MBL - both MBL’s on the same gig switch with nothing else - I average about 250-300 megabytes per minute.  This is no the network being slow - rather the safepoint creation has a lot of crunching that it does and only moves small amounts of data at a time - and therefore the perceived slowness.

I also tested my 8+ gig file transfer on a 100 megabit switch - and the copy took about 11 or 12 minutes - approximate 4 times slower.  (It’s hard to achieve true gigabit speed on a home network - but gig is usually much faster than megabit speed in most scenarios unless your network cabling is extreme low quality.  I can’t say I notice all that much difference between using CAT 5, 5e or 6 cabling.

What if you try to copy another folder - such as your iTunes library - if it is not too huge?  Can you try copying to a different share on the drive?


1 Like

I think I did the very basic I needed to do on this drive, I updated firmware, connected it directly to my mac, and started copying data.  I haven’t installed anything, I didn’t even create any new users or shares.  Just took the very default.

I’m pretty sure this network/copying data issue has been around since the moment I plugged it in.  I had all sorts of problems trying to update the FW, including various connection error messages and refernces to KB 5657.

Yet another ‘warning bell’ is your reference to the temperature.  I have 2 portable USB drives and a powered desktop USB drive connected to the Mac, and none of them are more than very slightly warm.  This MBL has been running really hot on the side of the unit.  Probably hotter there than around the vents.

To be honest… I’m worried that if a full self diag ‘times out’, then I’m runnig the risk of completely anhialating the drive if I attempt a full factory restore and it fails.  I think I’ll run it up the road in the morning and try it on my partners MBP, to rule out my machine etc, and if there’s still an issue, I’ll return it to the shop.  I only bought it on Saturday, so I should be right to return it.  Trouble is, they only had two left, and we bought them both :^)

The speed is definitely an issue, as I mentioned in an earlier post, I copied data off a portable USB drive to my partners MBL connected directly to the laptop, and we copied 20 to 30GB in less than half an hour. 

I’m calling it a day now, but rather than try another folder on my machine, I’ll head up the road and test the drive on the MacBook Pro tomorrow and go from there.

Thanks for your help Scott!

what version of mac os are you running?  also, are you by chance laying the drive on its side?  because that’s a big no-no, even with the caviar greens.  it will build heat unless its standing on end.  also, are you accessing the drive by its name or by its ip address?  try mapping the drive by its ip address and see if that helps.

Thanks Bill_S.

I’m running OSX 10.7.2.  But so is my partners MBP, so I know that wasn’t the issue.  And no, I definitely wasn’t laying the drive on it’s side :^)   I tried accessing the drive by name AND ip address.

I ended up taking the drive over to my partners place, hooking it into her MBP and trying again.  I got similar errors, and then I got a red light on the front that hadn’t appeared before, and stopped me in my tracks.  I ended up returning the drive to the retailer yesterday and getting a refund.  They didn’t have any more in stock, and aren’t expecting any until the end of the month.  Such a shame, because the other one we bought worked really well.  Never mind, it happens! :^)

Thanks to you both for your help… hopefully when I get a replacement it’ll work as intended. 

Yes - I am the same SBeattie2 that is posting on Apple Discussions about the Time Capsule and the server disconnect popup message.  That problem is also “AFP” related and I’m about to call Apple Care about it.  That particular problem is not a Lion-specific problem - it also happens on Snow Leopard 10.6.8.  The WD forum is probably not the appropriate place to discuss that particular issue - but I think there is a common link between that problem and some of the AFP related MBL issues.  All I know is that Apple made some sudden changes to their AFP implementation towards the end of Snow Leopard releases just prior to releasing Lion.  Please post on the Apple Discussion thread and we can get into more details.  Tomorrow I will be opening an Apple Care incident now that I have gone off and done all of the troubleshooting steps that I know they will ask me to do.


Thanks, Scott, for your help.

@ texinick

Sorry to hear that, but it does happen.  The red light can be bad.  So, yes, I would take it back right away.