Have to Set Up Network Every Time I Turn On Box

I’m not too familiar with networking, so a lot of the help threads I’ve tried to read are filled with jargon I don’t understand. So sorry if the answer to this is explained in numerous other places.

Anyway, I can get my WD Live working fine, with a Linksys Router, Netgear adapter and Windows Vista. I have successfully used the box to watch video’s both via the Network share option, and also using TVersity media server. However, when I turn the box on and go into videos>media servers/network share> I get a message “the device could not connect to network”. If I then go to settings, I can consistently setup a wireless network with automatic settings. But then next time I turn the box off, come back later and turn it on, I’ll get the same “device could not connect …” message. And I have to re-setup the wireless network.

How can I configure it so that this connection is automatic and always established?

I’ve never liked DCHP… especially when I’m trying to forward ports to specific machines, I like knowing that the IP isn’t going to change on me.  (DCHP is where the router assigns a semi-random number to a device every time the device connects to it.)

So I didn’t even try the automatic settings when I got my Live… I just manually entered the IP I was planning to assign the WDTV, the subnet and the gateway, and the Preferred DNS IP from my ISP.

I then tested the connectivity and it said everything was fine.

So, reset your WDTV (push the paperclip reset button on the side while it’s on, and then when it reboots select “Reset to factory defaults” in the “Settings” menu) and then pick an unused IP and try manual settings:

  • 192.168.1.x
  • xxx.xxx.xxx.xxx

You can pick any unused number (up to 255) for the “x” (as long as it doesn’t conflict with your existing devices and the DCHP range… my router is set to assign DCHP from 64-127, so I use 128 and above for assigning IP addresses manually.) and you can get the Preferred DNS IP (“xxx.xxx.xxx.xxx”), if you don’t know it, by going into _ Change Adaptor Settings _ in _ Network and Sharing _ on your PC and going into the TCP/IPv4 properties for your adaptor.

Should the IP address be the same as the ipv4 address I get when I do ipconfig in command?

No, that one that comes up will be the IP address of your computer on the router… you want the one for the WDTV to be different from that, so that the router can tell them apart.

You’ll want the last number to be different from the ones that come up for ipconfig on the PC.

Sorry I realised this as soon as I’d posted. I’ve chosen a fine IP now.

I got the thing working. Turned off box, turned back on. And what do you know, it wouldn’t work. However this time I got no “cannot connect” message. I just can’t select or scroll any further once I get to>media servers.

When I do a “check connection” it says the DNS server address is incorrect. When I check in properties of ipv4 in computer. There are no settings, as it is set to automatic. When I go into ipconfig on command, it has 2 ‘prefferred dns servers’. I used the first one. And like I say it worked fine. But then when I restarted, it didn’t. 

Should I change the option from ‘automatic’ in properties in network settings on my pc, to the the 2 that come up in ipconfig?

Well I went ahead and tried that. 

Same thing. Worked fine as soon as I did it. Restarted the WD, and it fails, and when I check it says its the DNS again.

Close to suicide. 

Ok, I’m not sure… because I don’t have “Automatic” DNS set up on my PC… I entered the 2 DNS servers from my ISP manually, and just used DNS #1 from my ISP as the value to enter on my Live.

Can you get a DNS server address from your router’s “Status” page?

In router status I get 2 similar looking DNS numbers. And I’ve tried using either of thos. Both to the same outcome, works first off, then doesn’t once I restart the box later in the day.

We have 4 or 5 laptops and a few phones which use the router for internet access. Would it be too much of a pain in the **bleep** to turn of dhcp?

smashupbox wrote:

Would it be too much of a pain in the **bleep** to turn of dhcp?

I’d presume so.  My network is all wired so I just manually assign IP addresses to each device and don’t use DHCP at all.

I’ve never had my Live revert the settings on me.

Try this:

  • select “Reset to Factory Defaults”
  • then push the paperclip reset
  • once the unit boots after the reset, unplug it and leave it unplugged for at least 10 minutes, if not longer
  • while it’s unplugged, make sure the Cat5 cable is firmly seated in the socket
  • plug it back in and when it boots, go to the network setup and try entering the information manually again
  • have it check the connection
  • play around and make sure you have access to your network and to the Internet
  • power it off and back on and see if your settings are still borked, or if it remembers them this time