Have to constantly reboot, this time there was a surprise

The last few months, I’ve had to constantly reboot m…my cloud. I believe it is on its way out the door. But this time, when I rebooted the device, this is what the dashboard looked like. What’s going on here? Do I have corrupt template files or is the hard drive just straight up dying? What do you think my options are?

mycloud_error3

What troubleshooting steps have you tried? Have you tried a 40 second reset? Can you access the My Cloud using SSH (assuming you previously enabled SSH in the My Cloud Dashboard)?

I’ve done both reset methods. I do not have SSH enabled on it. Like many others, since the latest firmware, indexing does take a considerably longer time, i’ve waited over 24 hours and it’s still the same.

If the prior firmware was working fine then one can try downgrading their firmware until WD fixes the indexing problem with the latest firmware.

Not having any luck being able to downgrade. I was able to enable SSH, but i keep getting connection failures when I try to connect. What do you think is causing the issue with the UI being the way it is?