[GUIDE] Building packages for the new firmware... someone tried it?

#14

Nazar78 wrote:


Yes I agree, we could do a repo or dedicate one thread (may be this? OP mauromol may be can help to update the 1st post which consist of the link to the deb, build and author), to have all the debs tracked. For the debs submission, one must include the build guide together to sort of assuring it’s safe to use from this source…

Time permitting, there’s no problem for me to update the first post with links. However I think it would need a lot of trust from users, unless someone puts up an actual repository and performs a little control over what is uploaded there. Unfortunately I don’t have the resources to do more than just gather links…

By the way, how do mail subscriptions work in this forum? I often don’t receive mail notifications, although I subscribed the thread :frowning:

#15

Hi again Nazar,

thanks a lot for your guide!! A couple of questions. Why do you say that a 64-bit host for cross compiling won’t work? What would it break?

Also, do you think that the same could be done in Debian instead of Ubuntu?

Lastly: what do you think is the actual difference between your environment and the one from WD firmware? I mean, do you have any suspect on what is causing the compiler segmentation fault in the WD environment?

In fact, if we could achieve to compile Debian source packages directly, package building would be much easier and, I think, we could obtain final deb packages with all the necessary scripts for integration in the target environment (like service start and stop scripts, for instance…).

Going from the plain source tar of each needed software would be a real PITA in fact…

#16

Good news, I think I’ve found the way to make the standard WD environment work with any package (without segmentation faults)!! I was finally able to successfully compile the unrar package. Now I’m currently compiling perl-base … next I’ll try mc. If all of them succeed, I will post here the solution.

#17

The toolchain was compiled for 32bit I think, therefore can run only on 32bit host.

Another simplified method would be great. I was looking into how to achieve cross-compile while auto resolve dependencies something like aptget build dep.

Looking forward for your results…

#18

I confirm I got it to work. The issue with the standard WD environment is related to qemu. The setup.sh script which gets called by the build script is supposed to replace the osbolete (and not fully working) qemu-arm-static binary provided by the bootstrap archive with the one coming from build_tools/debian/qemu/$arch, where $arch is the architecture (amd64 or i386) of your host system. This should happen the first time, when the build directory (containing the arm Debian subsystem used for building) is created. I haven’t investigated further (at a first glance the script looks good to me), however let’s fix this in an even better way.

Guide will follow in the next message.

#19

How to successfully build packages for WD My Cloud from source

 

The WD My Cloud comes with a Debian wheezy system on it. However WD customized that in a way that it is hardly possible (if not impossible at all) to install new packages using the standard “apt-get install <package name>” way, especially when you update the device firmware to version 4.x or later. The latest firmware, in fact, uses a modified Debian system with 64K sized memory pages: if you install a package using “apt-get install <package name>” from the standard repositories, almost certainly it won’t run and produce just a laconic “Killed” output.

So, to install new packages on the My Cloud you need to build them from source on another system, copy the obtained deb packages on the My Cloud and install.

WD provides a GPL source package of the latest firmware on their website, which contains a build environment to perform this operation. This is totally at the end-user own risk, since no support at all is provided by WD and installing 3rd party software may void warrany.

 

An additional problem is that the build environment provided by WD has a “minor” problem that causes the building process of most packages to fail because of a GCC compiler segmentation fault.

This guide shows how to deal with this problem and, in general, how to create a build environment to easily do the task.

Some Linux knowledge is needed.

 

NOTE 1: as of now, this procedure is surely needed to build packages for the 4.x firmware; however, by experience, I find out that it’s a useful procedure even if you are sticking with the 3.x firmware; so the guide explains how to build packages for both firmware versions

NOTE 2: in principle, it should be possible to build packages directly on the My Cloud, instead of using an external system; however I don’t think it’s a good idea to try this, because of many reasons, including: the My Cloud system is surely slower than a regular PC to compile packages; you would need to install all the development tools on the My Cloud itself (and this may require in turn to build them on another system first…)

 

Step 1: prepare the build system (required only once)


The build environment must be a Linux system, either Debian-based or Ubuntu-based. I personally suggest to create a virtual machine with such a system in it. This guide will take this route.

Download and install VirtualBox (https://www.virtualbox.org/) on your phisical system (either Linux, Windows or Mac). Start VirtualBox and create a new virtual machine for a Debian 64-bit. The default settings suggested by VirtualBox regarding memory, disk size and VM configuration should be ok to start.

After the VM is ready, download a Debian Wheezy 64-bit ISO image; I suggest the netinst image, which is the smaller one. Right now, Debian 7.0.6 is available and the direct links are:

Boot the VM with the downloaded ISO mounted in and install just the Debian base system (nothing else is required). Refer to VirtualBox and Debian websites for documentation on how to perform these operations.

 

Once the guest VM is installed, we need to make just a couple little tunings. First of all, Debian Wheezy comes with qemu-user-static package version 1.1.2. Qemu is an environment needed to emulate an actual ARM system on another platform, like the AMD64 platform our build system consists of. It’s a good idea to update Qemu to version 2.x from the wheezy-backports repository. To do this, start the build system and login. Then:

# sudo su
# echo "deb http://ftp.debian.org/debian wheezy-backports main contrib non-free" >>/etc/apt/sources.list
# apt-get update
# apt-get -t wheezy-backports install qemu-user-static

This should also install binfmt-support, which is another packages needed by the build environment. If this is not the case, also type:

# apt-get install binfmt-support

Now, let’s prepare the actual build environment. Let’s create a folder in the /root directory of the build system and download the WD My Cloud 4.x firmware source package from WD website.

# cd /root
# mkdir wdmc-build
# cd wdmc-build
# wget http://download.wdc.com/gpl/gpl-source-sequoia-04.00.00-607.zip

In case the link changes, refer to WD My Cloud support page to find the new one: http://support.wdc.com/product/download.asp?groupid=904&lang=en

 I then suggest to create different folders for different build scenarios. These are the possibilities:

  • the target system may be firmware 3.x (4k) or firmware 4.x (64k)
  • the source package base may be wheezy (Debian stable) or jessie (Debian testing); wheezy contains older packages, but that should run happily in My Cloud (which has a Wheezy in it!), while jessie contains newer packages that might also work and provide updated versions of many applications; I would personally recommend to build packages from wheezy, unless you absolutely need a newer version that is only in jessie

I don’t recommend to mix things, so I would create different folders for any different combination. You’re free to create just the one you are interested in, so among the following commands type fhe first ones, then only the block of commands of the combination(s) you’re interested in, then the last command:

# cd /root/wdmc-build
# unzip gpl-source-sequoia-04.00.00-607.zip packages/build_tools/debian/*

# mkdir 64k-wheezy
# cp -R packages/build_tools/debian/* ./64k-wheezy
# echo '#!/bin/bash' >>64k-wheezy/build.sh
# echo './build-armhf-package.sh --pagesize=64k $1 wheezy' >>64k-wheezy/build.sh# chmod a+x ./64k-wheezy/build.sh

# mkdir 64k-jessie
# cp -R packages/build_tools/debian/* ./64k-jessie
# echo '#!/bin/bash' >>64k-jessie/build.sh
# echo './build-armhf-package.sh --pagesize=64k $1 jessie' >>64k-jessie/build.sh
# chmod a+x ./64k-jessie/build.sh
# mkdir 4k-wheezy
# cp -R packages/build_tools/debian/* ./4k-wheezy
# echo '#!/bin/bash' >>4k-wheezy/build.sh
# echo './build-armhf-package.sh --pagesize=4k $1 wheezy' >>4k-wheezy/build.sh
# chmod a+x ./4k-wheezy/build.sh
# mkdir 4k-jessie
# cp -R packages/build_tools/debian/* ./4k-jessie
# echo '#!/bin/bash' >>4k-jessie/build.sh
# echo './build-armhf-package.sh --pagesize=4k $1 jessie' >>4k-jessie/build.sh
# chmod a+x ./4k-jessie/build.sh
# rm -rf packages/

In this way, in every folder will be created a build.sh script that passes the right parameters to the WD provided script, requiring only the name of the package to build. This would work straight away if there weren’t the problem with qemu I mentioned in the beginning, so another step is required to finish the prepare phase. Again, only type commands for the scenario(s) you’re interested in:

 

64k-wheezy:

# cd /root/wdmc-build/64k-wheezy
# ./setup.sh bootstrap/wheezy-bootstrap_1.24.14_armhf.tar.gz build
# mv build/usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static_orig
# cp /usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static

64k-jessie:

# cd /root/wdmc-build/64k-jessie
# ./setup.sh bootstrap/jessie-bootstrap_5.14.14_armhf.tar.gz build
# cp /usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static

4k-wheezy:

# cd /root/wdmc-build/4k-wheezy
# ./setup.sh bootstrap/wheezy-bootstrap_1.24.14_armhf.tar.gz build
# mv build/usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static_orig
# cp /usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static

4k-jessie:

# cd /root/wdmc-build/4k-jessie
# ./setup.sh bootstrap/jessie-bootstrap_5.14.14_armhf.tar.gz build
# cp /usr/bin/qemu-arm-static build/usr/bin/qemu-arm-static

The meaning of the above is the following: prepare an emulated ARM system and replace the qemu-arm-static binary provided by the bootstrap with the recent one we’ve installed in our actual build system.

Ignore any errors produced by setup.sh: that script is really buggy and many things it tries to do seem to be useless, unless we apply the mentioned qemu fix.

 

As a final step, I would recommend to edit the sources file list within the armhf build subsystem in order to be able to build packages that are in any of the distribution repositories. To do this, type the following:

# cd /root/wdmc-build
# nano <scenario>/build/etc/apt/sources.list

by replacing <scenario> with the desired one (64k-wheezy, 64k-jessie, 4k-wheezy, 4k-jessie); the nano editor will open, then replace the contents of the existing file with the following:

For 64k-wheezy and 4k-wheezy:

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.debian.org/debian wheezy-updates main contrib non-free
deb-src http://ftp.debian.org/debian wheezy-updates main contrib non-free
deb http://ftp.debian.org/debian wheezy main contrib non-free
deb-src http://ftp.debian.org/debian wheezy main contrib non-free

#deb http://ftp.debian.org/debian wheezy-backports main contrib non-free
#deb http://ftp.debian.org/debian wheezy-backports main contrib non-free

For 64k-jessie and 4k-jessie:

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.debian.org/debian jessie-updates main contrib non-free
deb-src http://ftp.debian.org/debian jessie-updates main contrib non-free
deb http://ftp.debian.org/debian jessie main contrib non-free
deb-src http://ftp.debian.org/debian jessie main contrib non-free

In case of wheezy, uncomment the last two lines if you want to build package versions from wheezy-backports. I don’t know however if additional changes to the build.sh script (or better to the WD provided one) are needed to instruct apt to download and build the source from the backports repository. I don’t have tried it yet. Anyway, I would recommend to leave those two lines commented unless you actually need something from the backports repository.

Save the file by hitting Ctrl+X, Y, Enter.

Now you’re ready to build your first package!

 

Optional additional step (not strictly required) for wheezy scenarios

You may also want to use an updated C++ compiler to build packages in the wheezy scenarios. Debian Wheezy provides g++ package 4.6, but 4.7 is also available. With the following commands you can install the new version and then switch from one to the other using update-alternatives:

# cd /root/wdmc-build/<scenario>
# chroot build# apt-get update
# apt-get install g++ g++-4.7
# update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++.4.6 10
# update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.7 20
# update-alternatives --install /usr/bin/gcc g++ /usr/bin/gcc-4.6 10
# update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 20
# rm /usr/bin/cpp
# update-alternatives --install /usr/bin/cpp cpp /usr/bin/cpp-4.6 10
# update-alternatives --install /usr/bin/cpp cpp /usr/bin/cpp-4.7 20# exit

After these commands, the default C++ compiler will be version 4.7. You can then switch to the old version by typing:

# cd /root/wdmc-build/<scenario>
# chroot build
# update-alternatives --set cpp /usr/bin/cpp-4.6
# update-alternatives --set gcc /usr/bin/gcc-4.6
# update-alternatives --set g++ /usr/bin/g++-4.6
# exit

 Or use update-alternatives --config <command> to get an interactive prompt.

 

Continues on the next message

8 Likes
Install Calibre for using Calibre-headless on WDMycloud
[APP] MiniDLNA original/patched for firmware V4+ (08/2017)
Clean OS (Debian), OpenMediaVault and other "firmwares"
Rtorrent 0.9.6 or qbittorrent 3.3.3 for firmware v4
Building binaries from source for MyCloudMirror
Optware on MyCloud?
Using of Subvision
Firmware 04.05.00-334 (3/12/19) Discussion
#20

Step 2: build your package


It’s time to build your package. Let’s build htop for instance, a nice replacement for top command. The example will build it for the scenario 64k-wheezy (i.e: packages suitable for 4.x firmware, built from the version of htop provided by Debian Wheezy). Start your build system, login, then:

 

# sudo su
# cd /root/wdmc-build/64k-wheezy
# ./build.sh htop

The built package will be placed into /root/wdmc-build/<scenario>/build/root and will consist of one or more .deb files (you’ll also find other files and folder, just ignore them and consider only .deb files). Sometimes building a package will build other packages, too: it depends on how package sources are organized. For instance, if you build transmission-daemon, you’ll also get the deb packages for the GUI packages (like transmission-gtk or transmission-qt): you can simply throw away those additional debs if you don’t need them.

Once the deb files are ready, copy them from the build system to your My Cloud (to achieve this, if you built a VirtualBox VM you may use a shared folder to exchange data with the physical host system). Then, login via SSH to your My Cloud and type:

# dpkg -i <path-to-build-deb-file>/htop_1.0.1-1_armhf.deb

where <path-to-built-deb-file> is the path where you stored the deb file you just built; if you copied it to the standard Public shared folder, the path will be /shares/Public/.

 

If you’re lucky, you’re done. Otherwise, the /installation command may prompt you something like this:

dpkg: dependency problems prevent configuration of transmission-daemon:
 transmission-daemon depends on libcurl3-gnutls (>= 7.16.2); however:
  Package libcurl3-gnutls is not installed.

This simply means that the package you’re trying to install depends on another package (in this case: transmission-daemon requires libcurl3-gnutls) which is not yet installed. You then need to build in turn this required package, with the same procedure, and install it before the package you originally intended to install. Repeat the steps for all the missing dependencies that dpkg reports. Sometimes, to fix circular dependencies (packages depend on each other), once you’ve built all the necessary packages you may install them all at once with: dpkg -i <path-to-built-debs>/*.deb, so that dpkg will resolve dependencies automatically.

Final notes

  1. building a package may require a LOT of time, just be patient…
  2. you may periodically clean /root/wdmc-build/<scenario>/build/root folder after you’ve built your packages, to free up space; in fact, building may require a considerable amount of (temporary) disk space
  3. once installed with dpkg, packages contents are unpacked to the My Cloud system partitions. There should be enough disk space available to not worry about disk space, however almost certainly a firmware upgrade will delete all of your installed packages; I would suggest to create a shared folder using the web UI, named “System”, protected by password and accessible only to admin users; inside it you may put your built deb files, organized as you like. In case of a firmware upgrade, you may simply re-install the packages from there using dpkg -i (one at a time, or all of them at once using wildcards, etc.); however please consider the following notes
  4. a firmware upgrade might change the architecture of the provided Debian system and might require to rebuild all packages… this is exactly what happened with the upgrade from 3.x to 4.x firmware, where WD decided to rebuild the whole system using 64k sized memory pages rather than the standard 4k sized ones… I don’t think WD is so sadistic to do that again and again, but who knows? I suggest to read carefully the release notes of the new firmware, have a look to the updated GPL source package (if they make it available on their website) and try to install a few small packages after firmware upgrade just to check that everything is ok; installing all in a rush may have catastrophic effects, especially when a package you had built on your own requires to update one of the WD provided ones… if it won’t work, it will almost certainly break something of the WD built-in features, causing a device failure in the worst case… again, you are on your own, you get no support for this
  5. to restore the whole functionality of third-party applications after a firmware upgrade, not only you may need to reinstall the deb packages, but you will also need to restore any custom application configuration; if you leave default settings, usually applications save their settings in /etc or in /root, which are both on the system partitions of WD and might be deleted and recreated by the firmware update process; you may choose to backup your application configurations or change things so that they are linked to a shared folder (for instance the aforementioned System shared folder) where they won’t be deleted; in this way, after the firmware upgrade you may just need to restore your backups or your symlinks; howerver, the exact procedure may be different for each package and is above the scope of this guide

From the above, two things should be quite clear: disable the automatic firmware upgrade in the web UI and use all of this at your own risk.

 

Feedback, improvements and corrections are welcome.

UPDATE ON 2015-01-10: I’ve published a new message where I’m providing patched scripts and an updated binutils package to make the build environment work better, especially when building packages from jessie repository and with 64k pagesize. Here is the direct link.

5 Likes
#21

NOTE: as of now, I have successfully used the above steps to compile many packages for 4k-wheezy, 64k-wheezy and 4k-jessie. I don’t think I’ve tried 64k-jessie, but if compilation succeeds for 4k I see no reason for which it shouldn’t for 64k.

Many of those packages have also been installed and run successful on 4k (in fact, I’m currently using firmware 3.x in my My Cloud).

ISSUES SO FAR:

 

  • iotop builds and runs successful, but exits immediately because the kernel in the My Cloud has been compiled without the flags needed by iotop; a kernel ricompilation would be needed: since we have the source by WD, in principle it should be possible to do…
  • transmission-daemon can be successfully compiled from wheezy suite (version 2.52), but not from jessie (version 2.82): configuration fails and, in the output, I see three segmentation faults of qemu which are likely to be the cause; I’m trying to build qemu 2.1.0-rc3 from source (Debian provides 2.0 at most) to see if this can be fixed… otherwise an alternative approach must be taken to get a newer Transmission: try to build it in the My Cloud itself (would require to build and install on the device all the development tools) or cross-compile from original source as Nazar did
1 Like
#22

Ok I followed your steps trying to build transmission 64K wheezy with updated g++ package 4.7 on Debian 7.0.6 64bit, 1st round the bootstrap was missing dpkg-dev so I chroot build and install it.

The 2nd round the make failed at “make[4]: Entering directory `/root/transmission-2.52/third-party/dht’” with lots of these errors: dht.c:2893:49: error: invalid conversion from ‘void*’ to ‘const unsigned char*’ [-fpermissive].

Reverted back to gcc 4.6, same error.

#23

Updates, my bad, I already messed up the binutils:

So the vital point is the qemu like you mentioned.

To summarize your guide, these are the required parts to successfully build the packages on host Debian 7.6.0 64bit:

  1. Update the host once:

    sudo su
    echo “deb http://ftp.debian.org/debian wheezy-backports main contrib non-free” >>/etc/apt/sources.list
    apt-get update
    apt-get -t wheezy-backports install qemu-user-staticapt-get install binfmt-support

 2. Get the WD GPL source and extract to working dir if haven’t done so:

wget http://download.wdc.com/gpl/gpl-source-sequoia-04.00.00-607.zip
unzip gpl-source-sequoia-04.00.00-607.zip packages/build_tools/debian/*

 3. Fix WD bootstrap once! cd to the package dir, replace qemu that was provided by WD:

cd packages/build_tools/debian/
cp -f /usr/bin/qemu-arm-static qemu/`dpkg --print-architecture`/

 4. Run the build command (watch out for timeout/gateway errors which will result in failure at the end, retry if some dependencies failed to download):

./build-armhf-package.sh --pagesize=64k transmission wheezy

Results:

OUTPUT debs can be found here:       
build/root/transmission-cli_2.52-3+nmu2_armhf.deb
build/root/transmission-dbg_2.52-3+nmu2_armhf.deb
build/root/transmission-daemon_2.52-3+nmu2_armhf.deb
build/root/transmission-gtk_2.52-3+nmu2_armhf.deb
build/root/transmission_2.52-3+nmu2_all.deb
build/root/transmission-qt_2.52-3+nmu2_armhf.deb
build/root/transmission-common_2.52-3+nmu2_all.deb

1 Like
#24

Hi Nazar,

I don’t understand, I just repeated the steps one by one to compile the package named “transmission-daemon” for 64-wheezy using G++ 4.7 and I had no issue at all…

Also, it’s strange that you had to install dpkg-dev manually: when you launch the build script, it invokes apt-get to install all the packages required for building. It’s all automatic. Are you sure your etc/apt/sources.list in the chrooted subsystem is ok?

Ok, I see now you’ve fixed your problem. However, are you able to compile libcurl3-gnutls? I can’t

Also, compiling transmission-daemon fails in 4k-jessie, again for a configuration error :frowning: It’s the opposite situation of libcurl3-gnutls.

I’m starting to think that transmission will need the use of packages coming from mixed sources… I’ll keep on experiment.

#25

You’re right about the dpkg-dev, I scrolled way up and noticed it failed to get the package, gateway timeout :frowning:

Anyway I’ve updated the summary and removed dpkg-dev. Only qemu needs to be replaced.

I cleared the build dir to simulate a new instance, it’s working now.

I haven’t tried 4k nor jessie nor other packages yet, it’s 5am here haha. But it has been a great breakthrough so far! Great work!

#26

I’ve managed to fix the build problem I had with libcurl3-gnutls from wheezy (it was my fault, I messed with the update-alternatives of gcc). So, now I have all the needed packages for Transmission 2.52 built from wheezy: I installed it and run successful!

Still I can’t build Transmission 2.82 from jessie. I think that Nazar’s solution is still valid if someone needs a recent version.

#27

Today I tried java and mysql, can’t seems to build the latest jdk/jre 7 only older builds, segmentation fault :frowning:

-rw-r–r-- 1 root root 138772 Jul 27 23:00 build/root/java-common_0.47_all.deb

-rw-r–r-- 1 root root   629082 Jul 27 08:57 build/root/libmysqlclient18_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root   898130 Jul 27 08:58 build/root/libmysqlclient-dev_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root  2974872 Jul 27 08:58 build/root/libmysqld-dev_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root  2973778 Jul 27 08:57 build/root/libmysqld-pic_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root    76726 Jul 27 08:54 build/root/mysql-client_5.5.38-0+wheezy1_all.deb
-rw-r–r-- 1 root root  1456064 Jul 27 08:58 build/root/mysql-client-5.5_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root    78566 Jul 27 08:54 build/root/mysql-common_5.5.38-0+wheezy1_all.deb
-rw-r–r-- 1 root root    76850 Jul 27 08:54 build/root/mysql-server_5.5.38-0+wheezy1_all.deb
-rw-r–r-- 1 root root  1740732 Jul 27 08:59 build/root/mysql-server-5.5_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root  3495408 Jul 27 08:59 build/root/mysql-server-core-5.5_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root 23062170 Jul 27 09:01 build/root/mysql-source-5.5_5.5.38-0+wheezy1_armhf.deb
-rw-r–r-- 1 root root  4290934 Jul 27 09:01 build/root/mysql-testsuite-5.5_5.5.38-0+wheezy1_armhf.deb.deb

#28

Nazar78 wrote:

Today I tried java and mysql, can’t seems to build the latest jdk/jre 7 only older builds, segmentation fault :frowning:

What does segfault? QEMU?

I tried to compile QEMU 2.1.0_rc3 from official sources. Compilaion succeded, but the final qemu-arm executable (which is not qemu-arm-static…) does not work… I mean, if I try to replace qemu-arm-static in the chrooted system with the file I get from compilation, chroot fails. The Debian package must be doing something to obtain the qemu-user-static package, but that goes beyond my knowledge. I even tried to download the Debian 2.0.0 source package, replace the sources there with the one coming from the official 2.1.0-rc3 tar.bz2 file and run the Debian compilation, but it fails :frowning:

We might try to ask for assistance to QEMU developers…

1 Like
#29

Thanks! It compiled flawlessly for me!

#30

Hi, everyone.

Command

./build-armhf-package.sh --pagesize=64k transmission wheezy

give me

mainwin.cc:276:1: internal compiler error: Segmentation fault

Who can help me.

Thanks!

#31

pkomissarov wrote:

Hi, everyone.

Command

./build-armhf-package.sh --pagesize=64k transmission wheezy

give me

mainwin.cc:276:1: internal compiler error: Segmentation fault

Who can help me.

Thanks!

Hi pkomissarov, read the previous posts here and my guide, I think I’ve explained it well the cause and the fix.

#32

Thanks  mauromol,

I built htop for gpl-source-sequoia-03.04.01-230a.zip, your instructions worked a treat (4k jessie).

I’m still on the 3.4 firmware as version 4.0 is so diseased at the moment its not worth the effort.

As a bonus, htop looks cool.

#33
  • iotop builds and runs successful, but exits immediately because the kernel in the My Cloud has been compiled without the flags needed by iotop; a kernel ricompilation would be needed: since we have the source by WD, in principle it should be possible to do…

In theory, yes, and I have been able to compile/build the 3.4 kernel which turned out to be not so bad. Had to install 32bit libs for the build tools, and dev ncursors to get the make menuconfig to go. However, building iptables into the kernel or .ko modules still escapes me … what ever I do, doesnt seem to make much difference in the build… then again I’ve never built a kernel before so its probably me :slight_smile:

But without a dev/test environment its a guaranteed bricking activity so testing the kernel becomes a point of contention unless you’re willing to sacrifice a my cloud and have a quick drive rebuild procedure when things have gone pear shaped.

1 Like