Green blink blink

i cant connect to router and still green blink and blink still going … anyone can solve it?

These ports are not open on my router for mbl

In all honesty, you need to tell exactly what’s been done before the fault happened and in as best details as possible. People will love to help but if you don’t give better details and descriptions then it is impossible to assist you. In that casse if you can not give a better description then it would be better for you to call W.D. Technical Support for assistance and/or return your MyBook Live back to Western Digital for repair and/or replacement.

ok i bought 2tb 3 week ago and i use fine and somehow power off and  i saw green blink and blink i check router is fine. i go in Quick factory restore i hope router will pick up mbl. but still green blink blink still . i found i read forum said have reset of back mbl still no luck  ((sigh)) i real want bad back work with mbl and i hope u will help me.   thank

I’m going to re-phrase back at you what you wrote to make sure I’ve understood.

You bought a 2TB MyBook Live (MBL) three weeks ago and recently the MBL lost power. Maybe a power-cut or it was simply unplugged from the mains power. It was then turned on, the boot-up sequence happens as notmal and then the green LED just continuously keep blinking. At this point the MBL still worked. You then opted to perform a Quick factory restore which also erases all user data off the MBL.  You have also pressed the reset button on the back of the MBL for more then 4 seconds.  From the specific point of the quick factory restore your equipment can not communicate with your MBL.

Before I proceed, is my understanding of the problem and the steps you took exactly correct?


I am also facing problem with the green blink blink light.

what you had descript was correct.

Any solution?

Hi all,

it seem that I get more problem.

Now my laptop cannot access the into the MBL…



OK, I had did a hardware re-set on the WD.

Now i am able to access the folders inside the WD.

How to solve the brinking green light?


The green blinking light means the drive is being accessed. You are aware there are processes running within the MBL what will cause the led to blink green.  Now that your MBL is working I suggest you assign a static IP address to your MBL, assign the static gateway to be the same as rour router and DNS setting using IP address  (Google’s DNS resolver.)

Maybe you are having DHCP server issues between your router and your MBL. Setting static IP details should solve that one particular issue.

Yes, I agree with you that the green brinking light status mean the drive been access.

when i first install the harddisk 3 months ago, when the system was in standby mode, it was solid green light.

when it goes into sleep mode, it turn to blue solid light.

Due to some re-position of the power plugs, i switch off the harddisk.

When i switch it on back, the green brinking light problem occur

But when i switch off my PC, the green light still keep brinking.

I left it over the night, the next morning, it was still brinking and the hard disk keep running and I can feel  the heat generated by the harddisk.

What could have cause this green brinking light problem?

I read through the messages over the last few weeks.

it seem that the green brinking light was a issue which still have not been solve by WD.

Anyone got the solution for that  green brinking light before i give up on the WD MBL.

if no solution, I think WD MBL will be my first and last server hardisk i going to have

for time being, i think i need to swtich off the MBL when I not in use,

The way i see the harddisk keep running 24/7, the harddisk going to fail very soon.

Hi guy,

How to re-format the whole harddisk in the MBL?

Please tell me it can be done, if not, i going to throw the whole MBL out of the window.

i use dlink dir-655 and  u said The green blinking light means the drive is being accessed. so now what i do?

Try this…  If you have access to the Dashboard UI and not using the features, disable the Twonlky, iTunes, Remore Access and FTP services. I might know why but before I make any suggestions, I want to know what happens when the four services are disabled.

i cant get in dashboard Ul ,and what next ? 

Tell me how you are trying to access the Dashboard UI.  What IP address are you using in the browser and tell me how you are sure if the IP address the MyBook Live has been allocated.

i succesful get in router   and ip and mac for mbl . pah i can get in dasboard ul and set up for static ip and  but stil green blink…  itch my head still green blink

but usage 0GB / 0TB ?

I did notice that. You will need to call W.D. Technical Support for that one. It should not be showing these figures and I wonder if the never ending green flashing LED is related to this. The problem is not being able to gain access to the MBL’s log files. With the information given I am at a loss. Can’t do any sort of factory restore because you can’t get at the Dashboard UI.  You’ve not enabled SSH access so there is no direct route to the underlying Linux operating system.

You’ve tried the reset button.

Only one thing I can try think of to getting to your MyBook Live.

  • Use the Reset button again.  This only clears the owners’s password, resets the Linux root password to welc0me and resets the networking configuration to use DHCP.
  • Download and install Apple print Services.   (I assume you have a Windows computer) . . .
  • Once you have this installed try accessing your MyBook Live within your browser using this URL, assuming you have not renamed the MyBook Live…

I have had an issue with my own MyBook Live where a reboot kills access to my Dashboard UI. After I fully shut down my MBL (have to do this using a Linux comment (I enabled SSH)) and then pulled the power. When I plugged it back in the Dashboard UI started working again.  I’ve since assigned a static IP address to my MBL. Just in case the firmware boot up or Apache2 has a bug in it.  (I would rather the IP be supplied by the router.)

now fine work with dashboad  and router pick up ip and mac . but still green blink i use window 7