Mybooklive blinking green light?


I had the wd mybooklive for about 2 years and today i suddenly cant connect to it.
It only blink the green light for every 10 sec.

I read multiple threads in the forum, and tried the solutions with changing cabels, using the WD MBL setup and so on, but still no luck, cant access dashboard either. 

The ethernet on the behind is steady green at the bottom and blinking in the top.

Anyone got an idea what i can try?

Have you tried holding the reset button down in the back for 5-6 seconds or tried unplugging the unit and plugging it back in? It may very well be some sort of hardware issue with either the hard drive, power supply or the board attached to the drive as well. Really hard to pinpoint this sorta issue but generally if something has been working fine for this long and you haven’t changed your network then the issue is most probably a hardware issue with the MyBookLive.

The good news is you have a 3 year warranty I believe and could setup an RMA and get the drive replaced.

Yeah i tried the resetting and also tried multiple times to unplugging the unit :slight_smile:

I hoped that there was a specific thing when the LED only blinked and wasnt steady green. 
And yes, i can make an RMA and get the drive replaced, but i have lots i pictures i was hoping to see again :slight_smile:
(i know that i should back up that as well, but have to learn it the hard way :frowning: )

Yeah most people do :frowning:  On the box they should write

Backup your data to several locations because one day I may die

  1. You could try a WD Data Recovery Partner and then RMA the drive once you get your data back

2) Rip open the drive Then download Disk Internals Linux Reader for Windows and install the program. Hook up the drive to your computer or a SATA dock and copy your data to another drive with enough space on your computer. If the drive is not recognized by the computer you would likely need the professional data recovery service if you want your data back

Yeah i seen that post in multiple forums, but i will first be sure that this cant be fixed somehow.

I contacted WD support also, hope that they have some kind of solution.

Good luck and let us know if you do get a fix for your issue.

This happened to me about 5 hours ago too. I tried to move some photos over and it just started blinking saying it couldn’t find the drive.

Looking forward to someone getting an answer.

Now I can see all my files but the light is still blinking.

I cant even see my files - how can you that, if you cant find the drive? 

Now i got a steady green light, but still cant see the drive :frowning:

Yeah, we might be in the same boat.  Recovery Partners cost a fortune… Geek Squad is $250 min, up to $1K for anything complicated, and the platinum partners start at around $800… those have to be some pretty valuable pics to be worth that (though I can imagine a lot of pictures that might be worth that… fortunately, nothing that valuable in my case).

If you are squeamish about tearing it open yourself (and don’t want to risk killing the pics for good) you could find a local recovery place- I know there is one near where I live (Charlotte NC) which is cheaper than the WD companies, but you might still void your warranty… though they will just send you another one of these things (which I wouldn’t trust again).

I’ll probably open mine up and try to get to the files at some point, but I don’t have time to dive into that at the moment, so it will probably be awhile before I try that approach.

@trmills, I’m over in Raleigh, it you run into any issues gimme a holler

I have the same problem. :cry:

After I came from holidays turned my MyBookLive 2TB on, but it did not show-up in the network. I left it switched-on overnight, but still nothing. Tried resetting several times but no success. The drive seems to boot normally, the front LED light starts from blue, white and finally green (not steady green, but blinking one in fixed intervals, aroung 2 blinks/sec).

I used to connect to MBL via WiFi, but in order to avoid possible problems from wireless connection tried to connec using wired connection. No success …The MBL is not recognized by the router at all.

Any help is appreciated.



Ps: in case it helps, the MBL has ssh enabled because I used to connect to the drive remotely (before holidays).

Update : After spending an entire day to find a solution I gave up and sent back the MBL to claim the warranty. It may take up to one month to repair it, and I think my 700GB of data will be gone.

Update 2 : After 20 days I received a new product, apparently it could not be repaired. All data gone!!! :frowning:

I couldnt wait anymore so i took the harddisk out to get a backup of my NAS before it died (or what the problem is).
Happily for me, the data was still intact, so maybe it was the NAS itself which failed. 

Wrote to WD support, but they only said i could reset the device (which i done multiple times), and see if that works. 

So in my case, my WD Mybooklive adventure is done and i ordered a new different NAS instead.