SERIOUSLY disappointed with my shiny new WDTV live smp. What’s the point of the “Get content” thing if all it will display is the cover art? I only bought the thing because I thought I would have a synopsis and other movie info readily to hand when I was looking for a movie to watch from my collection.

I’ve had it two days. Will Argos take it back just because it doesn’t do what it says on the tin? And yes, the blurb does say it will “Get movie info.” Pah!!!

Or am I being a muppet?

I did hear a rumble that a future FW will include XBMC. But I suspect they’ll make us fork out another ton of cash for a new version! Double pah!!

mine does get the content… are you using the “media Library” function? 

it can be associated with either a local attached drive or a networked share folder.  For the network share you need read write permissions on that folder. 

it actually works quite well. 

go to settings / system / media Library  - make sure this is “on” 

then go further into it, and click on the Media library connection manager ( not sure the exact title, currently at work) 

add a source to the library.

the box will start to flash it’s LED and put up a message “compiling media Library” 

I leave the "get content " to manual only, because it has locked up the system when it finds multiple titles that are similar

i.e. " the thing (1982)" and “the thing (2011)”

to start i would recommend it on local storage ( thumb drive or USB hard drive) first.

hope this helps



Thanks for speedy response.

My movies are on an external hard drive plugged into lap top. I’m using file sharing.

I’ll go back to basics here. I right click on the folder  I’m sharing - go into properties and the radio button for Read Only is highlighted. Try as I might - the darn thing won’t come off. I click it off  but when I go back into properties - whoosh, it’s back on again.

I’m at my wit’s end but I have made a  note of your name…you seem rather helpful!!

Should I plug hard drive into WDTV? It seems a bit of a faff  ! ! !


I don’t have a media library connection manager or anything like it.


Confused Dot Com ! ! !

Ginger william,

Just a suggestion, for starting simple… yes, plug the Hard drive right into the WDTV.

this will alleviate your sharing issues. 

I ran into a similar issue with streaming movie from my windows home server( WHS)

I set up an account for the WDTV to use to log into the server, and set the permissions on that account to read/write.

then it wouldn’t work.

I ended up manually setting permissions for that user on the individual folders, not throught the Home server user interface, but in windows explorer / right click / properties / sharing.  

what version of windows is on your laptop?  because sharing is different in each one, ( thanks microsoft)

but please try the simplest / direct connect first.

also, if you leave the drive connected to the WDTV, you can still access it through your network i believe.

what version of firmware are you running on it? 

i think it only came about in like 1.06 or higher.


Many thanks for all your help so far - if I can just prevail further.

I’ve just checked. Firmware is 1.03.10.

I put HD in WDTV and immediately it said it was compiling library or words to the effect. I now have Media Library as a source along with Local Storage, etc. But - I can’t see what it’s actually done. A few random art covers appeared even though I have “Get Content Info” set to manual. I still can’t see any info. Interestingly, User Manual (and I use the term lightly!) suggests that if I press “Options” with a folder highlighted, I get a menu which includes “Get Content Info”. All I get is “Move, Copy, Delete” etc.

Any ideas?

Many thanks again.

PS You’ll hear a large explosion in deepest, darkest Somerset if I solve this - I will actually pop!

Hey gingerwilliam, 

You also may want to upgrade the firmware before going too much further.  I have gotten this working in both 1.06 and 1.07.  I would try to go right to 1.07 if you can.   your WDTV is connected to the internet through wireless or wired connection … correct?  without an internet connection you can’t grab meta data.  - it pulls it from a site called

from what you are describing, You may need to change the “view” you are looking at.

click the yellow C button.  it will cycle through different display options. 

on one of them, you will see a list of like 6 movies at the bottom of the screen, and the one that is selected will show the background images, and movie metadata.  - if no meta data, click the options button, and the Get Content info.

I have found some movies where it doesn’t find the info.  I would start with the ones you mentioned having art covers. 

I am not sure how you have your movies named, or your file structure in the vidoe directory.

what i have found works well is a folder called video, then subfolders under that with movie name as the folder name, and then the movie file itself ( mkv, m4p, avi, etc.) in that folder.

Check on for your movies, naming them similarly to what they appear there will greatly increase the likely hood of getting the metadata.

hope this helps!!! 


Need to thank you a million times for your help on this one. All is pukka  now - more or less!

No worries, 

glad it worked out.