G-Speed Studio XL Red light Drive Gspeed2Util Bad CPU type in executable(SOLVED)

I have a G-Speed Studio XL that recently went red light and red G on 2 of the drives after a brief power failure. I am aware that this is cause by a desync between the drives and the raid controller. I am also aware that the way to resync these drives is using the Gspeed2util CLI in the terminal but…

I am using a 2011 Macbook Pro to control the NAS over Thunderbolt 2 and when I try to use this command I get the Bad CPU type in executable error. I am led to believe that this is caused by it being a 32 bit command and the Catalina 10.15.7 on my Macbook is 64bit.

I have scoured these forums and other attempting to find the solution and have tried many things including:

rebooting my Macbook into 32 bit using sudo systemsetup -setkernelbootarchitecture i386
running it in the terminal in 32 bit using Arch -i386 command

None of this works and I am at a loss as to how to fix this.

Are my options really to either, reinstall a 32 bit operating system on my macbook(assuming I can find one), or toss the G_Speed Studio XL’s(I have 2) in the trash and spend money on something more modern.

Does anyone have a way to make this command work or to resync these drives on a 64 bit OS?

Thank you to any who can help


My solution in the end was to reinstall MacOs Mojave, the last 32 bit OS before Catalina went 64 bit, and the I used the CLI gspeed2util terminal command to bring the drives back online. I have left the 2011 Macbook Pro with Mojave installed, as its only purpose is to control the drives and allow network access and put all of it on a UPS so a power failure doesn’t cause this problem again.

Frankly not supporting this command past 32 bit OSes is a bit of a customer service failure on the part of the devs. If these devices are that susceptible to power failure errors there should be a way for 64 bit users to fix it. It certainly wasn’t a simple process to get the app store to give up a copy of Mojave, every download kept failing, and i had to use third party utility’s to get a stable image and create a bootable USB.

Hi @Scodavvyy ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: