G-RAID with Thunderbolt Configurator Incompatible with MacOS Ventura

One of the disk drives in my G-RAID with Thunderbolt running in RAID 1 configuration failed this week.

Yes, I opened a case and have tried working with tech support multiple times to rebuild the RAID with the configurator, but in every attempt, it doesn’t detect the unit, even though the iMac mounted it on the desktop, and tech support said that they know that “sometimes it doesn’t work with Ventura”.

Does anyone have any ideas on how to rebuild the RAID, in this instance? I’ve bought a new drive on Amazon (WD was out of stock and had no timeline for availability) and installed it, but the configurator still doesn’t see the device and the light next to the drive is red, as well as the big G on the outside of the case.

Hi @cmhammon,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

@cmhammon I am not sure why @Keerti_01 is telling you to open a ticket instead of just telling you the facts.

  1. The G-RAID with Thunderbolt Configurator has not been updated in over SIX YEARS. Yes you read that correctly.
  2. The G-RAID with Thunderbolt Configurator has not been supported by the latest MacOS in over THREE YEARS.
  3. They continue to sell the G-RAID and they say on the web page for the G-RAID with Thunderbolt Configurator that it is supported on Ventura, but this is not true.
  4. I have opened multiple tickets, and eventually they capitulate and admit that it is not supported on Ventura. They have no plans to support this product going forward, they have essentially abandoned it. They will just tell you to find a VERY OLD Mac, to try to see if you can plug the G-RAID into it and install their SIX YEAR OLD software to see if you can make it work. Or to find a Windows PC and try to get it work work on there. It does not make sense that they just can’t hire a single Software Developer to fix this program. As I have said, its been years since this has worked on any modern version of MacOS.