Does Configurator for Thunderbolt work for anyone?!?!

I have a Sandisk Professional 12TB G-RAID 2. I can access it just fine, create partitions, read/write files. It works over thunderbolt as well as USB3. The Configurator for Thunderbolt utility does not work however, it does not recognize my G-RAID 2. I have tried:

iMac 2019 12.6.1, then upgraded to 12.6.2. GRAID was the only device connected via thunderbolt.
MacBook Pro 14" M1 12.6.1 again GRAID was only device connected
Mac Studio 13.1, my Apple Studio Display was also connected via Thunderbolt

I tried both Thunderbolt and USB3. I tried multiple cables. I tried both Thunderbolt ports on back of GRAID-2. Im getting the same results as many others in this forum, the software simply does not see my G-RAID2. So I have to ask, is it working for anyone running 12.6.1 or later?

I am using version 1.1(52) directly downloaded from WD website. I have an open support case.

1 Like

HI @bfeeny,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I am using an old iMac 2015 running the same version of Mac OS (12.6.1), connecting to a G-Raid 2 12TB*2 via USB3. The system recognises the drives most of the time but there are still occasions that I could not find the drives via Finder and Disk Utility. It seems like I must turn on the G-Raid a bit earlier before I turn on the Mac; if I turn it on after the Mac is already running, it will not be recognised.

About the Configurator, I realised that I must trigger some action with the drives (e.g. open a file) for the Configurator to see them, otherwise the Configurator will not recognise them.

No, the limp dicks at G-Tech, WD, SanDisk have decided they don’t need to support their hardware anymore.

Yes, also had a conversation with them. Seems more like burying their heads into the sand and pretending they never released their hardware. It’s such a ■■■■■■ move from such a big company that I’m not willing to spend more money in the future on their products.
Shame on you WD!

Was there ever a solution to this? I’m running into this now with the Configurator not seeing a G-RAID Shuttle 8, but I can see it in Windows Explorer. I’ve written WD support but have yet to receive a reply.

WD doesn’t give a ■■■■ about Mac users. It’s been a half-dozen versions of the OS, like 5-6 years and they haven’t updated basic software to support the products they sell TODAY. yet they still claim Mac support, deceptive!

1 Like