G-RAID Thunderbolt 3 16TB connected to Thunderbolt 2 port on iMacnot recognised


#1

Just received , here in Sydney, the G Raid with Thunderbolt 3 16TB bought from B&H. I have an iMac 15.1 27" late 2014 5K Retina, with 2 x Thunderbolt 2 ports. I am running Sierra 10.12.6
I have connected the G-Raid as follows: inserted in to one of the G-RAid Thunderbolt ports is the male end of thew Apple Thunderbolt 3 (USB-C) to Thunderbolt 2 female adaptor cable. Then connected to the female Thunderbolt 2 end is an Apple Thunderbolt 2 to Thunderbolt 2 cable, which is connected to one of the two Thunderbolt 2 ports on the iMac.
I have attempted numerous times to mount the G-Raid, but it is not recognised. I have disabled my firewall and removable media blocking software (Eset). I have changed connection to alternate ports on both the drive and computer. I have turned on the G-RAID after booting up computer and tried turning on before booting up.
The G-Raid does not appear in Finder nor in Disk Utility. In “About Mac” I see that the Thunderbolt ports do not see the device.
Thunderbolt Bus:
Vendor Name: Apple Inc.
Device Name: iMac
Port:
Status: No device connected
Help!


#2

Additionally I mention that the “G” light on the system is white.
I have also removed and replaced both drives.


#3

I have also tried to connect to the iMac USB port using the cable supplied with the G-RAID, Thunderbolt 3 to USB - still would not recognise it. But my two other external G-Drives (not Raid) and a Seagate drive connected by USB are and always have been recognised. So the issue relates to the overall connectivity of the G-Raid. But strange that my Macbook Air instantly recognised it using the Thunderbolt/USB-C cable.


#4

Answering only to say: I have the exact same problem.


#5

So the device works on your Macbook Air but not your iMac? on your iMac I would suggest trying to reset the SMC and the NVRAM. Reset the SMC on a MAC

The only requirements for a TB3 device like this is that you are on 10.12.x+ and since you are on Sierra that is all you’d need. Obviously the hardware on the device is working if it shows up and is usable on another computer.


#6

Hi. Thanks for your response. However I have the STC AND VRAM resets. To no avail.
Yes it is recognised on the laptop. But while my other G-Drives are connected and recognised on the USB ports, the GRaid is not when I use the supplied Thuderbolt3/USB cable. And not as I have explained either Apple cables.
What else can be tried?
Thanks


#7

I have now connected the G-Raid using the USB-C to USB-A cable. The USB-C end is connect to the unnamed slot back of the drive unit adjacent to the power connection (and which is not shown in the product brochure) and the USB-A to the port on the computer. The drive is now recognised. But I will only get transfer rate of the USB and not the Thunderbolt rate I had expected when specifically purchasing this product. I plan to see a Mac service store tomorrow to try and resolved the Thunderbolt connectivity.

NEXT ISSUE: setting up RAID 1. No instructions. Searching the https://support.g-technology.com/KnowledgeBase/answer.aspx?ID=15105, I found G-Technology RAID Configurators & Utilities, then a link to “Answer ID 14045: How to use Disk Utility to Create a RAID 1 Array”. But this relates to the Disk Uitlity that was discontinued by Apple with El Capitan. Fortunately I found a link to Macworld "How to configure a software RAID in macOS Sierra’s Disk Utility
So I have been following the clear instructions in this article. BUT I have become stuck.
Referring the step-by-step procedure in the article, I have opened the Raid Assistant from the Disk Utility down menu, then selected “Raid 1”, and clicked to next page. There I have the option of ticking the higher or lower reference to the G-Raid Thunderbolt 16TB (and selecting “Slice”. Not sure which should be selected, but regardless then the Next button is greyed out and I cannot proceed.
Please advise and clarify the procedure and any reformatting etc that is required. Not the simplicity I expected.

Configuring Raid in Sierra


#8

The performance will be the same on USB 3 and TB3.

Hard drives aren’t fast enough to use up TB3 theoretical ceilings. It takes 3 or more drives in a RAID0 to overpower what a USB 3.0 is capable of and to start using TB speeds.


#9

Understood. But if this is the case why structure a 2-drive system with Thunderbolt, and extol the benefits transfer speed, when it will give no benefit over USB-A?
UPDATE: I went to my local Apple Store and I exchanged the adaptor cable (Thunderbolt 3 (USB-C) to Thunderbolt 2) which I had bought last week. The when I connected this to the Thunderbolt port on the G-RAID and the Apple Thunderbolt 2 - Thunderbolt 2 cable to the iMac’s Thunderbolt 2 port, and Viola!! - the computer recognised the G-RAID. So the issue all along was the faulty Apple adaptor - who would have thought?

Re the Raid configuration issue I am having, as explained above under “Next issue”.

The packaging says one can choose between Raid 0,1, or JBOD - I would think that G-Drive icon or app would do this. Only by reading other posts on the forum did I see that there is a “G-Raid Configurator”. I searched Downloads and found the utility at [ https://support.g-technology.com/downloads.aspx?lang=en] “Download the latest version of the G-RAID Removable with Thunderbolt Utility (TB2/TB3)”. Having downloaded and followed through the steps (and “ignored” the prompt that said “your computer cant’ read this disk”, the configuration as Raid 1 was completed. I then erased the disk in Disk Utility and it was then re-initialised as Mac OS Extended Journalised as 8TB.
I trust this is as it should be?
(I note that a huge 1.49 GB is already used!)

Can I recommend that in the user manual that is only available on download one is pointed toward the right link/s to download the appropriate configurator, and then then would be far fewer people searching for answers to the same set-up questions on your forum.