G-RAID 16TB Thunderbolt 2 Not mounting


#1

My drive is not mounting via USB 3 or Thunderbolt 2. Occasionally the drive will mount but will unmount after a certain amount of time (e.g. 20 mins). I did research here and Apple’s community and tried the following to no avail.

  • Used a different Thunderbolt 2 cable
  • Used the USB 3 connection
  • Tried both ports on the back of the drive and in my laptop (MacBook Pro Late 2013)
  • Powercycled the drive
  • Turned off the drive power and made certain the drives were seated correctly

Sometimes the “G” on the front of the drive will light up, sometimes it will not even though I hear the drive’s spinning.

I went to the System Report / System Information > Thunderbolt and see the drive is recognized there. Please advise what I can to mount the drive and access my files again. Thank you.


#2

Attached is a screenshot of the information provided by system information when the drive is connected, but not mounted.
58%20AM


#3

Verify you are using the proper power adapter. What you’re experiencing sounds a lot like it is under-powered. The unit should be attached to a power adapter with ratings of 12v and 4 or 5a.

If you have verified you are using the correct adapter then the issue would be with the enclosure on the unit. If it is still within warranty then you can generate an RMA for the chassis(enclosure) on our site here: RMA Creation

If you create an RMA for this chassis (use the chassis SN, do NOT send drives along, only the empty enclosure and no cables.)


#4

Thank you for the response. I am using the power adapter included with the unit. The rating is 12v and 5a.

I will generate an RMA. Thank you.