G-RAID 12TB Thunderbolt 2 working but not mounting

Hi, I have three G-RAID STUDIO 12TB external Thunderbolt 2 hard drives. Two of them mount properly on the desktop, but one of them all of a sudden does not. The one that doesn’t mount appears to be working just fine, i.e. the power supply light is green, the drive LED lights are blue, the fan is on, the discs are making normal reading noises, etc – it behaves exactly like the other two, but it still doesn’t mount (or appear in any software application), regardless of restarting the Mac and resetting the PRAM… I’ve tried the failing drive with a power supply from one of the two drives that works, and I’ve tried different Thunderbolt cables, all to no avail. I’ve also moved the two 6TB drive units from the failing drive to one of the working drives, and then the drives mount properly. This leads me to believe that there is no problem with the actual two 6TB drive units (all data came up intact), but rather with some part of the hardware of the failing drive’s chassis.

I have filed a support case with G-Technology, but I thought I would check here too if anyone else has had the same or a similar problem, and if so how that was resolved?

Also, although I did receive an id number for this case, I haven’t received any confirmation response (which I was informed would be sent to me immediately), so if anyone from G-Tech support reads this, then please look into this case and comment here (as it may be that your emails get held up in a spam filter somewhere en route to my mail server and never reach me…) – thanks,


Hello Mark,

Please check your email we have requested some details and informed out EMEA team to prioritize your contacts so that we can resolved this quickly.