G-Drive Thunderbolt 3, 6 TB won't turn on

#1

I carefully moved/connected my G Drive Thunderbolt 3, 6TB drive from a 2016 Mac Mini to a new 2019 iMac. It was working fine on the Mac mini before disconnecting it. The power cord was plugged in and G-drive was connected to the iMac using a Thunderbolt 3 cable. It was working fine for about 10 min on the iMac while I was perusing photos in Lightroom Classic. Then all of the sudden, I get a iMac message that the G Drive was ejected inappropriately. No light on the G-drive and the iMac was not seeing any mounted G drive.

Things I’ve tried that have NOT worked:

  1. Unconnected it from the iMac and reconnected it, making sure the Thunderbolt cable and power cord were correctly plugged in.

  2. Connected the G-drive using a USB 3.1/USB C cable instead

  3. Connected the G-drive using a different power cord from a 2nd G-drive I own. Both power cords work fine on the 2nd, functioning G-drive, but not the one that’s causing me problems

  4. Tried different combinations of the 2 power cords, USB 3.1 cable and Thunderbolt 3 cable.

  5. Tried connecting to different 4 USB ports and 2 Thunderbolt ports on the iMac

  6. Tried to see if Mac Disk Utility could even see that the drive was connected. Mac Utilities doesn’t even see that the G-drive is on and mounted.

Now what do I do? The non-functioning G-drive was purchased at B&H Photo in November, 2017. I also have 3 year coverage plan with Square Trade.

Thanks in advance for any suggestions/help.

Ed (Cosmonaut1961)