G-Drive powers up but won't mount--deeply frustrating lack of support

G-Drive powers up but won’t mount [Incident: 230130-000215]-mounting via Disk Utility gets: com.apple.DiskManagement.disenter error 49244

I tried Support from this community.wd.com site, which sends me to this page

and G-Drive support support-en.g-technology. com/app/ask which sends me to the same. (I had to add spaces in front of the dot-coms in order to post this Topic.

My Ad-block is off.

I’m so deeply disappointed at how far WD/G-Drive Tech has fallen from its former superior service.

I’d already informed support that I’ve tried three different Macs with different OSs (including the Mac that originally mounted this drive a few years back), three different cables, and all the USB ports.

Disc Utility (connecting to a Macbook Air via USB-3-to-USB-C) finally allowed me to see the drive, but mounting it resulted in the error code:
com.apple.DiskManagement.disenter error 49244

I have spent two ridiculously useless hours on Chat with a support person who sent me all the same information as the email I received back from support. In case anyone else can benefit from that information (and not waste so much of their time):

| — | — | — |
|Reference #:|230130-000215|
|Subject:|G-Drive powers up but won’t mount|

Response by Email Eric M
(01/31/2023 10:48 AM)

Dear Heather Ordover ,

Thank you for contacting G-Technology, a Western Digital brand Customer Service and Support. My name is Eric M.

I understand that your G-Technology G-DRIVE is not mounting on your macOS. We will surely assist you.

As per the email received, I understand that the drive is not being detected. I apologize for the inconvenience.

Please be informed that these might be the possible reasons for the issue:

  1. The USB cable is broken
  2. The USB port is malfunctioning
  3. The USB adapter is not working properly
  4. The external hard drive is not formatted correctly
  5. The hardware and software like disk driver need an update
  6. The file system of the external hard drive is corrupt

To troubleshoot your issue, please provide the following information:

  1. Have you tried to plug the drive into a different USB port?
  2. Have you tried to connect the drive using a different USB cable?
  3. Have you tried to connect the drive to another computer?
  4. Have you performed any other troubleshooting on the device?
  5. Do you see any error messages when you connect the drive to the computer?
  6. Is your drive visible in the Disk Management or Disk Utility?

Please refer to the following articles for accessing Disk Utility on various Operating Systems:

How to access Disk Utility on macOS
support-en.wd. com/app/answers/detail/a_id/3823

Also if you have tried all the above-mentioned troubleshooting steps and the issue follows and the drive is showing up in the disk utility then, I would request you to try the below-mentioned steps in order to resolve the mounting issue:

  • Launch Disk Utility and click on view all
  • Select the main media partition the of the drive and click on mount
  • If mount option is not accessible then try running first aid on the drive

You may refer to the below-mentioned article to access the Disk Utility

macOS: Access & Use Disk Utility
*support-en.g-technology. com/app/answers/detail/a_id/3823

If the above-mentioned steps do not resolve the mounting issue then please follow the below-mentioned steps:

  • Open Activity Monitor and under CPU look for FSCK_HFS or FSCK_EXT option
  • After locating the above-mentioned options you have to force quit these option
  • After force quitting these options the drive should mount after few mins

If the issue follows then it may an issue with the file system which might have been corrupted and we can either try to erase the drive but since you may have important data on the drive, we certainly cannot erase the drive. Currently, you would either need to try and repair the drive with a third party software, or recover the data and reformat. We do have two software’s you can look into:

I would recommend you to perform self help data recovery in order to retrieve the data from the drive. Please refer the link mentioned below to know more:

Alternate 3rd Party Data Recovery Options
support-en.wd. com/app/answers/detail/a_id/18754

Refer> Disk Warrior to try and repair the drive
Data Rescue to try and recovery the data and then format

If the data is still not recovered, then you may need to contact professional data recovery team to recover the data for you.

Moreover, I am sorry to inform you that G-technology, a Western Digital brand does not provide Data Recovery services nor do we reimburse the cost of the Data recovery services performed on the drive. However, you may contact professional data recovery partners to help you recover the data. Please refer the link mentioned below to know more:

support-en.g-technology. com/app/datarecovery

If you have any further questions, please reply to this email and we will be happy to assist you further.

Eric M.
G-Technology, a Western Digital brand Service and Support
support.wdc. com/gtech/ <<—and this link on the email also results in image above?!

Note: If you have not visited our community forums, please make sure to do so. You may also find answer(s) to your question(s) there. Link to WD community forums at: G-Technology - WD Community.

This electronic message contains information from Western Digital, is intended only for the use of the addressee and may contain information that is confidential. The dissemination of this information is strictly prohibited. If you have received this electronic transmission in error, please respond back to this e-mail or contact us by phone.

In order to process your email, please do not remove this reference #: 230130-000215

At this point, ALL I’m trying to learn is the following:
what does this error code mean:
com.apple.DiskManagement.disenter error 49244

Screenshots of my entire process today: