G-Drive Won't Mount


#1

Hello my G-Drive USB Mobile 1TB will not mount on my macbook pro. I have tried using disk utilities and I repair it and verify it and it says everything seems to be ok but the only problem is it will not let me mount it. It gives me the option to restore, raid and erase but my only concern is I don’t want to lose what’s stored. Any Help Please??


#2

The volume is corrupted. If the drive was kept as Mac OS format out of the box then you can rebuild it with a more powerful repair utility we recommend called Disk Warrior.


#3

Hello. I have a similar problem. On my older G-Drive (USB 3.0), I know that the volume is corrupt. However, I cannot get it to be recognized by Disk Utility, Disk Warrior, or Drive Genius, to rebuild or reformat it. I am running a MacBook Pro, Mac OS X 10.12.3. Is there any other method by which I might be able to get the drive rebuilt / reformatted / usable? Thanks.


#4

If the computer and no software is able to actually detect the device that means it is hardware failure not software corruption. You cannot repair hardware issues with software.


#5

Hello, My problem is similar as well, but my G drive is showing that it is connected in the Disk Utility and Mac System Profiler. The problem is that it does not appear on the desktop so i can access it and it shows that it’s at full capacity when i know it’s not. I ran the first aid option and it said everything was fine. So I’m just confused at this point. Please help, thank you!


#6

@Elizabeth_Olivares,

in your situation if you left the drive as is out of the box and didn’t change the format then you will need to run a repair software like Disk Warrior to rebuild your corrupted drive.


#7

Same type of problem with my 8T G-drive. Shows up in System Profiler, but will not mount or show up in Disk Utility. HOWEVER, it does mount on another iMac. How can that be?


#8

@StuartVail,

Has your drive worked on that computer in the past? Which version of the Mac OS is your computer? What drive do you have specifically? Is it the Thunderbolt 2 or 3 model?

When trying it on another Mac, what OS is that one on?


#9

You’re not going to believe this this. It was the power supply. Looks identical to another, and somehow they got swapped. I was using 12V 6A instead of 19V 3.2A. The 12V was enough to turn on the drive, so things looked normal, but it just wouldn’t boot.

Thanks for taking the time to answer. You can add this to your knowledge base.

Stuart


#10

Hello. I have a similar issue here… G-Drive USB Mobile 1TB that was working just fine (software wise) and it all the sudden went down. Since I have not been able to mount it… It shows in the disk utility but will not let me run First Aid. Says the “process failed.” It still shows up in the System Report. Any idea or suggestions would be appreciated!


#11

@tp2017

Your issue is vastly different in that it is not hardware or power related. Yours is software corruption. The Apple First Aid is very under-powered and usually doesn’t work.

In order to rebuild your drive you would need to use a more powerful 3rd party software such as Disk Warrior or if the data isn’t important just Erase the drive in Disk Utility and begin anew.


#12

Hi, my problem is that my G-DRIVE PRO with Thunderbolt won’t mount in any computer, the power goes on and it seems like is working properly but it won’t mount or appear in disk utility. Is that a hardware o software problem? What can I do?


#13

@evba,

Make sure your power adapter is 12v and 4a. If it still won’t recognize even on Disk Utility then it is hardware failure either in the drive or the enclosure. If it is within warranty you can create an RMA on our site to get a replacement.


#14

In Disk Utility, highlight the “mounted” drive, then click the “mount/unmount” button twice to toggle the state. This will make my own drive now appear on the desktop- but it’s at an age now where I feel it’s time to swap mine out anyway


#15

Hi there,

I’m having issues with my brand new 4TB G Raid drive. I was able to mount and view it on the desktop of one macbook (Version 10.13.14 macOS High Sierra), but not the other (Version 10.12.1 macOS High Sierra). I erased the drive as soon as i got it through disk utility on the Version 10.13.14 laptop so that its fresh to use. Should I restore the drive on the computer that recognizes it? Does anyone have any idea for why this is happening?

Thanks


#17

My new drive won’t work in High Sierra Os. I have 2 mobile usb drives that will work on another Mac (El Capitan)


#18

There is nothing in the drive that would stop it from working on High Sierra. There are no incompatibilities.

Make sure you check in your Finder > Devices list to see if it shows there, If you don’t have the Finder Preferences set to show external drives on the desktop it will always show there.

Also check your Disk Utility to see if it is recognized there. If the drives still mount on another Mac I would suggest transferring any data off you need on it to the other drive and then Erasing it in Disk Utility to clean off any possible corruption that might stop it from mounting on a new OS.