G-Drive Won't Mount

#22

Disk warrior will only be able to repair the Mac partition.

#23

Hello

My G Raid 8T doesn’t mount at all in my Mac book pro. The system in my computer was having trouble to recognize the drive (which it was weird). Basically I could hear the G raid trying to mount but no icon of the drive on the desktop. Now the hard drive only turns the light but it doesn’t mount at all and it doesn’t show in the disk utility or desktop. I had direct thunderbolt 3 connection. Is there any solution for this? Is there any way I can get my information back?

Many thanks, IPS

#24

You can try attaching it with USB to see if perhaps the connection over TB3 is part of the issue. If it shows in Disk Utility or mounts fully on USB then you can proceed with a replacement Thunderbolt cable if needed. However if it doesn’t get recognition at all then the next thing to check is the power adapter.

If it is a Thunderbolt 3 G-RAID then it will have a 19v 4.74a adapter. If it is a Thunderbolt 2 or 1 G-RAID it will use a 12v 4a adapter. Make sure you are using the correct one and if it still isn’t working then it would be a hardware issue and if it is within warranty you can generate an RMA to get a replacement on our website. RMA Creation

#25

Hi there.

My brand new G Drive 1TB Mobile SSD R-Series just arrived in the mail. I had just finished loading 400GB’s of data onto it and it was working fine, until I just plugged it back in now and it’s no longer mounting. I tried to run First Aid in Disk Utility and it said the process had failed. From reading the other comments, it would seem that the software has been corrupted and I could try erasing and restoring the drive. I’m confused as to why / how the software has become corrupted this early on, and how I can prevent this from happening in the future, as I’ve only just started using the drive and want to have peace of mind that it won’t become corrupted again. I would rather not have to erase the drive or purchase Disk Warrior at this point. The drive was connected to my computer as it died last night. Could that have caused the software corruption problem? I was also running it through a USB hub for some of the transfers I made. However I’m now plugging into the Macbook Pro directly and still it’s not mounting. Please let me know if you have any other solutions to this problem and how I can prevent this from happening again in the future. Thank you!

#26

If your computer goes out while drive is in use on it then it is counted as an improper ejection and can cause corruption.

You also want to stay away from hubs if possible. But yes in your current situation only erasing and starting over or using Disk Warrior to rebuild the drive will bring it back to being usable. You want to make sure the drive is not disconnected without being ejected properly or it can cause corruption.

#27

I have a G-RAID 8TB drive that will only mount intermittently. I must plug it in and power up multiple times until the drive will finally mount onto my desktop (mac) I am using a thunderbolt cable and have replaced the cable without any difference. I have never had it fail to mount but sometimes I must unplug it and power it down many many times before it finally mounts. This last time it took me an hour to finally get it to mount. Any help on solving this problem would be great.

#28

I have a 10TB G Drive. After connecting it to a Nighthawk R7000 Router using ReadyShare for network and remote access, G Drive won’t mount on iMac (Mojave) or Macbook Pro (Sierra). Run First Aid on Disk Utility which said drive is fine. Please help.

#29

The G Tech drives I purchased are all defective. The connection to plug in the cable that goes to the computer is slightly distorted or just too large. This allows the plug on that end to be inserted into the drive but the connection is shaky at best and at some point it stops working. Or it will be seen by the computer off and on as it’s an improper fit. Loose connections from the start are bad news and I have lost two 4 TB drives of data. They seemed like great drives at the start. They were no cheaper than any other. I was just looking for something other than WD drives so it would last and the G Tech are not the answer.

#30

I faced the same problems today. I read this series of help notes from the community. My G-drive mobile SSD 500gb was password protected using iMac disk utility. I run OS Mojave 10.14.4. The drive did not show in Finder. I ran disk utility repair. No luck. It told me the disk was full, no free space. I right-clicked on the logical volume Mac OS Extended [Journaled, encrypted] and chose mount. At this point the disk prompted me to enter my password. It was restored to Finder and appeared on the desktop. It now showed it had 232gb free. It is returned to use. I am much relieved. It had months of unique files, all personal, that I was archiving and also writing. I hope this might be an answer to some G-drive owners who experience this issue. The drive is a few months old. Best wishes to you all

#31

Further notes on G-drive issues mentioned in my post yesterday. The R-series drive could be mounted through disk utility but it wasn’t loading automatically. So I looked for more help and came across the SETAPP website which suggested a reset of NVRAM [shutdown, wait 60s, restart and immediately hold down four keys: alt + cmd + P + R for 20s]. It worked. For details see other useful notes at https://setapp.com/how-to/how-to-access-external-drive-thats-not-recognized-on-mac
NVRAM [non volatile random access memory] stores things like screen resolution, time zone information, and which hard drive to boot from. Plus lots more.

#32

If possible can you help me?
My G Drive USB 4TB is plugged in correctly, connected to my computer as it has always been and the light is powered on but there is nothing happening. It’s not starting up. I can’t hear anything happening from it anymore, when I put my hand on it, usually I can feel it running. I’m getting nothing and my Mac is not recognizing it at all. Any way to fix this without sending it in for warranty? Any help is much appreciated.