FTP, dynamic ip - a lot of problems with config ftp

I have a lot of problems with my cloud. FTP does not work. Here is my configuration on router (tp link archer c2, dynamic ip. I have reserved an address for my cloud on dhcp settings)

In my cloud ftp port is, I dont know why, 990. In my cloud settings I have changed dhcp to static ip and set correctly. Device has internet connection but FileZilla says (port 21):
Status: Connection established, initializing TLS…
Status: Verifying certificate…
Status: TLS connection established, waiting for welcome message…
Status: Server does not support non-ASCII characters.
Status: Logged in
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/” is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (here was ip numbers)
Command: MLSD
Error: The data connection could not be established: ECONNREFUSED - Connection refused by server
Why? What should I do to have ftp access over the internet?

Why is there a “virtual server” entry? Normally one just uses a port triggering entry.

Try disabling that “virtual server” and see if remote FTP connections work.

It should be noted that FTP is NOT a secure protocol. Generally the username/password used to log into the FTP Sever (on the My Cloud) is sent in the clear and can be intercepted.

When connecting via the internet one uses the broadband IP address of their local network. One may have to do an internet search for “what is my IP address” to find their broadband IP address. Some may want to use a DDNS service if their router supports if when their broadband IP address changes due to the router being power cycled or the broadband IP address lease running out and a new IP address being issued. There are a number of free DDNS web sites out there.

1 Like

I have disabled that virtual server, set ddns on router too… But, if ftp is not secure I will not use it. I disabled ftp, mycloud sync is secure and I can drag and drop files as well as I do on finder or explorer. Thank you for help!

You can also use the WD My Cloud Desktop program for remote access if needed. Same goes for the MyCloud.com web portal. Both will allow you to upload content to the My Cloud from a remote location. If using a mobile device there are WD mobile apps for Android and iOS that will allow for remote access and file uploading/downloading.

On the local network just use Windows File Explorer or Mac Finder. One can “map” the My Cloud to their local network PC to make access easier/quicker.

Every attempt I’ve made to the MyCloud device through FTP has failed. Believe it or not, using SSH works perfectly and is the perfect replacement for FTP. Simply do this:

  1. Go to your router’s port forwarding and configure port 22 to your device

  2. Download (for example) WinSCP and create a new entry using your the IP address (192.168.x.x) for your device on port 22

My router allows me to connect remotely. If yours also does, follow their instructions and again point to port 22. I tested this on my phone using mobile data (i.e., disabling WiFi) and it works like a charm.

Keep in mind the default ROOT login and password are “root” and “welc0me” (sans quotes). You can change the password if you want.

This simple method did NOT work with FTP. I can’t understand why the developers made connecting with FTP so notoriously difficult.

If you allow external SSH access to your device, I would very strongly suggest that you disable the root account, and certainly change the password. Otherwise, you are leaving your device very vulnerable to hacking.

I’ve already changed the default root password. Disabling the root account is out of the question, the only way to access your files via SSH is with a root login - at least as far as I know.

If a boogie man to access my files, he’d have to know my router login URL as well as my new root password. Then again if this were FTP and he had this information he could clean me out just the same. In fact, he could do the same if he just borrowed my phone and used the WD app.

Be advised that if anyone deserves the blame for this situation, it’s the developers. They’re the ones who have made it next to impossible to use FTP and extremely easy to use SSH. You gotta to with what works.

While I don’t normally have it active or use it, I have no problems using FTP both locally and via remote access in the past using the FileZilla FTP client (https://filezilla-project.org/). If your having problems it generally is related to your broadband provider (blocking FTP/port 21, or changing the broadband IP address) or your router (improperly configured).

If your broadband IP is changing and the My Cloud FTP server becomes inaccessible that isn’t the fault of the My Cloud or its developers that’s the fault of your broadband provider. There are potential workarounds to a changing broadband IP address, those workarounds include using a free DDNS service and using a router that supports using DDNS.

Let’s see if we can make FTP work.

I have a my own cable modem connected to my Asus AC3200 router. I can access via FTP any media I connect to the router’s USB port, both locally and through Asus’ DDNS service.

Tech support at Asus says I should be able to access the WDCloud via FTP. All I need to do is forward a port (or port range) to the device other than 20 or 21 (which are used internally to access USB media) and that should do the trick. Every time I’ve tried to this, it responds CONNECTION REFUSED. This stategy, however, works perfectly with SSH (SFTP), both locally and via DDNS.

I use the root login and password for SSH (SFTP). I’m assuming this won’t work for FTP because it involves less security. Using the same login and password which worked perfectly on the CM Cloud Android app didn’t work on FTP.

Did I miss anything? Please explain how you set your router up to communicate with the device via FTP.

If you are not using the FTP option (or USB port) within or on the Asus AC3200 router one can usually disable it via the Asus router administration interface. One generally just uses the port forwarding option within the router administration page to forward FTP Port 21 to the My Cloud (normally its IP address. FTP will also need to be enabled on the My Cloud Dashboard > Settings > Network > Network Services > FTP Access = ON.

If one tries to use a different FTP port they will need to ensure their FTP client will support using an alternate FTP port other than port 21.

What is probably happening, then, is that your router is intercepting all FTP traffic, and directing it to its FTP server that is serving the USB content.

So, as Bennor suggests, try turning off your router’s FTP server, and forwarding FTP ports to the MyCloud.

If you can get that to work, then it may be possible to get both the router FTP server and MyCloud FTP server to be accessible, provided you make them respond to different ports; maybe leave the router FTP server as standard, and use different ports for the MyCloud, forwarding as appropriate, and configure your FTP client to access different ports for router FTP and MyCloud FTP servers.

OK, we’re getting there.

I reconfigured port forwarding on my router to FTP port 21. I configured the FTP client this way:

192.168.x.x:21 (internal IP of MyCloud device)
login: xxx@email.com
password: xxx <— same values as Android MyCloud app

Now it says this:

“Welcome to the MyCloud
USER xxx@email.com
530 Permission denied”

When I press “Cancel” the FTP client prompts me to reconnect. I now believe there is nothing wrong with the router or its configuration. It’s the MyCloud device that isn’t letting me in. I tried this with another port and got no reply. Apparently the MyCloud’s FTP is hard wired for port 21 and won’t respond to any other. FTP and SSH are both enabled, I’ve checked and checked again.

BTW, just to make things simple, on device there is only one user and one share (Public). All others were deleted. I don’t know if maybe this has anything to do with it.

Let me mention once again that despite being less secure, SSH (SFTP) works perfectly with no problems of any kind and can be accessed both locally and through DDNS. Because of this I don’t really need FTP, but I’d like to see if I can make it work regardless.

Any ideas?

You use the User name and password created through the My Cloud Dashboard when logging into the My Cloud FTP server not the email address and password used when one created their MyCloud.com account for remote access.

I went into my profile and checked the username. That didn’t work either. The strange thing is that logging into anything with the username doesn’t work (“anything” meaning web site and Android app), only the email address is accepted regardless of local or remote access.

You know what? I give up! To anyone else having a problem, don’t bother with this and simply use SFTP. It works perfectly and is fully supported by Filezilla. As a precaution, first change the root password and configure Filezilla to go directly into your shares. That way you’ll avoid accidentally interfering with the device’s Unix-like file system.

1 Like