FTP issues from external network for firmware v04.04.02-105

Does anyone have any issues with FTP on the latest firmware (v04.04.02-105)? I’ve only just upgraded today and already running into issues…

FTP is enabled in My Cloud dashboard. I can FTP from internal network, I can telnet to port 21 (again from internal network) so it’s definitely working. If I turn off FTP in the My Cloud dashboard and try to FTP or telnet, it doesn’t work as expected. So that part is fine.

Obviously, to FTP from an external network, port forwarding needs to be setup. I haven’t touched the port forward settings that already exist on my router. They are the same settings that worked for me prior to me upgrading the firmware on my WD My Cloud. I double checked the settings anyway, points to the same internal IP and same port (21) and everything checks out OK. I just can’t telnet to it using my external IP.

On the My Cloud dashboard, I can see that it says port forwarding established for Remote Access. I know this isn’t for FTP and is I believe used for accessing mycloud.com (which works for me), but still it leads me to believe that it’s accepting port forwarding OK.

I’ve rebooted both my router and my cloud several times.

If I do a open port scan using e.g. this:
http://www.ipfingerprints.com/portscan.php

I can see that ports 80, 443 AND 21 are opened. So this leads me to believe there’s nothing wrong with my router, after all I haven’t upgraded or touched it in ages. The only thing that was changed was me upgrading the firmware on my WD My Cloud. While 80 and 443 works on it, 21 doesn’t. Not sure if it’s not accepting inbound on 21 or something? The thing is, I also checked /etc/vsftpd.conf and can see it’s listening on port 21 and listen is set to enabled.

ftpd_banner=Welcome to WD My Cloud
listen=yes
listen_port=21
accept_timeout=60
connect_timeout=60
data_connection_timeout=300
max_clients=0
max_per_ip=20
xferlog_enable=YES
hide_ids=YES
dirlist_enable=YES
download_enable=YES
use_localtime=YES
write_enable=YES
file_open_mode=0755
local_enable=YES
local_umask=02
local_max_rate=0
anon_root=/nfs
local_root=/nfs
check_shell=NO
chroot_local_user=YES
userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/user_list
vsftpd_log_file=/var/log/vsftpd.log
anonymous_enable=NO
anon_mkdir_write_enable=NO
anon_upload_enable=NO
anon_world_readable_only=YES
anon_other_write_enable=NO
no_anon_password=YES
anon_max_rate=0
anon_umask=077
#share_acl_enable=YES
pasv_enable=YES
pasv_promiscuous=YES
pasv_min_port=5000
pasv_max_port=5099

By the way, my WD My Cloud is set to use a static IP and port forward points to the correct IP…

I’ve also viewed these 2 guides here and already got the correct setup:


1 Like

Firewall?

Paul

Hi Paul,

I thought of that too but that’s definitely not it.

First of all, nothing was changed in the last 24 hours, other than that the WD My Cloud was upgraded from firmware 04.00.00-607 (7/09/2014) to 04.04.02-105 (01/27/2016). Nothing was changed on my PC or on my router.

I checked the firewall anyway, disabled it on my router, also checked it’s not using any DMZ. Unfortunately my router is a bit ■■■■ (it’s supplied by my ISP) so there’s no logs on what’s coming through the firewall. I could probably telnet to it and enable some features, but I can’t be bothered and I KNOW that shouldn’t be the source of the problem.

I’ve also disabled firewall on my PC and tried telneting to it via my external IP (e.g. telnet 123.111.44.5 21) and it still doesn’t work.

So how do I know it’s definitely not the firewall? Because I downgraded the firmware back to my old firmware and woila, it works again. I can telnet, I can FTP via my browser, as well as FTP via Filezilla.

So something must have changed between the firmware versions. I’m going to check the /etc/vsftpd.conf file tonight, but if anyone else knows why this is the case and can shed some light on this, that would be great…

I sort of regret upgrading the firmware. When I was still using the stock factory firmware (04.00.00-607), it ran well. Everything worked. FTP, Safepoint, remote access, WD2Go, etc. I don’t use Twonky, but 99% of the stuff worked fine and the performance was decent. While the upgrade went successfully and I got all the tweaks and everything working (including mycloud.com access), FTP just wouldn’t work. Also, it runs quite hot despite that content scan is idle (and services disabled via my tweaks) and there’s no data on it. I’ve been busy trying to get FTP to work that I didn’t even have time to copy data across, and yet the enclosure is quite hot to touch. On the old firmware, it runs really cool.

Also, no idea why WD2Go changed to MyCloud.com and why that wouldn’t continue working. It’s not important to me since FTP is a much better protocol for transferring files anyway, but I’d like to have it as an alternate method of accessing my files, plus the additional features or security enhancements of the new firmware.

No. Remote FTP is working fine on my end with 04.04.02-105 using FileZilla. Have the router’s DHCP server assigning a static IP address to the My Cloud and port forwarding ports 20-21 to the My Cloud. The My Cloud has FTP Access set to On.

That’s exactly what I had setup in the first place. Nothing’s changed. I’ve assigned the static IP out of the DHCP lease range on my router and gave it a permanent lease. I’ve also tried releasing the lease on my router and confirmed the MAC address matches what’s my WD My Cloud.

The 2 links in my initial post explains this in detail as well. It’s straightforward and easy to setup.

The only thing I can think of is perhaps my router doesn’t like the updated firmware. A bit unrelated but devices tend to have WiFi issues after updating their firmwares. My friend had updated the firmware on his iPad or Android and they suddenly lost WiFi access and had to downgrade. I think it may be similar here for me, maybe a compatibility issue with my router, not sure.

Upgraded to firmware 105 again, this time FTP works. No changes on my router etc.

Super weird.