Frustrated with WD Elements Play 1TB mkv

I recently bought a WD elements play 1tb and to my dissapointment it did not play certain mkv movies. The other mkv movies would show picture, but there would be no sound.

I check read the forums on this website regarding the problems and the one suggested that the latest firmware be download. I downloaded the latest firmware available for my WD and when I tried to instal it I got a message that the update was an older version than the one that was installed on my WD so then I did not proceed with the update.

I then came upon another topic that suggested mkv fix tool be used. I downloaded that and all the mkv files was scanned and supposedly fixed. Then I tried playing the movies, some movies still only showed the picture with no sound and the others were playing sound now but it was out of sinc. The peoples lips would move and the sound will only come afterwards.

Then I took one one of the origanal mkv files on my pc that was not used in the mkv fix and I converted it to avi, same problem with the sound that is out of sinc.

I am really frustrated with this now as I have tried everything. Please help, or otheriwse I will have to ask for a refund?


I have strong evidence (too lazy for testing it): WEP does not support header compression of Matroska files.

In order to fix your MKV files, see this thread.

Private advice: if you still have the chance to get the refund, give back the WEP and buy another HDD player.

For most of them, you’ll get much user-friendlier functionality (e.g. copying folders from the USB stick) than WEP offers:

just look at the number of buttons on the remote control.

Note however, that many RealTek based player do no support Matroska header compression, so most probably) you’ll have to fix your MKV files anyway.

Thank you for the Reply.

I sent it back on the 4th of May and I am hoping to get an answer soon on whether they will refund it.