Front LED not light up

Cannot access to MyCloud. Front LED does not light up, even after reset. Back LEDs are green.

Would this be a power issue, or what should I check before I send the product back for repair?

@cychow How old is your device? Is it a 1st or 2nd generation My Cloud? The front blue LED does burn out on the 1st generation, however, it still works as shown by the rear LEDs working. What type of computer and operating system do you have?

My MyCloud is 4 years old - 1st generation. It’s plugged to my router and my usual PC is Win10

@cychow Does it show as being on your network in your router? What type of router is it? Are you able to open the Dashboard?

This could be your problem.

thanks @cat0w. I turned on smb sharing as suggested but it’s still not shown on the network. my router is a linksys.

@cychow Have you rebooted both your router and computer?

I have always used Linksys and both of my devices show on the router and my computer. I reboot all devices once a week.

image

Thanks @cat0w
Rebooted both router and mycloud. Still not shown on the network.
what else can I do before going to the recover way?? it’s over warranty and no repair is likely possible

Access the router’s administration page and review the client DHCP listing to see if the router is handing out an IP address to the My Cloud. Then try accessing the My Cloud Dashboard using that IP address. If you can access the My Cloud Dashboard using the IP address you can, in a pinch, use that IP address in Windows Explorer (ex: \\192.168.1.10) to access the My Cloud.

If still having trouble, one can try performing a 40 second reset which will reset the My Cloud Dashboard to default values including resetting the static IP address optin within the Dashboard to default. No user data is lost performing a 40 second reset.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13986

hello i have the same problem,power led work when i start my disk but later not light blue color,but this work normally

thanks @Bennor my router’s admin page does not show the mycloud
also reset mycloud using 40 second reset, but still not show in router’s admin page
~frustrated

As a troubleshooting step you could try putting a switch between the My Cloud and the router. Certain routers may have a conflict with the My Cloud. WD has the following knowledgebase article covering that issue.

https://support.wdc.com/knowledgebase/answer.aspx?ID=15086