MyCloud not working - front LED does not light up - just Network lights up - no connection though

Hi guys,

bought my WD MyCloud approx 14 months ago. Today I wanted to access my files which was neither possible through my Macbook, nor through the iOS App, nor my TV.
Checked the MyCloud and found out that the front LED was not lighting up - the green network LED was active and I could feel the HDD vibrating.
The drive could not be discovered in my macs network environment and the airport router’s LEDs which normally indicate network connection did not light up.

I tried to reset the device with the 4 seconds reset method which did not work. Unplugged the devices, pushed the reset switch and plugged the device in again, while holding the reset switch for 40 seconds - No result. Still, the front LED does not light up, just the green network LED.

Can you please help me to reactivate my device?

Thanks in advance and best regards


First, for the LED did you check the Dashboard under Settings>General>Energy Saver>LED to see if it is on or off?

Second, did you turn off your router, wait about a minute and then turn it back on?

Third, I take it since you say you have had the My Cloud for 14 months that all the devices have been given access to your My Cloud, if not this can be done in the Dashboard also. Under Cloud access, each user, see what devices are connected.


Since he can’t access the device, he won’t be able to access the Dashboard to do any of that…

As a diagnostic, to see if the thing is even basically operational, what happens if you unplug the Ethernet cable and reset? It ought to flash the front panel LED yellow, to indicate no network connection.

Are the network LEDs flashing to indicate activity, if you plug the network cable in?

Does the device show up as active under your router’s network map? If so, can you access it via the IP address, or even ping it?

Hi guys,

thanks for your comments. It was’t possible to access any of the functions of the device - No dashboard, not via network environment. Not even the blue operation LED was on. The mainboard seems to be dead.

My conclusion was to open the case and disassemble the HDD and to put it into a SATA-USB 3.0 Dock. I installed a Live Linux on a USB Drive and checked with Parted Magic if the drive was still functional. Luckily it was and my files were still there.

I went to the IT shop again and bought a two bay NAS which I’m currently installing. The WD MyCloud case will find its way to eBay while the WD Red Drive will still be used. Hope everything works out as planned. Scary Experience… Thanks for your support.

OK, If it were me and I had gotten this message (mine) and the first suggestion could not be done then I would move on to the second one. However, you are saying he can’t do that because the My Cloud Dashboard controls his Mac Airport Router.

If the second had worked then maybe he could have gotten to the Dashboard to perform number one and three.

Julian_82, were you able to get your issues resolved? I’m having similar problem and am considering the method that you took to resolve.

Yes, no data was lost. I disassembled the MyCloud case and bought an SATA/USB Adapter to retrieve the data. Still using the HDD in a 2-bay NAS. Works flawless since early 2016.