Flashing blue light

Well the flashing yellow light is gone now that I have the unit connected directly to the router. Strange how it wouldn’t let attach it to a network switch…But anyway, I now have a rapidly blinking blue led power light, the other 2 LED’s are not lighting up. It’s been like this for 2 days now. What could it be??

Flashing power LED is normally just when powering up / updating firmware, I wouldnt expect it to continue for very long.

Can you access the admin console via a web browser?
Can you see / access the drive from your PC (or whatever device you are accessing it from)?

It has blinked for 4 days. I can’t see it or access the admin console. It’s like it’s not even there!!

I assume you have tried a reboot?

If yes, have you tried the 4 second / 40 second reset options using the reset button on the back?

Both will do different resets but will only impact the system and settings, it will not impact any data.

Yes, I have tried both, and neither one does anything. I have unplugged it, held the reset, and plugged back in while continuing to hold the reset button. I have held the button for as long as a minute and a half, and NOTHING. I talked to WD support yesterday, and they told me that it was “configuring” or something along those lines, and it could continue in this state for up to 7 days! So I guess I just need to be patient and wait and see if the problem solves itself…

Good luck.

Configuring for up to 7 days seems excessive, but best to give it the time if that is what they are suggesting!

Pretty sure that’s not true.

Does it continually reboot? Does anything display on the LCD?