NEW My Cloud EX2 Ultra - Power LED keeps blinking blue, unable to detect it

Hi, got a brand NEW My Cloud EX2 Ultra + 2x2TB WD Red drives (pre-installed).

I wanted to set it up but the Power LED keeps blinking blue (both HD leds solid blue) and I can’t detect it.
I tried to solve the problem with the long reset: pushed the reset “button” with a pen while power cable of device was plugged off, than plugged in the power cable (also tried when device was completely plugged off) while still pushing the reset “button” for at least 40 secs. Unfortunately my problem was not solved. After the 40 secs (even 60 secs) the device didn’t give me any visual or audial feedback that the reset was successful. The power led keeps on blinking blue.
After the “reset” I waited over 20 mins but still: The power led keeps on blinking blue.

Have I performed the reset correctly?

What else can I do? Can I upload a new firmware if it is defective?

Thank you.
But how long can a “file system check” take? I left it process (if it is that, what it is doing) for hours! The device is brand new. I expect no data except the OS on the hard drives…

Hi Karakosta, how did you get this resolved? How long did you have to wait in order to get the File System Check process to complete ? I have the same problem and been waiting for hours. I have a 8 TB empty hard disk and taking so long. No chance of reset or other.

Hi, no answer yet.
Had to send it back. Had no chance to solve it by my own. Sorry…

My blue light’s been blinking for a week. I’ve tried resetting but like Karakosta, there was no indication that it did anything at all. Just kept on blinking. I can’t see WD My Cloud in the list of connected devices either on the Asus browser tab ( or in the command window after arp -a. Rudy wrote back from WD with a list of
questions and I wrote back with these answers:

• What is the Operating System of your computer? windows 10 enterprise
• How is your device connected to the router? Explain us the topology. ethernet connection to Asus RT-AC3200 Wireless AC 3-band Gb Router router
• Are you able to access your device? NO!
• Are you able to access the dashboard of your device? NO!
• Is the Internet connection working fine? Yes
• Have you tried changing Ethernet cable? Yes
• Was the device working fine before? Since how long are you facing this issue? Yes, up to a week ago.
• Is the power adapter working of your device? Blue Light is blinking so I guess so.
• Screenshot of the error message, if any. No message of any kind.

I think it’s time to rip out the hard disk and hopefully recover my files, then get a new NAS device.

So I know this is an old topic but exactly the same problem has happened with me. Constantly flashing blue and nothing I do can get it to work or be recognised by the router anymore. Tried different Ethernet cables and plugging it elsewhere in the house but to no avail.

My question is, did any of you manage to resolve the issue? I only received this product less than 24 hours ago so hoping if can’t be fixed then to send it off for a replacement but just wondered if anyone had any solutions?

Same here. Directly after FW update.