Firmware 2.41.116 for Gen-2 appears to be "OS-5" - what's the deal?


I currently have a Gen-2 My cloud device with a bunch of data on it, (as I have referenced in other postings), and today I boot it up and get notified that there is a firmware update to firmware version 2.41.116. I click on the “firmware release notes” link within the dashboard and I get taken to the OS-5 page.

Further research disclosed that - apparently - the 2.30.181 firmware in my unit is apparently now considered OS-3.

Reading the OS-5 pages indicated a number of things, not the least of which is that the upgrade is a one-way process, that it replaces “the entire Linux kernel” and makes significant modifications to an otherwise working box.

Things that jump right out at me when I read this:

  1. WD is still supporting and upgrading the My Cloud - at least the Gen-2 versions.
  2. This is a MASSIVE upgrade that claims will take (at least) 15 minutes + after the update just to re-configure the beastie.  (Think migrating from Mint 18.2 to 20.1 - all at once.)
  3. Much functionality has changed.  For the better?  Dunno.

I’m trying to read the “FAQ’s” but they sound more like advertising than serious information.

Does anyone here know what the Real Deal is with this update - BEFORE I throw caution to the wind and upgrade?  Does it really fix anything?  Does it address any of the issues people have been raising about this device since The Fall of Rome?

I’m going to hold-off for the time being, especially since I don’t know how to back the update out if I do the upgrade and later decide I can’t stand it.

What say ye?

“I boot it up” translates to “I keep the device shut down and powered off until I need it for something, then I boot it.” It can be off for months and months at a time, then I’ll power it up and use the heck out of it, and then power it back down and let it collect more dust. . .

Use the forum search feature, magnifying glass icon upper right, and search through the OS5 subforums. PLENTY of discussion on the various issues and problems with those devices that support OS5. Further there are several discussion in the OS5 subforum on how to roll back to OS3 firmware.

OS5 Subforums

User of the second gen single bay My Cloud always have the option of using one of the unbrick methods to roll back to the OS3 firmware. For example:

Couple of discussions on OS5 that are in this My Cloud OS3 subforum (again found using forum search).

And if one checks the WD Support Knowledgebase articles they’ll find a number of articles and issues related to OS5:

My Cloud OS 5: Feature Differences Between My Cloud OS 3 and My Cloud OS 5

My Cloud OS 5: How to Update From My Cloud OS 3

My Cloud OS 5: Online User Guide and Solutions

My Cloud OS 3 to My Cloud OS 5 FAQ

My Cloud OS 5: Firmware Availability and Supported Devices

Much more in the Knowledgebase:

1 Like

OK, works for me - I can deal with that. I don’t know what I was doing differently, all I got back were WD’s FAQ’s about OS-5. . .

The link in the text file ( is a “dead” link that returns a “placeholder” site hosted by

I found a copy on GitHub located here:

It even has a copy of the original text file with the instructions.

Looking at the “feature differences” between OS-3 and OS-5, it looks like OS-5 tightens up security but removes a lot of desirable functionality.

Wtf am I getting this email for

Have not the foggiest. . .

Perhaps you were “watching” a thread that was referenced by, or linked to, in this posting somewhere?

Anyway, humblest apologies for disturbing you.

Or just see the directory for all of Fox’s gen 2 single bay files:

The forum sends an email or notification if someone posts a link to one’s post in another thread discussion. You are getting one because I linked to one of your posts (the thread Help with piece of junk OS5) in an earlier post above.

Having perused the various links and such you provided, (thanks!), I am still puzzled somewhat.

Correct me if I am wrong, but my takeaway from what I see is the usual fussiness that happens on any forum where people are trying to figure things out, along with a few “This is a piece of GAGH!” posts that, (IMHO), translate into “You expect everything to be perfect all the time. Can I have some of your drugs?” (:wink:)

However, what I have not seen is any definitive status:

  • Is the upgrade worth it? (i.e. Do the benefits outweigh the risks/annoyances?)
  • Does it address any of the fundamental issues that have plagued the Gen-2 since day one?
  • Or is it just more of the same in a different pretty-colored box?


You didn’t disturb me. I have no idea why I would be getting these emails I don’t subscribe to WD even tho I have a piece of ■■■■ OS5 on my NAS. I have fixed it myself waiting for WD is a joke anyway. Again no disrespect to any of you I have also unsubscribed to this and I still get emails. Plus I don’t know why all of a sudden I started getting these like I mean today. Just is weird anyway I will try again with the unsubscribe oh FYI. Try to lean some linux google some scripts ask on a Debian forum to fix the problems with OS5. It’s pretty easy to do I am a linux admin certified engineer this WD NAS is a script playground try it out

Good luck all

Not sure what this means.

As previously indicated the the support site ( is sending you the email due to a post you made elsewhere being quoted or linked to here. You have to access your profile settings on this site ( and change your account preferences email settings.

Note the highlighted section in the above screen capture. Try changing the Send me an email... setting to Never and hopefully it will stop the board from sending you messages when others quote threads or posts you have made to this community support site (

You may have missed the fact in some of those articles and posts, that WD removed a number of features and apps that the OS3 firmware had. While you may not use them or see them as important, others were using them and lost them with no (apparent WD) replacement. That is what some are complaining about. Others have had their unit bricked after applying firmware OS5 update. The indexing (just like it did on OS3) is apparently causing issues for some in OS5. Others are apparently having trouble getting the apps installed in OS5 (they’re not showing up properly apparently). Smartware and WD Sync are not supported in OS5 so users either need to move to Goodsync or use third party alternatives.

Is the upgrade worth it? That is entirely subjective. As you can see (if you read through the OS5 subforum), some have not found it worth it to upgrade and want a way to downgrade back to OS3.

Does it address any of the issues in OS3? Only you can answer what issues you wanted fixed. They apparently have carried forward issues with indexing and the inability to shutdown the My Cloud (some indicate they apparently call it “hibernation” in the OS5 Dashboard). Until someone subjects the firmware to significant vulnerability testing users have no idea if WD fixed the various security issues that were present with OS3. WD introduced new issues like the 5GB limit uploading using the web portal: My Cloud OS 5: Error Uploading Large Files in Web App

Or is it just more of the same? Much like the move to OS3, some of it is under the hood changes that users will never know about. Over time more issues, just like with OS3, will present themselves. In some cases, it’s still just putting lip stick on a pig. They can only do so much due to device limitations. Same long standing issues or features that more advanced users want (remote drive mapping for example) are apparently left unaddressed.

Personally if the My Cloud unit that supports the OS5 firmware is mission critical and is working just fine on OS3, then why upgrade right now after reading the differences laid out in the knowledgebase article between OS3 and OS5 and the issues some are having with the upgrade or post upgrade? My “wag” (wild a… guess) is WD may be setting the stage to eventually terminate OS3 support (including the OS3 portion of the web portal) all together, because they’re already putting certain OS3 My Cloud units into End of Life/End of Support status and or not including certain My Cloud devices in the OS5 update. So eventually one may not have a choice but to upgrade to OS5 on supported devices.

YMMV and all that. :slightly_smiling_face:

Again I didn’t sign up. Are we going to split hairs all day on this I’ll try again to put this on a unsubscribe but I keep getting emails from you. Kindly stop I didn’t sign up on anything


Just to clarify for anyone reading this thread and are wondering what certain posts are referencing. When one quotes or links to someone else’s posts on this forum, one may receive an email notification. There is a setting in one’s forum profile (Preferences > Email) that may control if one receives such quote or linked notifications. One can change that setting (shown in the previous screen capture) to Never and hopefully that will stop such email notifications.

One should be aware that there is also a bell icon alert setting for each thread at the bottom left of the thread. Depending on that setting one may receive emails when new posts are made to the thread. One can manually change that bell icon alert setting to Mute which hopefully will stop certain notification emails.


Note: It’s possible to convert apps from OS3 to OS5.
I can’t test it, but i thinks - it may work: Fox_exe file archive

Hi J Harris,

Devices phones, tablet that cannot be updated to the newer My cloud WD app.
These will not be compatible with the 5.11.112 and your not be able to connect using the older WD app 4.4.25

The more I read about OS-5 the less I like it.

It appears to trade something like 90% of the existing functionality for a couple of dubious security updates, fixing none of the complaints and issues that have plagued this device since day one.

Since it appears to be a gigantic step backwards, I think I’m going to skip it.

Is there a way to “ignore” the update and turn off the “!” indicator for this update?

Yes buy another NAS drive :slight_smile: or use other app’s like VLC to connect to the WD mycloud, if you update the WD firmware.
Personally I would not update for now, see how it works.
The Hardware ok, but the Software is what makes the unit work for the users.
Update OS, probably find tablets phone incompatible when using the apps WD.
Think it requires IOS 11 and above.

My two cents:

OS/5 is the ONLY path forward for WD products. Anything still running OS/3 at this point will be an unsupported legacy product.

OS/5 does fix a number of annoyances from OS/3

OS/5 does implement a number of security patches.

OS/5 is geared towards making things easier to access on the web. . . .to make that happen, there is an indexing process. This can be AVOIDED if you do not enable ANY cloud services on the device.
To be blunt. . . it does not appear that the MyCloud devices can successfully survive indexing. . . I don’t know if it is a RAM or processor issue. . .but I am not seeing any “success” stories for these boxes.
MyCloud Mirror (Gen2) devices seem to survive. . but indexing will tie up the unit for WEEKS. More advanced/powerful nas boxes do better

OS/5, being more web orientated, does some things that a privacy minded person may find objectionable.

Overall: If you have a MyCloud Gen2: Avoid this upgrade.

1 Like