WDMyCloudPR2100_5.18.117_prod.bin isn't a firmware file?

I’ve gotten email about OS 5 for several days, so thought I’d do it. I’m on 5.13.115 and the new one is 5.18.117. I used the Update Now button and it started the update at 98% done, which I thought was odd, but maybe there’s a background download, so I let it complete. Well, after 10-15 minutes, it died. Tried it again, no dice. Tried a 3rd time, still failed. So I found a link to the the firmware file and downloaded it for manual update. It loads to 100% then says the “firmware file is not found”. Rebooted the MyCloud and tried a different copy of the firmware file, same result. I downloaded the first one with Edge, the second with Chrome. They are identical.
What gives? How do I get the update? Do I need to download interim levels to move forward and if so, where can I get them?

Hi @Rayda,

Please refer to the below link to download firmware:

For more information, please contact the WD Technical Support team for best assistance and troubleshooting:

So I spent about an hour in a chat on this web page.
I downloaded the firmware file twice during this chat. Neither copy would load using the ‘manual update’ function.
We also tried the ‘4 second reset’ then the ‘40 second reset’. No go.
My best guess is that 5.13 to 5.18 might be too large a jump, but I don’t know that of course. It doesn’t seem that 5.14, 15, 16, or 17 are available to download individually so that I could just step forward with each update one at a time.
I’m also willing to try ssh and run any Linux commands from the console session if there are any suggestions for that.
As a member of the drive’s firmware team I’m perfectly comfortable attempting this (the actual drives, not the Cloud unit).


The 5th image above is from after the 40 second reset. The unit displayed this almost immediately upon trying the update, then stayed at 98% for several minutes, then posted a failure. I don’t think you can get from 5.13 to 5.18.