Finder and Word crashing while saving a document


I’m working on a Macbook with OS X Yosemite installed. I habe the newest firmware installed on my My Cloud EX2. Approximately every time I save a word document to the cloud storage, Microsoft Word was crashing. The rainbow circle is spinning all the time. After closing Word my system (especially the finder) is crashing too. Restarting the finder didnÄt work. It won’t come up again. Only a hard reset of my laptop solved the problem.

Has anyone else out there the same problem?

Working with the cloud is nearly impossible…

Here is an error report from the dashboard. Bizarrely, the IP in this report varries from the IP given from the router…

2015 Feb 15 16:27:12
OTHER ORION_LOG /var/www/rest-api/api/Auth/src/Auth/User/UserSecurity.php ISAUTHENTICATED [ERROR] dbgvar0: Array\n(\n [RequestScope] => RequestScope Object\n (\n )\n\n)\n

Thanks for your help!

I haven’t had this issue nor do I have a Mac or know anything about this issue with a certainty. But based on the error message and your comments, there’s just two possible reasons I can think of that’s causing the issue:

  1. Perhaps your EX2’s IP is now different after EX2 reboot and your Mac is still trying to reach it at its old IP. To avoid that, you should assign a static IP for your EX2 on your router…though I am not sure if that is indeed the issue, and I think your laptop is connecting to it (and therefore finding the right IP) given the log entry but since you mention about a different IP, it is best to assign EX2 an IP statically on your router. There are other ancillary benefits than just (perhaps) a fx for this issue.

  2. A more likely cause based on the log entry looks like there is some user authentication issue. Not exactly sure how you are connecting from your Mac…I don’t have a Mac nor did I install any software when I bought my EX2…I connect to my EX2 from Windows using Samba (CIFS) service and never needed any addtional software to connect locally…though almost every customer do install the provided WD’s “cloud” app. So if that app is being used on your Mac as an added layer to connect to the drive instead of direct network access, then it could be playing arol in this issue. I wouldn’t know a thing about the app as I never installed its Windows equivalent.

Thanks for your help!

  1. The IP in the error log is the IP of my laptop. After changing both IPs to static and changing the protocol from afp to smb, the problem ist still there.
  2. Yes, the cloud app is installed. I’m only able to reach the NAS when the computer is in my own network. Reaching the cloud from outside is more difficult to install. Installation of the app is more simple than installing a remote connection, because I need a DNS service. This method seems to be more difficult.

Yesterday, I tried using OpenOffice. While using the app, saving a document was much faster than saving a word document. And no crashes!

Anyway, there is a problem with the user authentification that you mentioned in your post. Maybe anyone else has a solution.