File creation date?

I’m hoping to use my EX2 to sync pictures from my phone and make them available to my pc’s. The old OS didn’t work. It tried and failed. (but at least the file dates were right.

I’ve gone to OS 5 and jumped through all the hoops to get it working and accessible.

I installed the new app on my android phone. (the old app had never been installed on this phone) and enabled “camera backed.”
It copied 1367 files really quickly.

I opened the shared folder in windows file explorer, and ALL THE FILES ARE DATED TODAY!!!

If I open a file in windows image viewer, and get info, the correct date is there.
If I use… it’s the same thing. The directory shows all files dated today, even though when I display a file and get info, the correct date is there.

This is useless.

I have to do my wife’s new computer and her new iphone. 7000 pics on the iphone, 55,000 to move from the old computer to the new.
They can’t all get today’s date!

1 Like

nope. I’m not nuts.
If I create a new folder on the ex2, and copy a bunch of files from my pc to it, all the files retain the original creation dates.

If I attach my phone to the pc with a cable, open a window with the phones pics and another from the ex2 and drag files from one to the other, they have the same original correct dates.

It’s only when the “camera backup” function of the new “OS5 MyCloud” android app copies the files that the file date changes to when it was copied rather than when the original picture was taken.

1 Like

Yes, you are absolutely right: I have the same problem:All photos, that are backed up by my cloud os5 android app get the date of “today” instead of the original file date. Would appreciate, if a member of wd could set this “urgent” on the open topic list for the wd os5 app


No kidding.

This fundamental flaw in functionality has been present from the start of OS/5. . . .and has never been acknowledged as a fundamental issue that basically is one of several reasons a number of people consider the app useless.

Unfortunately, it seems, there are no WD representatives reading the threads…

Same problem here with file dates.
Also the very handy slide show function of the app (only android version not IOS, WHY?) has gone.
This would be ideal when showing pictures on your tv.
WD claims OS5 gives you better multimedia support…
Not being able to sort and arrange files is the very backbone of data storage and completely ignored by WD so it seems.

Really seems, that there is no WD-representative willing to take this essential problem on a open topic list.
This makes me sure, that was the last WD product, I purchased…

WD Community,

If the file does not contain EXIF data, the data cannot be extracted for any reason, the files creation date is used in the mobile and web client apps. To view and find more information regarding media files, please refer to Answer ID 2745 How to Find Detailed Information About Media Files

My Cloud OS 5: Photo and Media Content Are Not Correctly Sorted

Answer ID 30288

Dear @WDStaff,
Here you can find an example where the picture date is marked as yesterday while in the exif data the creation date is on August 2012.

Can you confirm why in the mobile and web client the date is not taken?


Please contact support, provide the system logs from your My Cloud device, mobile app logs and the media in question so that it can be analyzed by our team to determine the issue.

Thank you for the reply.
I’ve opened #211127-000181 but in the form i can’t find any way where to attach system logs.

How should i sent them?


Is the implication here that this phenomenon; which has been noted by numerous users since day one of this product, is not known to the software team?

For sure the software team need clear non working examples to debug the problem that is affecting most of us.
I’ve upload system logs and the picture files in the support request. I found that with tools suggested here in the post of 23 Mar from WD staff the creation date in the EXIF datas is not properly read.

Using Jeffrey’s_EXIF instead the creation date is there.

I hope this could be useful to @WDStaff to adjust the current software :wink:

I found maybe the guilty field. Image on the left have the Data taken filled with the date of the shoot, while the picture on the right have that field empty. Anyway, as you can see in the previous postl, the data could be took from the field GPS Date Stamp.

I am going to ask a Noob question:

I don’t seem to have this problem when I copy files off of my phone using Win10.
Somehow, I don’t think windows is going into the EXIF data to find date created and date modified information.

What is different here that makes it so useless?

Please do not try to pass this off as a “phone problem”!

In the previous version of WD’s software, before OS5, the camera backup function worked just fine. Photo’s came over correctly sorted by the date the picture was taken.

OS5 uses the date the backup was run.

EVERYONE has this problem.
Attempts to split us up are not required.
Previous attempts of mine to do so have been ignored, I’ve opened a number of support cases, been told anything from “need additional info” to “your WD drive is out of warantee, sorry”

Again, this problem only happens when a phone is “Attached” to the W-D with the camera backup function, on the initial backup.

It is not a phone problem and it is not a problem of the backup. I didn’t use the backup-function from the My Cloud-App. I copied the Photos with the App FolderSync. Some Files are shown as the belong to the Date of the copy, some other are sorted to the correct Date in the MC-App.
What I found out on two samples:

Filename: IMG_20210531_153913.jpg
Shown as picture from 24.Nov.2021 (date of copy to the ex2ultra)

EXIF-Information (only that ones with “Date” in Tagname ;-)):
exiftool IMG_20210531_153913.jpg | grep Date
File Modification Date/Time : 2021:06:02 18:17:00+02:00
File Access Date/Time : 2021:06:02 18:17:00+02:00
File Inode Change Date/Time : 2021:06:02 18:17:00+02:00
Modify Date : 2021:05:31 15:39:13
Create Date : 2021:05:31 11:35:10
Date/Time Original : 2021:05:31 11:35:10
Profile Date Time : 0000:00:00 00:00:00
Create Date : 2021:05:31 11:35:10.583756
Date/Time Original : 2021:05:31 11:35:10.583756
Modify Date : 2021:05:31 15:39:13.583756

(stat IMG_20210531_153913.jpg):
Access: 2021-06-02 18:17:00.000000000 +0200
Modified: 2021-06-02 18:17:00.000000000 +0200
Changed: 2021-06-02 18:17:00.000000000 +0200
Creation: -

FolederSync keeps all the Date/Time-stamps in the EXIF-Tags and the Indodes. The only difference I found to the pictures wich are correct assigned to their creation-Date is the ICC-Profile in the EXIF-data (here the Profile Date Time). This Tags are only in my false ordered pictures, but until now I don’t know if in all of them. And up to now I don’t know how to remove or set this date correct. ExifTool says, I am not allowed to write or delete that tag.

It is not a issue of the backup-function of the MY Cloud App, cause I have the same Problem but don’t use that function.

Hi all, seems that this topic is becoming hot avain :slight_smile: i hope for the right time

From what i’ve understood the date of the media gallery is extracted from the service restsdk-server for all images stored under each shared folders.
Under the main forlder of my disk i found this folder restsdk-data/data (80GB :scream:) containing a db file and thousants of other files under restsdk-data/data/files/[1-z]/ containing i guess the preview of the picture to be shown in the media gallery.

So, also reading my previous posts in this topic, seems that some EXIF datas are stored in the picture in a different way that the restsdk service is expecting. This cause that some pictures are sorted by the correct date and others are stored with the storing date. In both cases two different files are showing the right date checking details with a Android phone.

@mija: have you tryed to check on IMG_20210531_153913.jpg the EXIF datas with
Answer ID 2745 How to Find Detailed Information About Media Files
and with
Jeffrey’s_EXIF? Are working both?

@WDStaff: which should be the right date label of the EXIF that is taken from the restsdk? And please, don’t close my support request with a “sorry, your WD drive is out of warantee” :wink:

Thanks all,