Faulty MyCloud, lost data?

I have a 3TB My Cloud, OS3 I think (I’ve certainly not updated it).
I have had it plugged directly into my router and mapped as a network drive for, years really.
A couple of weeks ago I wanted to copy off some folders with photos to a laptop (Win10 Home)
Part way through the copy the drive became ‘unavailable’. I tried to reconnect which worked briefly and I noticed that some of the folders had disappeared. Really bothered about that as these photos are important.
It lost connection again and I was unable to get access to the drive through any of the standard routes.
I have bought an external case and put the 3TB drive into this.
Although I can’t see this via Windows, I have plugged it into the USB port on the router and I can see into the drive. The problem is the layout does not show any obvious ‘files’ so I’m guessing there is some WD special internal formatting/file system that has the data held in a different form.
The drive is approx half full.
How can I recover the data first, and then maybe recommission the drive. But the files on it are by far the most important.

The My Cloud is designed to use the Ethernet port not the USB port for device access. The My Cloud USB port is for attaching external hard drives only.

What color is the front LED on the My Cloud?

Can you access the My Cloud Dashboard using a web browser?

How to access the Dashboard on a My Cloud (single bay) device

How are you accessing the My Cloud (when it is connected to the network router), are you using Windows File Explorer?

On Windows, is SMB 1.0/CIFS enabled?

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Hi, The MyCloud has been successfully networked to my system using the ethernet port for many years. It was mapped as a network drive to enable easy access and file sharing. I could also access it using the dashboard if I needed but i always chose to use Win File Explorer and look for the mapped drive. I am not trying to access the drive through the drives USB port at all. Because the drive became inaccessible via File Explorer and also the dashboard access, I removed the drive from the WD housing and fitted it to an external drive case with power. This allowed me to plug it into the USB port of my router which can at least see into the drive but without the WD controller card.

Because the drive uses EXT4/2 Linux File System/Partitioning.

Plug it into a PC running Linux or Windows with a Bootable Linux Live CD and you may have a chance at retrieving your data.