Extremely slow performance on WD20EADS Caviar Green Drive

I have 2 HP Personal Media Drives, both with the 2TB WD20EADS Caviar Green Drives. They were bought online together (in December 2010) and arrived on the same day.

Both drives would originally transfer data at 30+MB/s, whether connected externally, or within the drive bay designed for the Personal Media Drives.

Suddenly, one of the drives will not transfer data any faster than 3MB/s (<10% of its original speed), and frequently has UNBELIEVABLY slow performance. (See images below.) The slow drive has been used very rarely for system backups. (I mount the drive in the internal drive tray, conduct the backup, then remove the drive. MAYBE 500 hours of total run time.) The fast drive has been used whenever I’m not doing a backup to the slow drive.

Sometimes the drive is so slow to respond, it makes the system appear to have hard-locked, until I un-plug the drive between constant (and intermittent) activity. CPU Usage is negligible.

Does ANYONE know what causes this? I saw another post that recommended using wdidle3.exe; however, the WD site warns that it is only to be used on a certain range of drives, of which the WD20EADS is NOT listed.

ANY help is appreciated!


The image of the benchmark for the newly glacially slow drive.


Performance of the other drive, and what I expect from the slow drive with an identical setup.

System Specs:
Intel Core i7 920 (8x2.66GHz)

9GB DDR3 Ram

Windows Vista Home Premium 64bit

nVidia GTS250

+all service packs, system updates, and current motherboard, video and sound card drivers.

You can use wdidle3

I just don’t think this will work in your case but it would not hurt to try

make sure to backup all data before the update

you can also test the drive with other utility and replace it the behavior continues

I’m in the middle of a backup, but at 2.5MB/sec, backing up the data that’s on it will take me weeks as I don’t have 2TB free to dump the data onto.

I’ll give wdidle3.exe a try when that’s done and update you. Thanks for the input!

Sounds like it kicked down from USB2 to USB1 speed. I just had this happen recently with 2 WD20EADS HDs. I switched to a different brand enclosure (Rosewill) and my speed returned. You could try that.

I have a Kingwin 2.5", 3.5" and SATA combo device that allows me to power up and connect any external drive and plug it in via USB. That was the first thing I tried, but I get the same results.

Actually, I’ve been copying files off of the drive, and the slowest sustained transfer rate was 32KB/sec… far below even USB 1.1 speeds. It’s around 98KB/sec sustained as I’m writing this post.

Is it possible that the on-drive cache has blown up? I just re-ran the WD Data Lifeguard Tools, which normally shows the drive as “PASS” with a green checkmark, but now gives “FAIL” and says it cannot read the drive’s SMART information.

It sounds like the drive is dying badly, and I have limited time until it goes into “clicky death” forever, but the drive is less than 2 years old, and I’ve easily doubled the total run time just in the last week now that I’m trying to back up the data from it (due to its horrible slowness). WD refuses to warranty a drive that was purchased by any OEM, regardless of age.

Any other thoughts or suggestions?

Sounds like it’s dying. Transfer as much of the data off of it that you can. Drives can die at any time. WD is only warrantying these drives for 2 years now. I had a batch of 500Gbs that died on me from 6-18 months. I had to take the remaining ones out of service because I didn’t trust them anymore. If it dies on you completely, you can try pressing on the motherboard and the connector underneath the drive. Someone wrote on this forum that that worked for him. Some people have had success freezing the drive (put it in a Ziplok bag first and get all the air out). I’ve never tried it. But it sounds bad.