External HDD connected to USB on My Cloud has corrupted data

I have an external WD HDD connected to the USB ports of my My Cloud Mirror Gen 2. The other day I browsed a few files on that external HDD when I tried again an hour later I could no longer access some of the files. I ejected the USB (properly through the My Cloud OS) to see it if would improve the situation but no luck. I even did a full restart of the My Cloud system but no luck either. I safely ejected the USB again and then connected the external HDD directly to my Macbook. It found the storage but couldn’t access the same files as I couldn’t when connected to USB on the My Cloud. (Interestingly, some files are fine, so it is not that the HDD doesn’t work altogether.) I ran Disk Utility on Mac to check the health of the HDD and it gave a message that the HDD needs to be reformatted and advises to copy over data to another storage.

The problem is I can do this but will lose data. :frowning: As some of the folders that certainly had data in the past now show size 0, so this won’t effectively copy any data.

Any thoughts why this happened?

Is it me using the NAS wrong? In that case I’d like to understand what I should do differently. Starting to lose trust in the My Cloud reliability. :frowning:

Hello,

Please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/12455/