External FTP access to MyCloudEX4100

Hi all,

I’m attempting to get external FTP access running on my recently purchased MyCloud EX4100.

The box is up and running. I have configured my router to open ports and forward them to the appropriate internal static IP. Under cloud access in the settings menu it is reporting ‘Connected’ and ‘Port forwarding connection established.’ I can access the control panel by using my public IP and login. I can access FTP inside my local network. Most things working!

However, I cannot access FTP through my public IP. FileZilla will connect to it, but then it will hang when trying to retrieve the directory listing. This is vitally important as external FTP access is to be one of the main uses of the NAS.

Could anyone offer any assistance? Setting up FTP servers is new to me, I’m reading in some places you have to open ports for passive mode (the EX4100 seems to only offer passive rather than active mode transfer) but then I’m seeing others says opening more ports isn’t necessary.

Hi @Shane_Malone

You have to open only Port 21 for Passive Mode. If you open more ports, then it would be active mode. Foroward Port 21 ONLY from the router to the My Cloud. If you want to use restricted access from any web browser, then the URL should be

ftp://username:password@public-IP/sharename

Hi Joerg,

Port 21 is open. I have also enabled FTP servers behind my router before. I seem to be quite limited in the options I can apply to the FTP service in the admin panel.

Hi @Shane_Malone

OK, let’s fire up the truck and cycle through the whole stuff step by step :smile:

Prior to the following, you have to enable the port forwarding inside your router. The example below is bound to port 21 only for Passive Mode FTP.

Entry point is the web interface of the My Cloud at Settings -> Network

FTP Access ON, then “Configure>>”

First page of the FTP settings with limitation of the amount of concurrent connections, Idle time of open conenctions and standard port (don’t change this):

Next screen, Passive Mode; best experience if you don’t change anything:

next screen, fine tuning:
Client language deafult is UTF-8 support, best experience to keep this “as is” as almost all characters are supported. Personal tipp: Switch ON the FXP, File Exchange Protocol for the best performance, otherwise the FTP daemon will not use the full bandwidth (important for internal network FTPing)

Add-on to the client laguages, there are much more supported than UTF-8 only:

Last page of the settings, blacklisted IP addresses an exclusion period:

blocking period can be adjusted:

So far, so good, but we shall open the Port Forward rules too. Therefore scroll down to the end of the Settings -> Network page and open the Port Forwarding:

Click Add to open and stay on “Select the default service scan”:

Select the FTP service for port 21 only - this is the FTP server in passive mode. If you want to enable Active Mode FTP server, you have to enable port 20 here too. Not recommended unless you know why Active Mode FTP shall be used. Active Mode FTP does not mean that the FTP will work faster than passive.

Click Finish and wait until the rule is applied:

If your port forwarding rule in your router was configured correct prior to the steps described here, then you will see the Status message “Success” if you click on “Details”. This will check if your FTP server can be reached from outside your network:

I am still trying to get this to work externally. EX2 Ultra.

Every screen is setup exactly as above - I connect fine but times out on directory listing.

Router is a Netgear R7800 and port 21 is forwarded (and obviously working or I would not be able to connect at all).

But the “test” on the EX2 Port Forwarding setup fails…

I was told that for TLS, PASV connections i still need to forward port 990(?) as well… any truth to that?

Not sure how to post screen shots or I would…

Fixed my own problem… I had to configure custom ports for PASV on the EX2 and then make sure that range is forwarded on my router… DOH!