Help with FTP

I’m having some issues with setting up the FTP so that I can access my WD remotely.

I have enabled FTP access in the dashboard settings and port forwarded. I can access all my shares through FTP when I type in the URL: ftp://(my external ip). However, I’m unable to download anything! Would really appreciate some help here. Thanks. 

Hi randenius, welcome to the WD Community. See if the following links help. 

How to access data using FTP on a WD Personal Cloud drive and other WD NAS devices

1 Like

Thanks Jubei. I have followed both guides but it still does not work. 

Btw, I forgot to mention in my initial post that I can download the files only if I access the FTP through my local IP:


As I have mentioned before, I am able to access all the shares if I enter the FTP through my external IP. The issue is that I cannot download any files.

You need to open the port 21 on your router to the port 21 of nas first. It’s called port forwarding. Get to know your router brand/model then Google on how to port forward with your router brand/model. Each router differs.

Hello Nazar, I have already done that at the beginning.

I have checked that if I close the port 21, I will have no access to the FTP at all. With the port opened, I am able to go into the FTP server and see all the shares, but I cannot download anything.

Oh ic, try to connect in passive mode or active mode vice versa. Are trying to access from browser? Have you tried from a client such as WinSCP?

Would you be able to guide me to connect in active mode? I do not know how to do it.

So I’ve downloaded winscp and tried googling how to do it, and what I did was to uncheck the passive mode as shown in the picture.

It doesn’t solve the problem though. Are there anything else I need to do to connect in active mode?

Anyway, I’ve played around with the ftp client and found out that I can actually transfer small text files from my computer to the FTP server and vice versa. However, if I try to transfer anything else, connection would time out. Furthermore, I am able to delete any files too. Hopefully these information would be useful.

Active mode doesn’t require additional setups. It’s by default transferring data in active mode when you use CLI clients.

Passive mode on the other hand requires additional port(s) to be configured and port forwarded for data transfer. The client will issue PASV command to initiate this. The port range needs to be port forwarded and the server config will also need to specify the port range eg. /etc/vsftpd.conf:

pasv_address=ip/host of external IP

If you’re able to transfer small files then this shouldn’t be the issue. I’m not sure though if your ISP is the cause of this.

Would you be able to test SFTP instead?

I’m not sure if I’m doing it right… What I did was to enable ssh in my WD setting. In winscp, I change the option for connection from ftp to sftp. 

However, I am unable to connect through my external ip, only through my local ip.

You’ll need to port forward port 22 for ssh/sftp.

Yea I forgot to mention that I have already opened port 22 on my router along with enabling ssh in my WD setting.

Any error? If just timeout, double check your port forward. You could use online service to check if the port is open.

Just to let you know only root is able to ssh/sftp. If you need other users to login you’ll need to modify “AllowUsers” the /etc/ssh/sshd_config file. Either append the usernames space separated or comment out to allow all. I would also suggest that you set PermitRootLogin to no or at least to without-password(via key exchange) else your root will be vulnerable to internet brute force attacks.

It just timed out.

I have checked my port using with no problem.

Btw, my sshd_config doesn’t have the option PermitRootLogin. I also just realised that I have created this thread in the wrong forum: I am actually using a My Cloud Mirror. I guess I’ll have to post this issue in the right section.