Help with FTP

I’m having some issues with setting up the FTP so that I can access my WD remotely.

I have enabled FTP access in the dashboard settings and opened port 21. When I connect to the FTP through the external IP, I can access all my shares using a client or browser. However, it seems that I cannot transfer most files except for small text files. Another thing that I can do is to delete files, but that’s about it.

I have no problems when I connect through my local IP.

Anyway, I have posted this issue some time ago in the other section of the WD community:

until I realised that I have been posting in the wrong section.

 Would really appreciate some help here. Thanks. 

Have you tried different FTP clients? They all have different features and limitations with regards to uploads and file management.

1 Like

Yeah, I’ve tried filezilla and winscp and also windows explorer by typing my IP in the folder. However, they all timed out when I try to transfer any other files besides small text files.

Would someone please help me out with this issue? Thanks!