EX4100 Can't see in my Cloud, but can reach via network share

I have a EX4100 that is connected to my network. I can get to it by using fully qualified path (Name or IP Address) and all the subfolders within it.
Yet when I got to the “My Cloud” app, the NAS shows up as “Offline”. Display on devise says it is in standby mode.
I can’t get to any of the settings pages to try and make changes. When I try via the app I get a message saying “Unable to connect, check it isn’t rebooting or unplugged”.
I have all 4 bays filled and lights are all good.
Not sure what to do here?
Thank you for any help.

Exact same problem here but with a WD 3TB My Cloud Personal Network Attached Storage. Were you able to enable cloud access on your local device dashboard (accessing the device via the IP address on the browser)?

I can’t get to settings in any way. No matter how I try I get “Device offline” message in browser.

Do you have a specific link in mind? If I try and get to my just by using IP address or device name, I get nothing. When I go to “My Cloud” I see both the devises I have , but can’t get to this specific one. Other one works fine.

Follow the guide on this page to access the dashboard
My Cloud OS 3: Access the Dashboard on a EX4100.
Once you’re logged in try to find cloud access (look at the screenshot on step 4). I believe you need to sign in to your cloud account to enable access

Logging into the server is the first part of the issue. I can’t address you provided and going to IP doesn’t work. I get a “Site can’t be reached” page.

If I go to file explorer and browse to \ I can see all the shares on the server and browse them as normal.


Very likely your IP address is wrong or you’ll have to set it as a static IP address on your router

I know for a fact that the IP is correct. I looked it up in my router. And as I said before if I go to file exporter and hit the shares using IP I get them.

Also, if I can’t get into settings to make a change, I can’t change to static IP.


That’s really strange. Maybe try downloading WD Quick View and accessing the dashboard from there

I understand that you’re experiencing connectivity issues with your EX4100 NAS device. Here’s a similar situation that you may be facing: Despite having a properly connected EX4100 NAS on your network, you’re unable to access it through the “My Cloud” app, which shows the NAS as “Offline”. The NAS itself appears to be in standby mode according to the device display. When attempting to access the settings pages through the app, you receive an error message stating, “Unable to connect, check it isn’t rebooting or unplugged.” Despite all four bays being filled and the lights indicating normal operation, you’re unable to make any changes or access the NAS settings.

That pretty much sums it up.
Have any ideas?

So you can access shares via Windows File Explorer, but you can’t access the dashboard using the same computer?

  • To state the obvious: I presume EVERYTHING (PC, Router, NAS) has been rebooted?
  • To state the obvious: I presume you are using one of the public domain addresses; (192.168.xx.xx or 10.10.xx.xx) and not something unique and weird(like 123.45.67.xx)
  • Have you tried another PC?
  • In windows file explorer, have you tried using the ip address both way (i.e. \\192.168.xx.xx and //192.168.xx.xx). One will yield the shares, the other will yield the dashboard.


Basically: Yes to all your assumptions.

Details one by one:

Yes, all devices rebooted individually and as a whole (All devices rebooted at same time)

Yes, using 192.168.1.X subnet

Using file explorer: This is where it get interesting. I have 2 cloud devices, both are EX4100’s.

Device 1: I can get to the share using \<Share Name> and by \<Share Name> both of those work just fine. I can add, remove and update files on the share. Web interface from the same computer doesn’t work, by IP or name.

Device 2: I can get to via the web interface but not via \<Share Name> nor \<Share Name>

When I do login to “My Cloud” I see both devices, I can update/control Device 2 as much as I want. Device 1 has a status of “Offline” (Having been up for a month or 1 minute doesn’t seem to change anything).

Using My Cloud app on my android phone, the issue is the same, I can get to Device 2: Add, remove, update files. Device 1 has status of offline. I can see that it exists in interface, but it is not accessible.

They both used to work fine. I don’t remember exactly when they stopped, just degraded over time and “I’ll need to fix them”, turned into a few months.


I’m assuming Device 1’s firmware is all up to date. WD restricted “My Cloud” devices from using Cloud unless they are on the lastest firmware.
Have you tried soft resetting Device 1? I fixed my “My Cloud” cloud issue by soft resetting (the reset that doesn’t remove user data)
Sounds stupid but try to disconnect Device 2 from your network and only have Device 1 connected and see if it works after a soft rest.

All firmware is update as far as I can tell. As I can’t get to Device 1 via the web interface, I haven’t tried a reset.

I have tried disconnecting Device 2. By powering it down. My cloud showed both devices being offline.

I have been able to determine why I can’t get to Device 2 from my local network. For some reason, which I haven’t figured out yet, it is on 192.168.68.x subnet…more fun down the road for that one.


You don’t need to access the web interface for a soft reset. Have a look at How to Reset a My Cloud EX4100 Device | by rahmanarif | Medium but do some research and googling first to make sure it doesn’t wipe out your user data.
I would suggest trying the 4 second reset first to see if it’s fixed. If not try the 40 second reset.

On the right track. . . . .

. . . .I agree with soft reset.

. . . . .both devices want unique device names and unique IP addresses on your network. I like assigning IP addresses FROM THE ROUTER to avoid silly problems. I have not tried NAS units with duplicate share names. . . .I can imagine the system being confused if you do that.

Just curious: If you log into your router, can you “See” the device from the router? Are you sure it is being assigned a valid IP address?


I have the exact same problem.
Cant access configuration, I get “This page isn’t working192.168.1.111 is currently unable to handle this request. HTTP ERROR 500” every time.
But I can access every share I have via windows network or samba in linux devices.

I have some differences from everybody because I know there were some power outtages and some of the bootings may have been interrupted… Maybe the EX4100 had some problem during one of those boots.

Another clue I have, is that the name of the device changed to the default.

Can someone make something out of this?