EX2 Ultra not updating

My ex 2 ultra currently sits on fw version 5.16.105 even though auto-update is set to enabled. When I try to force an update to 5.18.117 (as it is suggesting me to update) the download will start smoothly but then stop at the 20% point. Keeps doing this multiple attempts but keeps stopping at 20%. Fairly sure it probably is something trivial but have not been able to find a olution online yet … Advice is highly appreciated.

Is it done indexing?
Did you try to restart it?

Yes I have restarted .but no improvement there … Last time I saw the indezing progress it was still indezing … but for some reason do not seem to be able to find any reference to indezing anymore in Mycloud ? Not sure whether I am just looking at wrong place or whether it would mean indexing is done but update still hangs at 20% download

Maybe router and upnp?
Did you try manually? (With the downloading of the update first.)

Connection status is reported as relay as isp router does not support uPNP but that has not hindered with previous updates. I have downloaded file called WDMyCloudEX2Ultra_5.18.117_prod.bin from Mycloud website but when I push that I get following error message.


You should get in touch with support. @WDStaff

Good luck!

Ok thanks austin … submitrted the Question to support let’s see…

And the outcome is… ???

I’m very interested too!
The update on my EX2 ultra seem blocked.
Download without problem and then updating stopped at 0%.

2 hours passed: the admin panel says that no action could be taken when firmware upgrade is activated. The problem is that 2 hours passed… and so i cannot reboot, and i’m very frightened!!!

edir: Be patient. It took several days for the update to complete on my 4TB MyCloud (the actual update was not too bad but the indexing and other changes took forever).

Ok but on the firmware tab i see the old firmware number and cannot do anything… is it normal?

Hmmmm… OK, well, if the update didn’t take, give it till tomorrow then do a 40 second reset.

Is it safe? I prefer to remain with old firmware that risk (in this period of year) to remain without nas.

Thank you

Yes, a 40 second reset is safe. And it’s going nowhere right now!

It’s 16 terabytes. I’ll wait some days then a reset. Thank you
The ticket to WD is unanwsered after 2 days…

Had a (fairly useless) standard reply from WD support with ifo about updating from OS3 to OS5 but no indication that the original text I sent them (basically same I posted here) had been read before replying. Even had a link to describe how to download and install manual where I already mentioned I had tried that, including downloaded file name… So still not any firther will also try 40 sec reset probably.

Has anybody had a resolution to this issue? I am now two versions behind on my 16TB model on OS5. Tech support advises to “wait” my other WD unit was deemed unable to upgrade to OS5. I even went as far as factory reset after using the 40 sec reset method. Not very happy right now.

In the event someone is experiencing the same problem still, the solution is to remove both drives, remove the button cell battery in the device, replace it put it back together then reboot. The auto download will now pass the 20% plateau and upgrade to the latest OS version.

Thanks @Disgruntled1 Disgruntled1 would love to try this fix just wondering is there an instruction on how to replace the battery. It is somewhat awkwardly positioned and can’t quite see how to remove the battery (once removed I will be fine getting it back in I guess)

The mention of the battery was never provided as a fix to me by WD support, I was going to replace my unit with a new solution as the drives were still operational, when I took them out of the enclosure inside there is a CR2032 you can’t miss it, you can see it I believe in the center, use a precision flat head to pop it out from the metal copper side it is a little tough and be careful not to break the clip popping it back in was easy, this I am guessing clears the memory of the corrupted firmware.