EX2 remote help!

Let me preface this by saying that I am fairly tech savvy but this is my first venture into NAS/networking.  I apologize in advance for the lengthy post but it has allowed me to collect my thoughts!  

I just purchased, received and hooked up a new EX2 on Wednesday 4/2/2014.  I hooked everything up according to the instructions that came with the drive.  When I am on my home network it seems to function flawlessly.  I can access the dashboard, change settings in the MyCloud, etc.  It doesn’t seem like I have any trouble within my home network accessing the cloud.  Just for the record after setup I have three icons (internet shortcuts) to the WD MyCloud EX2 learning center, WD MyCloud EX2 Dashboard and the WD MyCloud EX2 Public Share.  I also successfully setup my account to use wd2go.com 

  1.   I have enabled cloud access through the dashboard as I plan to use it remotely while I am at work (I am a teacher).  I was able to set up my android mobile device to access the mycloud and it functions correctly, even remotely.  I cannot however access the EX2 remotely from my windows based PC.  When i follow the directions provided in the “WD MyCloud EX2 learning center” to set up cloud access it tells me to download the WD MyCloud Desktop App.  I click on the link, download it but nothing happens.  Either it’s not installing fully or has already been installed on the computer.  It ends the installation process saying it is complete but I can’t find any evidence of it on my computer (unless it’s related to the three icons I referred to earlier).  

  2.  When I go to wd2go.com and login I see my EX2.  When I click on the picture of the EX2 or on tab labeled “shares” it takes me to a screen that says “Get Apps” and won’t let me go any further except to download software.  What’s up with this?  I thought that was how I was supposed to access the EX2 remotely outside of my home network??

    I am able to access the MyCloud via the mobile app remotely when using 4G or through WiFi at work.  

    I know WD has had a major issue regarding remote access and I saw the sticky at the top of the forum.  Is this the         source of my problem?  I read through almost the entire post but couldn’t find a clear answer.  I probably just               missed it…

  1.  How do I wake this thing up remotely when it’s in powersave mode?

Sorry for the ramblings.  Just very frustrated.

Hey below is an answer to your questions as best as possible. If you have any other dont hesitate to ask as I have spent many hours on the phone with tech support getting my regular MyCloud and EX4 set up just right. 

  1. I had the same issue with my Windows 8 and was able to finally get it installed by going into settings and control panel and removing all WD software seen in there. I then made sure I was completely to date software wise and then downloaded the software from  http://support.wdc.com/product/download.asp?wdc_lang=en&fid=wdsfMyCloud_EX2 and it worked. 

  2. The web page is very misleading as it only works for the original mycloud for some reason. There are two ways around A) the desktop app & B) the dashboard web view app. To do the web view app you would need to have the dashboard accessible from outside the network set up. 

  3. When the device is in powersave mode all you have to do is make a connection ie open the MyCloud app to see your shares or mount the drive. This will wake the device up immediately and you will hear the drive spin up and the light begin to blink if you are nearby. 

Thank you for your reply.  

I actually had already tried that.  I deleted anything related to WD or WD MyCloud that I could find both by searching, manually scanning throught the programs installed on the HD and I even scoured my registry keys to see if some a fragment of the program was still left and causing a problem.  I redownloaded the software from the website and still no change.  It prompts me to accept permissions which I do.  Then it claims it has finished installation almost instantly.  I click finish and nothing happens.  Nothing shows up- no new programs installed, etc.  It’s driving me CRAZY!!!

Meanwhile I went through and double checked the ports in my router and made sure they were open.  Everything looked good. 

I also stumbled across these instructions:


After following these instructions, I am able to access Mycloud dashboard by my windows 7 PC when I am not on my home network (using the mobile hotspot on my phone).  This leads me to believe it’s more of a software issue at this point.  Any additional suggestions??  

At this point I don’t even care if I use the “MyCloud Desktop App”- I just want to be able to freely access my files remotely.   I did manually map my EX2 to access using windows while on my home network.  

On a side note- thanks for escalating my case to the second tier.

I played around with the EX2 all weekend trying to get it to work properly.  I have made a few observations that might provide a little insight to the solution. 

I was able to use my wife’s computer over the weekend.  I downloaded the MyCloud desktop app, successfully installed it and accessed the MyCloud EX2 through the desktop app.  Additionally I was able to use the desktop app to upload and back up much of her data from her computer.  Everything functioned perfectly on her computer as I presume it should.  Additionally I downloaded the Smartware software and was able to set her computer up to back up successfully automatically.  

We are both running windows 7.  The problem lies on my end.  The only WD software I have been able to install was the intial setup wizard that helps set up the drive itself on your home network.  Even though I have repeatedly tried to clean my system of all WD software in order to reinstall it, I have yet to have any luck for ANY of the software products made by WD including the desktop app, quickview, and smartware.  

This morning at work, I wasa able to succesfully access the MyCloud through my browser by using the instructions above.  This leads me to believe it’s purely a software issue on my machine.  

How can I completely scrub my computer of all WD software so I can hopefully reinstall it and fingers crossed, it works?  I have deleted everything manually that includes the name “Western Digital” or MyCloud without any success.  I am guessing I’ll have to dive into the registry to properly remove everything?  HELP!!!  

On a side note- I could care less about using the acutual WD desktop app software if there is a way around it.  I don’t know much about networking but if there is a way I can access it through windows explorer while being remote that would be perfectly fine.  I did map the drive using windows explorer to access while on my home network but it only shows the “public share”.

Thanks again!!!

I first had a similar problem mapping the ex2 as a drive, for some reason it sets the default password to be blank as the main administrator. Maybe try using the user name admin and blank for the password. Hope this helps

Special thanks to Luis at WD tech support for contacting me and getting this resolved. 

As I mentioned earlier, I had isolated my problem to a software issue on my computer.  I was able to install the WD software onto another laptop at my home but unable to download it and install it on my personal machine.  We ended up copying the entire folder and it’s contents from his machine directly to mine.  Luckily it worked indicating you don’t have to go through the install package.  

Thanks again!!!