EX2 file download stalls after a few MByte

new installation of EX2 a week ago (firmware 2.10.310), local network access only (typically no internet access) - cloud services turned off, just a shared drive throughout the network for sound and image files, also turned off power saving all configurations have the same problem:
Was able to upload 100GByte of data, but when I try to copy for example a folder with 1GB of image files, transfer will stall at the end of a file after a few MByte, I can finish the download if I either click through the directory structure on EX2 in fileexplorer or play a long sound file in the background. This is very consistent either when connected to a Win8 PC therough gigabit wireless router/switch or a win10 laptop and totally different router/switch in a different location.

Is this something with my specific unit - has anyone experienced or fixed same?

Web Interface and user control were set up and I can map the drive.
Thank you,

Hello, how is the CPU load on the drive? What type of files where you transferring? Was the drive doing something else?

it indicates low load.
The files are a mix of mostly images (5MB) and small html files, but it happens with any type, I tried large sound files as well - same problem, when leaving it alone it will stall.
The drive was not connected to internet, no backup is configured.

Hi, I would try resetting the drive by pressing the reset button in the back of the unit, this will not delete the information but the settings will need to be changed back. I would also try to zip at least 1 GB into a zip folder and see if the same thing happens. I would also try the WD My Cloud desktop application and see if it happens the same.

Hello Iluna,
thanks for your consideration -
I have narrowed it down to a set of .html files (as small as 0.5MB), which cause this weird behavior.
I can copy many Gig of data until I encounter some of these files.
Turning Norton network or other protection off did not change it, others recommend on the internet to try NETBIOS over IP, renaming, re-locating, all with the same result, about 70% is copied (or opened) then stalls unless I browse the NAS files or play back a NAS sound file in the background

  • I opened two support cases with WD and uploaded the file, but sofar no response.
    I will have to return it, as this is not reliable enough, who knows which other files would cause the same issue -

The same files and folders copy/open fine on an older WD NAS, but it was getting too small. Installing custom s/w is not really an option throughout the network, nor would it be necessary for just a Network drive, no (I will not use the cloud feature)?