WD MyCloud copy issue

Today I wanted to copy 2gb large file (.avi) from my work (via wd2go.com) to my mycoud 4TB at home.

File started to copy quite fast (I have optical connection), but than, 5 seconds before end, it stopped and went nowhere.

I left it stood more than 10 minutes, than I cancelled the operation and repeat it but without any sucess.

Than I tried to copy some small .pdf file, and it worked flawlessly.

Is there any filesize limitation? or what can be done?


Unless your internet speed for the entire path is greater than ~30mbit/second, then you didn’t wait long enough.

When you copy files via WebDAV (which is what WD2go.com uses), FROM your PC TO your NAS, the initial fast speed is actually just Winodws copying the file (locally) to its cache.

Then it will appear to hang (in fact, the windows will often say “Not Responding”) while the copy moves from the cache to your NAS.

there also seems to be a bug with files over 250MB, at least for me they will sometimes copy but many times will just continually send data but never finish.

I started trying to pin point the issue but have not had a chance to get back to it.

I would let it go at least twice the time required for the slowest link. If you hit the bug above you won’t be able to cancel and will need to reboot the PC

On both ends there is 20/20 Mb/s speed.

2GB file should be copied within “seconds”, but it hangs on last 5 sec forever. I left it for hang 20 minutes, no change…

So, this got to be some Bug.

WD, pls comment.

japke wrote:

On both ends there is 20/20 Mb/s speed.  2GB file should be copied within “seconds”, 

Your math is very wrong.

With 20 Mb/second internet speed, it will take 14 minutes … and that’s assuming you get full entitlement of that 20Mb/s speed the entire time.

Seldom does internet speed remain constant – I would expect such a file to take 30 minutes or so.

While you’re copying, open the Windows Task Manager and open the network tab.  You’ll still see your network moving data.