EX2 Dashboard Problems

I’m really pulling my hair out on this one.  I just bought the EX2 today, set it up and actually got some files uploaded to it.  Then I realized I hadn’t set it up as RAID0.  I don’t need mirrored backups and wanted to have a full 8TB available for my media collection which I already have backed up on external 4TB USB drives.  

So I launched the WD MyCloud EX Dashboard application from my Windows 7 desktop (I have the latest update for Java and I tried this both under the latest versions of both Chrome and IE 11). I also have my machine directly connected to my Gigabit ethernet router with Cat 6 cable.

So it launches fine and brings up the following screen:

Of course this is the screen you want to see.  Then I click on storage and get the following…

Then I click on the Change RAID Mode button and get the warning pop-up…

Everything is fine until this point.  But when I click OK, I get the following dimmed out screen…

If you can’t see it in te pic, it’s the pop up window showing the 4 different RAID options (JBOD, Spanning, RAID 0, RAID 1) and then it just hangs.  Nothing I can do until I refresh the tab and then it takes me back to the home screen.  It turns out that any time I do something on the dashboard that requires a window to pop it, this happens.  I tried to update the firmware and the same thing happened.  I actually was able to get the firmware updated via my iPad app.

I’ve tried factory resetting the NAS, turning the NAS off and the router off for 30 seconds and turning them back on, and restarting my computer (now twice) and nothing seems to be working.

Customer support was completely useless.  Their outsourced level 1 support had no idea where to even start with me.

Any  suggestions would be greatly appreciated.


Ok.  An update.  I was able to get the dashboard to work in Chrome on my MacBook Pro.  Wow.  What a complete cluster.  I am still seriously considering just returning this thing.