Error while using UpnP

Hi, my wd my cloud doesn’t work when I have enabled the UpnP in my router.
When I have enabled UpnP, my router show me ports forwards as OK, and my cloud show this message: Port Forwarding Connection Established. But I can’t have access my files using website wd2go, and app wd my cloud.
I only can access my files, if I disable UpnP in my router and the connection is connected and the message is: For best performance, enable UPnP on your router to establish a direct connection.

What can I do to fix my problem?

I’ve had a similar problem. It seems to be that a reset to the router disturbs the port forwarding connection method, possibly due to the router’s external IP address being changed by my ISP when it reboots.

I found that turning cloud access off and on again restored the remote access (until the next reboot).

Relay mode connection seems to cope with the router reboot; I suspect the WD server is effectively providing a DDNS service in relay mode, that fails in port forwarding mode.

All this using the WD Apps, rather than the service, but I’d guess the mechanism is the same.

I don’t enable UPnP on my router; I don’t want software to be able to autonomously open holes in my router’s firewall.

I suspected that might be the change of IP by my ISP. This function should works well only in static IP.

In my friend’s house, He has static IP, and works fine. In His house, he has better performance than in my house.

Probably because WD should use DDNS as you said.

Thank you. I’ll leave uPnp disabled, is more safe.