"Error occurred while creating the backup folder"


#1

after Time Machine completes a back up and everything is fine. Time Machine has the little message saying it will back up at a particular time and when it tries to backup again I receive the following message:

“Time Machine couldn’t complete the backup to my passport. Unable to complete backup. An error occurred while creating the backup folder”.

How do I fix this. In order for me to do another backup, I have to eject the hard drive and start from step 1. How do I get my passport/computer to automatically backup without getting the above mentioned error?

thanks in advance,
joey


#2

Hello,

Did you set any password protection on the passport?

Was the drive attached when time machine attempt to create the backup?


#3

Good afternoon,

I did set a password when i initially got the hard drive but i think i went back into the app and removed it. I will have to double check. The drive was attached when time machine attempt to create the backup. It works great when i disconnect and then plug it back and start a back up, it’s the automatic backups that time capsule is trying to run after the initial one.


#4

If the drive and Mac have been sleeping, then this is a similar fault to that I have seen on three recent WD drives with Sierra and Time Machine. It has been reported in a number of posts here in various forms. If the Mac is kept awake all works well but if allowed to sleep the above happens.
I had three Mybook for Mac 3TB drives before I gave up and asked for a refund. All had same behaviour on 2015 iMac on Sierra. Now using another brand drive and everything works perfectly, just as it also did on two other older WD drives. Compatibility problem?


#5

Thanks for the reply. I didn’t realize it was the “sleep” mode that was the cause till you mentioned it. That is exactly what’s happening. What a bummer. I’ll probably start looking for another brand of drive now too. Lesson learned I guess. Tried going the less expensive route and got what I paid for.


#6

I was having the same exact problem. I am running Mac os Sierra 10.12.3 on a late 2015 27 inch iMac 3.3 i5. I tried every repair on line that I could find at no avail. Then I noticed that my machine was doing backups in the middle of the night and that the failed backups were during this time period. I turned of Enable Power Nap in the Enery Saver settings in the System Preferences and have not had a failure for 10 days, this was happening daily. I don’t now why this remedied the problem but I can live without downloads, updates, backups and notifications while my machine is sleeping until the real problem is found. I hope this will help in some way


#7

Good Morning,

will definitely give this a try.

thank you


#8

I didn’t want my hard drive to run continuously so this worked for me on my macOS Sierra 10.12.5:

  1. Eject then unplug My Passport for Mac.
  2. Deselect Automatic Backup in Time Machine Preferences.
  3. Shut down then restart the computer.
  4. Plug in My Passport for Mac.
  5. Do manual ‘Back Up Now’ in Time Machine.
  6. Set weekly (or more frequent) reminder in Calendar for manual backup.

#9

I have the same problem under 10.12.5. “An error occurred while creating the backup folder.”

WD Disk Utilities do not seem to work on this version of Sierra.


#10

I have spent 6 hours with 3 different mac specialists trying to sort this out and it still does not work with auto backup. They have tried numerous things and work arounds and non have worked. So who’s problem is this? Is it a flaw in the macs communication or is it WD problem with their hard drives. I will try turning off “Power Nap” and see if that works. I really hope that I will not need manually backup all the time.
I have turned off power nap and still having same problems. Arg!


#11

I have tried turning off power nap. Still fails on every backup.
Running High Sierra 10.13.1

Has anyone solved this for High Sierra?


#12

I have exactly the same problem. Have wasted quite a bit of time running Disk Utilities, reformatting external WD drive, etc. I have been using a My Passport drive for Time Machine for at least 4 years without any previous problem. Any suggestions very welcome before I buy a new drive.


#13

This is the error message
i get …

"Are you sure you want to erase the backup disk “easystore”? Erasing will destroy all information on the disk and can’t be undone.

The disk must be erased before it can be used for Time Machine backups because it has an incompatible file system."

… so why would I ever want to erase the backup disk!!?


#14

My WD was working great until I updated the MAC to OSX 10.13.2 and now get an error message. it is constantly trying to back up and fails. I contacted WD support and they told me it was Apples problem, not theirs. My Mac is working fine. I don’t see anyone here who has solved their problem except some work around for manual back ups. I want the service that I paid for. I wonder if the warranty is any good?


#15

I went through that process when i set mine up and thought the same as you. Anyway i did what they asked to format the disc for my mac and it worked fine until i upgraded to OSX 10.13 .2 . So I am in the same boat as the other people in this forum with no apparent solution.


#16

I’m having the same exact problem … and their website/ contact point is
useless!


#17

The real question is, I suppose, is why do they bother to have this forum if there’s no one from the company that reads the feedback … They got our money, that all that counts!


#18

I sent them an email and told them that I had been in the forum and that there were many no apparent solutions to this problem and that I wanted to return the unit under warranty. To my surprise they answered immediately with the return policy and disclaimers about lost data. Looks like they have given up. Anyway i followed the process to do manual back ups and it is in process as we speak. This whole thing is scary. Fortuneately I only use it for back up purposes and not my main files. I no longer feel secure as I did about external hard drives. Espeically WD.


#19

I also have the same situation.In order to back up I have to eject the passport ,physically unplug it -wait a bit-then plug it back in and then I can do a manual backup-after that it will not auto back up it is a major incoveniance and has turned me of anything to do with WD I will try to find something that will work with my Mac[10.13.3]


#20

Solved for me! Was having the same problem. Tried many things, including turning off power nap. Would work for a while then get the error regarding not being able to create the backup folder. Finally, I (re-)launched the WD Drive Utilities app, selected “Settings” (the gear icon), and then turned OFF “Sleep Timer.” It was on (30 minutes) by default. I have not had the problem again for several days.