Issues with Time Machine - new backup must be created


After long struggle with setting up My Book Live for Time Machine in Mac OS X, I have finally managed to do so.

I have backed up two Macbooks and everything seemed to be successful, however, after 2-4 hours (I believe that during the next backup window) I have received an error on one of the Macbooks that:

“Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.”

Then, Time Machine erased my backup and started over! I’ve searched through the internet to find the reason and solution for such error, but was only able to find that this happens occassionally and non-Apple solutions are usually not recommended for Time Machine. It is also the best to have a wired connection during the first backup, but I cannot do this since the Macbook that is experiencing issues is Air and there is no ethernet connection there as you know.

I would like to ask you: have anyone of you experienced such issues? There is no point in making backups when they are not reliable and may become corrupted and unusable at some point in time?

Should I give up Time Machine and start using e.g. Carbon Copy Cloner? It is a bit different and I wanted to use versions capabilties of Time Machine, but again if it is not reliable, there is no point I guess.

Is there anything I can try to have it corrected?

My setup:

My Book Live 2TB with newest firmware - 02.02.02-020

MacBook Air with Mac Os X Lion

My Book is connected with gigabit ethernet connection to a Linksys router - there seem to be no issues with connection - no disconnections, etc.

Macbook connected wirelessly


There was one other thread reported on the forums about this same issue. From our side, we did extensive testing of Time Machine and never saw this issue. If you google that error message, you will find quite a bit of information about it from Apple’s user community. To me this does not sound like something related to our product, but more of a Time Machine robustness. It may have something to do with your wireless connection causing the issue. Here is a site that give quite a bit of information on Time Machine:

For what its worth, I had this exact same issue. I have been using WD Live for about  6 months, with both a Macbook and iMac backing up via Time Machine.  I upgraded both to Lion, waited for the update, and about 3 weeks after the WD update, both declared that I needed new backups. I am not sure if this was due to the wait for WD Live firmware, or the significant changes in Lion or what. 

I am letting it run, and will monitor it over the next few weeks.

I also experienced this issue. Seems it’s really a problem of MBL. I’m using Lion 10.7.1 and the latest firmware. After 2 days of my first backup, it says “Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.”. I deleted all my Time Machine backups and re-backuped, 3 days later, it appeared again.

Now I have to use Time Machine with a USB WD Elements, and this dialog never showed.

I browsed some other NAS forums, and seems it’s a common issue for all non-apple NAS and Lion. There may be some problem with the current Nettalk(afpd) which all non-apple NAS uses.

I have the exact same problem. I have a MyBook Live and a MacBook Pro. Everything was great with Snow Leopard, but as soon as I upgraded to Lion I got the verification error. Since Lion and the newest MyBook Live firmware 02.02.02-020 it has been impossible to keep a reliable backup for more than 1 week, rendering the drive useless. 

If there isn’t a fix on the way you should let us know and refund the drives so we can go buy a Time Capsul. 

I am successfully backing up a MacBook Pro to a MyBook Live via Time Machine and it has been working for almost 2 weeks.  My MacBook Pro is a 15" Mid 2010 - Intel Core i7.  I should point out several things that may be important here - 1) My MacBook Pro has a clean install of Lion.  I never backed up to the MyBook Live on Snow Leopard.  2) I am running the time machine backup manually - I click on the icon in the menu bar and say “Backup Now” - rather than allow Time Machine to backup on its own.  Today I enabled automatic Time Machine backup and will note if anything different occurs.  3)  I have not yet tested the ability to restore from the MyBook Live time machine backup.  I will do so only after I do a backup again on the Time Capsul and a full image drive copy to an external drive.  I am not seeing any unusual behavior in the backup process - it appears to behave identically to when it was backing up to the time capsule.  No validation errors and no message indicating that Time Machine has do start a new backup. 

October 7 2011 and I’m having this problem on My Book Live using firmware 02.02.02 - 020. I get the famed:

“Time Machine completed a verification of your backups. To improve reliability, Time Machine must create a new backup for you.”

It’s the second time it happens. A little tired of rebacking up (on a USB macbook air it takes forever even via ethernet). I"m on Lion 10.7.1

Does this happen only after Time Machine decides that the backup needs to be verified - the verication usually occurs if the mac has been shutdown of has been sleeping for several days and an intervening backup has not been done - so it decides to perform a long verification before actually doing the next backup?  I have not yet encountered a situation where it wants to do the verification - so it is possible that I may encounter this when that happens.

Do you by any chance have the WD Quick View app installed on your MacBook?  Quick View on a Mac places an icon in the menu bar that allows you to quickly view the health status of your WD Live drives and provides some detailed drive information - and that’s about it - but I wonder if it is interfering with the Time Machine backups?  If you have it installed - can you completely uninstall it and take notice of whether the Time Machine backup starts to work correctly? 

In my case, the laptop is being used every single day for hours. The last back up was about 15 hours ago.

Regarding Quick View, I just checked and I do not have it installed.

Time machine should be backing up every hour - if you are using the MacBook steadily - why is there a 15 hour delay since the last backup?  Unless your Mac is going to sleep each time before a backup actually starts - however - it usually starts the backup (in most cases) wihin a few minutes of waking up.

Good point. I did actually notice it early this morning so it must’ve been just after I woke it up.

You have just tipped me off to something - with your 15-hour delay in your backup.  A few days ago I posted that Time Machine was working on my MacBook Pro - to the MyBook Live - but I had been running backup manually - automatic Time Machine was not enabled.  I enabled it 3 days ago - and forgot about it - it went to sleep - woke it up - over an hour ago - and it has not yet started an automatic backup - which should have occurred within the first few minutes of wakeup.  So - I think something is not right here.  I am backing up my two other Macs to a time capsule - and that is behaving as I have been describing.  Something is different with the MyBook Live.

I stand corrected - the TimeMachine backup just ran on its own - and I am now thinking the time was just about 1 hour - and it did not perform a backup verfication and appears to have worked perfectly fine.  I will keep watching to see what it does in the next hour.

I have exactly the same issue. Using a MacBook running Lion with a MyBookLive firmware 02.02.02-020.

In my case it takes a couple of weeks before I get the verification message.

With Snow Leopard I never had any issue.

How can we find out if WD is addressing this issue with a firmware update? I’m somewhat disappointed because I gave away my Time Capsule to my sister and bought the My Live and now I’m basically without backups! Not fun.

I have still not encountered this error after backing up successfully for several days.  I even forced Time Machine to do a verification of the backup (by holding down the option key while right-clicking the Time Machine icon on the menu bar.  The verification runs normally.  Also backed up a friend’s mac to a different MBL - and the backup was actually done on top of a previous backup that was copied over from a Time Capsule to the MBL - and the backup was 100% - and it did a verification on its own - without issue.

My Mac is MBP 15" Mid 2010 - Core i7 - Lion 10.7.1  Friends Mac is MBP 13" Mid 2010 - Lion 10.7.1 - no issues.

I will continue for another week or so with the MBL - but out of suspicion of running into the problem you are describing - I will probably go back to my Time Capsule soon - as it works flawlessly.  I bought the MBL’s for purposes other than backing up my 3 Macs - so I am more or less experimenting with capabilities of the MBL at the moment.

Here is a link to an Apple support article - regarding the message about Time Machine Completing a Verification and wanting to start a new backup.

apple kb article

At least now I know that my macbook air is not to blame for the back up problem inasmuch as my daughter’s macbook has the same problem. So clearly, the My Book Live is not handling time machine back ups correctly. This is a major problem for me!