Backup fails on Time Machine

#1

I’m running MacOS 10.12 and can make an initial Time Machine backup and occasionally subsequent backups. However, within a day at most, I get an error telling me that ‘Backup Failed. Time Machine couldn’t complete the backup…’ to my 4TB WD My Book for Mac.

It’s about a month old, and this issue has been a constant: I’ve reformatted the drive, tried Disk Utility and both running and uninstalling the WD tools.

WD My Book for Mac Backup Disk Not Available
#2

I don’t have a solution, but I’m having the EXACT same issue with the same drive (My Book 4TB) on the same version of MacOS (10.12.1). Also with Time Machine (encrypted).

I bought this drive in Feb 2016 and haven’t had any issues until the last few weeks. I can reboot and get the drive to come back online and work for a few hours or days, but this error always happens again. First Aid from Disk Utility will run and fix a few things and say everything is fine. WD Utility shows nothing wrong.

So I don’t know what to do. Return the drive? I’m running a clone on a WD Passport without any issues.

#3

I’m also having the same issue, except with My Book for Mac 3TB (with iMac Mid-2011). Seems to have started when I upgraded to Sierra (10.12.1). I’ve also noticed when this occurs that the drive contents are empty (in Finder). Additionally, I cannot eject the drive (says it is in use). My Book is also unresponsive in WD Drive Utilities (does nothing when running drive status check) and Disk Utility.

After rebooting the iMac, drive is fine…Time Machine backs up properly and all is well: passes WD Drive Utilities drive status check and Disk Utility First Aid with no errors. But, after ~1 day this issue recurs. I’ve search numerous discussion boards with no solutions.

The My Book is only 3-4 months old, but I’m about ready to purchase a different external drive.

1 Like
#4

Update: I have resolved the back-up issue by uninstalling the WD Utilities program and removing other items associated with this program. There is an uninstall icon in /Applications for this. Additionally, I deleted the following that were not removed by the uninstall program:

/Library/LaunchDaemons/com.WDPrivilegedHelper.plist (this starts the WD Drive utility helper).

From the System Preferences>Users & Groups>Login Items, remove WDDriveUtilityHelper (this runs the helper when a user logs in).

After performing these actions, My Book has successfully executed Time Machine backups for 2 days with no issues.

What drew me to take these actions were:

  • Determined the issue was not with Time Machine as I turned backups off, rebooted the iMac, confirmed with Finder that I could read from My Book (Backups.backupdb folder was visible and accessible). After a few hours, I could not access My Book with Finder (no Backups.backupdb folder).
  • When automatically updating for the Sierra 10.12.2 update, an App Store notification window appeared stating “WDDriveUtilityHelper prevented updates being installed”. This was a flag that the WD utility program was the issue.
5 Likes
TimeMachine automatic backups fail
My book partitions, after Mac wakes up, look empty
#5

I haven’t been having the issue since updating to 10.12.2 about a week ago. No idea if that has anything to do with it, but knock on wood…

#6

I’m having this EXACT problem and will try Boller’s solution. It just started happening 1-2 weeks ago. The drive becomes randomly blank and unusable to Time Machine - If I eject the drive and reconnect it all is well again. I do like having the Drive Utilities installed as I have a MyBook pro connected and like to keep an eye on its health. Perhaps I’ll uninstall and then reinstall the apps to see if that works. Just updated to Sierra 10.12.5

#7

I am having this problem as well, but it started after I moved to a new MacBook Pro, from the TM backup on that very external drive. I have tried the following:

  • running checks of all three tiers
  • turning on/off the disk and the computer
  • removing the TM plist file (as means of resetting TM settings)
  • using another external drive as a TM backup disk and adding the WD drive as a secondary TM disk

No avail…

Now that I have another backup safely tucked away, I am erasing the WD disk, to reset it and redo the RAID setup. And will try again to backup, if that doesn’t help I’ll remove the WD Utils and see if it makes a difference. I’d prefer to avoid that option since I won’t have any means of interacting with the RAID setup otherwise…

It’s also extremely clumsy that the official software from WD would be so incompatible with TM, I am guessing they have tested things before launching the product…

#8

I am having the same problem on 10.12.5

split this topic #9

A post was split to a new topic: Removed post

#10

Me too… Just bought this today.

#11

Hi BollerJR,
I’ve been hunting for solutions to this exact problem with WD disks for months, finally going back to an earlier operating system. I did have the problem characterized and it wasn’t just the backup disk – all but one of my WD drives. Then I tried your solution, and it worked! I’ve tried all the permutations, and the problem seems to be gone.
Thank you, thank you. I hope your situation is A-OK as well. Thanks again.

John

#12

The problem you are facing is from the WD driver. If you look at its website the required OS for mac does not go beyond OSX 10.11 . WD software has not been updated for OSX 10.12 yet.
I was running this backup without any problem until I up graded my Mac Book Pro to OSX to 10.12. From that moment the WD back up stopped working.( I can still see my earlier backups)
WD should provide an update driver the latest Mac OSX i.e 10.12 and later

#13

I’m running 10.12.6 (Sierra). I’ve only recently upgraded.
A week or so ago I bought a WD My Book Due 12TB. I configured it as a 6TB RAID 1 then I used Disk Utility to partition it into two 3TB partitions, one of which is now my Time Machine backup for my 3Tb Retina 5k iMac.

However I keep getting a message that there is an error with my RAID, that I should launch WD Utilities and check the drive over.
Screenshot 2017-08-27 07.07.28.pdf (244.3 KB)

I do this but get no adverse reports. SMART is okay, RAID is healthy, and both drives are online. The drive itself copies and store files as expected.
Screenshot 2017-08-27 17.29.52.pdf (498.5 KB)

Screenshot 2017-08-27 17.30.22.pdf (325.2 KB)

Could this be a symptom that WD Utilities hasn’t been updated to Sierra too? It is version 2.0.5.18.

UPDATE: 24 April 2019 : WD replaced my 12TB STUDIO II with a another (16TB) device shipped all the way from California. Result: Problem gone. No issues since.

#14

Same problem here, Sierra 10.12.6 on a brand new Macbook Pro with WD Elements.

Additionally, my WD Elements has started beeping every few seconds since I think the second attempt at reformatting I did. I didn’t drop/damage the disk in any way, it’s brand new.

The beeping occurs when the drive is attached to an external Mac keyboard (also new), which is attached to my MBP via an official thunderbolt-to-HDMI+USB adapter which is in turn connected the the MBP thunderbolt (because there’s no… USB drives). Nightmare.

The beeping stops when I attach the drive directly to an official thunderbolt-to-HDMI+USB adapter (so skipping out the keyboard extension). In either method of connection, backups fail as noted by the OP.

I’ve downloaded and installed latest drivers for “Mac OS 10.12” (WD v2.1.0.166), running the WD app does not recognise my WD drive.

At this point, I’m going to try BoilerJR’s suggestion and if that fails - never getting a WD drive again. I want safety in my backups, simple!

#15

WD released new Utilities and Security software on 8/3/17. It appears the Security package includes the utilities. This is supposed to be compatible with Sierra 10.12. Meanwhile, Apple has released High Sierra and there is no indication WD has a compatible software package in the Downloads menu.
Still on Sierra 10.12.6 and using a late 2010 Macbook Pro, I installed the 8/3/17 updates and tried to run a backup on Time Machine. The only difference from the previous inability to make a backup is that Time Machine is not indicating any backup occurred, but the usual error message failed to pop up as well. I then attempted to eject and re-mount the drive. A popup error message appeared that the disk was not ejected because one or more programs may be using it. So the only option remains is to force Eject.

WD obviously could not care less about its customers. I am never purchasing anything from them again.

#16

Your original description of the problem is exactly what I could have written about my own situation. Since you posted your solution, however, on 8/3/17 WD released a new version of the utilities and security software, so I attempted using that before attempting your solution. It turns out that the installation of the new software is lacking the utilities uninstaller program. In addition, the new software release does not fix the problem. Although I have yet to try it, I believe your solution is the only solution. I do not recommend anyone download the new software release because they will lose the utilities uninstaller program.

#17

Has anyone tried simply removing “/Library/LaunchDaemons/com.WDPrivilegedHelper.plist”?

#18

I’ve just purchased a 1TB Passport for Mac (running OSX10.11.6 on a 2016 Macbook Air). Same issues as you have outlined. On the face of it this device seems incompatible with Macs…I’d find it hard to recommend this product to anyone else, or to buy another of the same brand.

Does anyone from WD ever participate in these discussions to offer technical advice?

#19

I’m glad I found this thread. I bought a new iMac 27" this summer and transferred my older WD 2TB drive over and did a time machine restore- worked perfect.In mid October started to get time machine failures and disc utility couldn’t repair, so I bought a new Mydrive from bestbuy (didn’t want to wait for delivery). Running OSX Sierra at the time.

Next day the backup failed same way. Rebooted mac, drive icon now not the time machine, but TM works. A couple of days later, same thing, reboot fixes again. Called Apple support, they are mystified. So I set my computer to shut down each nigh and wake up each morning. This works but is really awkward. So I take my chances and turn off the automatic reboot. Of course the problem comes back.

I’m pretty sure that I installed some WD software for heaven knows what reason, so I will try Boller Jrs fix tonight. Fingers crossed. If this fails I will return the ■■■■ drive and buy a LaCie.

#20

Update. I uninstalled the WD stuff as suggested. BTW there was nothing in system preferences…

I’ve now been running for five days and TM is working properly.

I strongly suggest that Mac users simply reformat the drive and don’t apply any WD software. It’s not needed and obviously can cause issues.

Thanks Boller!