Backup fails on Time Machine


#21

My Book failed after just 3 months service. I am using a MacBookPro High Sierra 10.13.1
WD replaced the drive under warranty but I was unable to mount it using the Mac Disk Utility.
I spoke to WD Customer Support. They told me to uninstall WD Drive Utilities and get a new version from their website. I then used the new WD Drive Utility to reformat the drive in APFS. Time Machine promptly popped up and asked if I wanted to use it for backups. For about 24 hours that worked, then Time Machine reported that back ups failed. I tried to use WD Drive Utilities to check the drive but nothing happened at all. I then read this thread and unistalled WD Drive Utilities using the provided uninstall program. Then I opened Time Machine from System Preferences and chose My Drive as the back up disk. The scheduled back up then started 120 seconds later.

I will report back to this thread if there is any change


#22

I was having the same problem with an addition. I tried using time machine to back up through a Netgear wireless router using their ReadyShare software on my MacBook Pro. I thought I could just unplug the drive from the router and go back to a hardwire time machine backup on my MacBook Pro. When I did this, my computer could not mount the drive to my MacBook Pro and the ext. WD drive would not recognize TimeMachine. Eventually I noticed that on the Netgear ReadyShare software, there is actually a reject drive button which I originally didn’t see. After I plugged back in the drive an ejected it properly, my computer could than recognize the Ext. MyBook WD drive.

It took me days to figure this out, so I hope this may help if anyone else has this issue.


#23

Has this worked?


#24

Yes - like I said I would report on here if it changed. It hasn’t. Backups are now being made regularly by Time Machine to My Book.


#25

thanks


#26

Just used the Boller Jr fix – got rid of WD drive utility, restarted and chose the non-time machine WD icon for my removable hard drive from the bottom list.
Backup initiated and executed successfully. I, too, will report back if I have any issues with this fix.


#27

I never installed the WD software in the first place for my 8TB Easystore HD, and I am having the same trouble.

I tried to delete com.WDPrivilegedHelper.plist, and it tells me that it can’t delete this file as it’s required by the MacOS.

I’m stumped.


#28

I had the same issue trying to use a 3TB My Passport as a TimeMachine backup. After the initial back up, it started to fail, the drive appeared empty, and I had to do a force eject. After remounting, everything was there and I could do an additional backup before it started to fail again. I went through Disk Utility and WD utilities, they fixed a few things, but after a day or two, it all went south again. I returned a 6 month old drive to WD, as they said it sounded like it was failing. It was covered under warranty. The replacement drive did the same thing, so I returned that as well. My third drive showed the same symptoms, and I came across this thread. Did the WD Utility deletions as well as all the other suggested deletions described by Boller JR, and everything is now well. I wish WD customer support read this forum, it would save them a lot of money on returned and replaced drives.


#29

Absolutely unacceptable from WDC. I fought for months on this exact issue. Tried two WDC drives. I eventually replaced the internal drive with an SSD drive, reload of MacOS. Converted old internal drive (non WD) to external USB housing and it works fine. The Passport is NOT Time machine compatible. Tech support solution was to keep Mac out of sleep mode and display on at all times. Too much time lapsed to return drive WDC refuses to do anything.


#30

Thanks for your post. I have removed the ofending utility and now the system is backing up as one would expect. Fingers crossed that tomorrow will bring continued success.

Thanks again.


#31

Just wanted to say I had the exact same issue. Time Machine backups fail a few days after installing a MyBook, it appears there are no files in the MyBook disc folder, I’m unable to eject the drive as is always “In Use”, etc. etc. I have to Force Eject the MyBook.

Uninstalling the WD utilities (using the WD uninstaller in my Applications folder) worked. It’s now been several days and I have no problems anymore.

WD support don’t seem to be aware of this still-current issue!


#32

BoilerJR, you are a lifesaver! I have had the same problem for a long time. Very frustrating. I followed your instructions and it seems the problem is solved. I have the same hardware and software configuration as you. Thanks so much.


#33

I had same Time Machine backup problem, except that steps provided by BoilerJR did not resolve my issue. However, I kept on searching and found a solution which should fix broader cases of backup failures.

Steps to fix the problem are described in Apple forum: https://discussions.apple.com/thread/7734594

Detailed steps listed on reply from tyson279.

The solution consists on turning on “console”, which will log all errors, start TM backup, at some point the backup will fail, look for error in “console” which looks like this: “Error: (-8062) SrcErr:NO Copying /Users/NAME/Library…”, then you delete the file or folder that causes the error, continue with Time Machine backup. But this time it will complete without errors!

In my case, the issue was caused by a file from an Uninstaller App I purchased from Apple App Store. It turns out Apple policy changed and they no longer allow Apps to remove files from other programs.

If BoilerJR solution does not work for you, try solution I found.

Cheers.


#34

Wow, good call FlyingCat. I found the error following the steps you described. Thanks so much!


#35

Agreed. I’m not impressed with Western Digital. Thank goodness for competition and quality testing.


#36

Hi I am new to this community and I hope somebody will answer me to a problem which seems to be not uncommon.
I have a MacOS High Sierra (10.13.6) and an external HD My Passport Studio. Time machine worked perfectly well up to a couple of weeks ago now it does not. I wanted to format it but I can’t do it. When I turn on the Mac it says (messages in Italian but I am sure you will know what it means) Inizializza Ignora Espelli. There is a main WS My Passport with a red bar in the middle on the left it says disk2s1 32 kb and on the right disk2s3 1TB. If a give a S.O.S. it says operazione riuscita (done) but if I try to repair the file system it says Esecuzione di S.O… su disk2s3 it says

Validating target…
Validating source…
The volume on device “/dev/disk0” is not of type Apple_HFS or Apple_UFS
Could not validate source - Dispositivo non configurato
Impossibile completare l’operazione. (OSStatus errore 6.)
Operazione non riuscita…

If I move to disk2s3 it says the bar is grey. Says not activated. Message for SOS is:

Riparo file system.
Il volume è già disattivato. =volume already not activated
Eseguo fsck_hfs -fy -x /dev/rdisk2s3 = running …
Il codice di uscita per la verifica del file system è 8=code for the verification of the file system is 8
Ripristino lo stato originale rilevato come disattivato. Error
Errore nella verifica o riparazione del file system.
Operazione non riuscita…

message for repair is:

Validating target…
Validating source…
Recovery partition restores can only be done on GPT partition maps.
Impossibile completare l’operazione. (OSStatus errore 22.) impossible to do the operation (OSStatus error 22)
Operazione non riuscita… Not worked

I wonder if you can give me a suggestion about how to repair/format it.
Many thanks for your answer and thanks for your time.
Carmine50